KXStudio 10.04.2 is out!

Discuss anything new and newsworthy! See http://planet.linuxaudio.org for more Linux Audio News!

Announcements of proprietary software may fit better in the Marketplace.

Moderators: raboof, khz, MattKingUSA

sgr119
Established Member
Posts: 6
Joined: Fri Oct 08, 2010 6:40 pm

Re: KXStudio 10.04.2 is out!

Postby sgr119 » Wed Oct 13, 2010 11:51 am

Now, does anybody have a clue how to enable the touch screen?

GirSalahad
Established Member
Posts: 3
Joined: Tue Oct 26, 2010 1:48 am

Re: KXStudio 10.04.2 is out!

Postby GirSalahad » Wed Nov 03, 2010 1:28 pm

Should I wait for 'KXStudio 10.04.3' ?

10.04.2 Live is running quite fast on my system - so far everything I have tried is functional...including midi hardware w/ esi Juli@ card.

My plan is to just use KXStudio :D - upgrades are brutal sometimes tho - don't want to install .2 and have .3 visions at nite.

Thanks falkTX for this fine project you have endeavored !
asus Q6600 Quad Core 2.4 Ghz 4GB ram w/ esi Juli@ card

Raul
Established Member
Posts: 11
Joined: Thu Nov 11, 2010 11:50 am

Midi

Postby Raul » Thu Nov 11, 2010 1:51 pm

Hello,
It's just because I have no sound on Rosegarden, Kmid or Kmetronome...
I'm only musician, I like linux and use it always, but I have few Knowledge on informatics. I suppose it's easy to solve but I can't.

Great job, FalkTX, on Ubuntu Studio I was going crazy with sounds!

Any help?

PD: Someone has Kxstudio on a netbook? How is it?

Thanks a lot

Pablo
Established Member
Posts: 1269
Joined: Thu Apr 17, 2008 9:57 pm

Re: KXStudio 10.04.2 is out!

Postby Pablo » Thu Nov 11, 2010 9:59 pm

Hi Raul,

Rosegarden (and the other programs you mention but I know better rosegarden) is (mainly) a midi sequencer and it does not make sounds by itself. Their midi tracks need either an external synth (which can be either hardware or software) OR an instrument plugin.

Elaborating a bit: when you launch rosegarden for the first time, If you right click on a track you have three options:

1. General MIDI Device: This is a default name and it is used for external synths. In Studio -> Manage MIDI devices you can rename it and, above all, connect it to somewhere: Either the midi connection of your sond card if you plan to use a hard synth or the input of a soft synth such as qsynth or anything else.

2. Synth plugin: This is for dssi instruments and it is the easiest way to get sound from rosegarden. Push the button "No synth" and load a dssi plugin, such as hexter or anything.

3. Audio. This is for audio tracks. Not used in your case, I think.

Cheers! Pablo

Raul
Established Member
Posts: 11
Joined: Thu Nov 11, 2010 11:50 am

Midi

Postby Raul » Fri Nov 12, 2010 2:54 pm

Thanks Pablo!
I've tried, no results, but in Kinfo centre I've found this:

Synth devices: NOT ENABLED IN CONFIG
Midi devices: NOT ENABLED IN CONFIG

Also,
On Qsynth, I have no Soundfounts... there is no sound. It's supposed that I have sound fonts somewhere on the computer?

I will use internal midi devices.

Thanks and apologizes because of my ignorance.

PD: In case that someone wants only hear a .mid file, is it possible to do this just on a media player (as on Windows with Windows media player)?

Pablo
Established Member
Posts: 1269
Joined: Thu Apr 17, 2008 9:57 pm

Re: KXStudio 10.04.2 is out!

Postby Pablo » Fri Nov 12, 2010 3:41 pm

On Qsynth, I have no Soundfounts... there is no sound. It's supposed that I have sound fonts somewhere on the computer?


Install the package "fluid-soundfont-gm" if you don't have it installed. In qsynth, load "FluidR3_GM.sf2" which is located in /usr/share/sounds/sf2/

You can get more soundfonts from the internet.

I am not sure about the othe questions. I never use a general multimedia player to play midi files and I don't use KDE.

Cheers! Pablo

Raul
Established Member
Posts: 11
Joined: Thu Nov 11, 2010 11:50 am

Midi

Postby Raul » Fri Nov 12, 2010 5:42 pm

Yes! Now it works, thank you very much

In case that someone wants only hear a .mid file, is it possible to do this just on a media player (as on Windows with Windows media player)?


Why VLC Media Player, e.g.., can play midi files on Windows and not in Linux? Is it?

Pablo
Established Member
Posts: 1269
Joined: Thu Apr 17, 2008 9:57 pm

Re: KXStudio 10.04.2 is out!

Postby Pablo » Fri Nov 12, 2010 6:31 pm

Why VLC Media Player, e.g.., can play midi files on Windows and not in Linux?

It is not exactly so, but anyway, here is a good explanation: http://ubuntuforums.org/showthread.php?t=1561490
It could be that vlc in KXstudio is ready to play midi files, but I don't know for sure.

Cheers! Pablo

Raul
Established Member
Posts: 11
Joined: Thu Nov 11, 2010 11:50 am

Re: KXStudio 10.04.2 is out!

Postby Raul » Fri Nov 12, 2010 7:22 pm

thanks Pablo for your interest and help!

tubifex
Established Member
Posts: 5
Joined: Mon Nov 01, 2010 1:34 pm

Re: KXStudio 10.04.2 is out!

Postby tubifex » Sun Nov 14, 2010 9:08 pm

Great work, FalkTX!

But now I've a little problem. Since last update the graphical driver doesn't work. Here the output:

Code: Select all

$ sudo dpkg --configure -a
Richte fglrx ein (2:8.783-0ubuntu1+rt1) ...
update-initramfs: deferring update (trigger activated)
Removing old fglrx-8.783 DKMS files...

------------------------------
Deleting module version: 8.783
completely from the DKMS tree.
------------------------------
Done.
Loading new fglrx-8.783 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.33-29-realtime
Building for architecture x86_64
Building initial module for 2.6.33-29-realtime

Error! Application of patch rt_preempt_33.patch failed.
Check /var/lib/dkms/fglrx/8.783/build/ for more information.
dpkg: Fehler beim Bearbeiten von fglrx (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 6 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von fglrx-amdcccle:
 fglrx-amdcccle hängt ab von fglrx; aber:
  Paket fglrx ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von fglrx-amdcccle (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Richte linux-image-2.6.33-29-realtime ein (2.6.33-29.1) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.33-29-realtime
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.33-29.1 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.33-29.1 was configured last, according to dpkg)
Running postinst hook script /usr/sbin/update-grub.
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.33-29-realtime
Found initrd image: /boot/initrd.img-2.6.33-29-realtime
Found linux image: /boot/vmlinuz-2.6.32-24-lowlatency
Found initrd image: /boot/initrd.img-2.6.32-24-lowlatency
Found memtest86+ image: /boot/memtest86+.bin
Found Ubuntu 10.04.1 LTS (10.04) on /dev/sda3
done
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 2.6.33-29-realtime /boot/vmlinuz-2.6.33-29-realtime
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 2.6.33-29-realtime /boot/vmlinuz-2.6.33-29-realtime
run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.33-29-realtime /boot/vmlinuz-2.6.33-29-realtime
run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.33-29-realtime.postinst line 1003.
dpkg: Fehler beim Bearbeiten von linux-image-2.6.33-29-realtime (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von linux-image-realtime:
 linux-image-realtime hängt ab von linux-image-2.6.33-29-realtime; aber:
  Paket linux-image-2.6.33-29-realtime ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von linux-image-realtime (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von linux-realtime:
 linux-realtime hängt ab von linux-image-realtime (= 2.6.33.29.1); aber:
  Paket linux-image-realtime ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von linux-realtime (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von kxstudio-kernel-realtime-33:
 kxstudio-kernel-realtime-33 hängt ab von linux-realtime; aber:
  Paket linux-realtime ist noch nicht konfiguriert.
dpkg: Fehler beim Bearbeiten von kxstudio-kernel-realtime-33 (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von kxstudio-kernel-realtime:
 kxstudio-kernel-realtime hängt ab von kxstudio-kernel-realtime-33 | kxstudio-kernel-realtime-31; aber:
  Paket kxstudio-kernel-realtime-33 ist noch nicht konfiguriert.
  Paket kxstudio-kernel-realtime-31 ist nicht installiert.
dpkg: Fehler beim Bearbeiten von kxstudio-kernel-realtime (--configure):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Verarbeite Trigger für python-gmenu ...
Rebuilding /usr/share/applications/desktop.de_DE.utf8.cache...
Verarbeite Trigger für initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.33-29-realtime
Verarbeite Trigger für python-support ...
Fehler traten auf beim Bearbeiten von:
 fglrx
 fglrx-amdcccle
 linux-image-2.6.33-29-realtime
 linux-image-realtime
 linux-realtime
 kxstudio-kernel-realtime-33
 kxstudio-kernel-realtime
$ uname -r
2.6.33-29-realtime

If you don't understand the german parts, say it, and I try to translate.

I hope, you can help.

regards tubifex

User avatar
kaimerra
Established Member
Posts: 91
Joined: Sun Jan 04, 2009 9:41 am
Location: Minnesota, USA

Re: KXStudio 10.04.2 is out!

Postby kaimerra » Sun Nov 21, 2010 8:36 pm

I tried to install a package called 3gpwiz, which pulled in a bunch of QT dependencies. It failed to fully install and now I am stuck. KDE programs won't launch and I can't install or uninstall anything. How can I resolve this? It looks like a hiccup between your PPA and the regular Ubuntu packages.

Thanks,
Brian


brian@defiant:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
libqt4-assistant libqt4-declarative libqt4-help libqt4-network libqt4-opengl libqt4-svg libqt4-test libqt4-xmlpatterns libqtassistantclient4 libqtcore4 libqtgui4
libqtwebkit-dev libqtwebkit4 qt4-qmake
Suggested packages:
qt4-qtconfig
The following packages will be REMOVED:
libqt4-multimedia
The following NEW packages will be installed:
libqt4-declarative libqtassistantclient4 libqtwebkit-dev libqtwebkit4
The following packages will be upgraded:
libqt4-assistant libqt4-help libqt4-network libqt4-opengl libqt4-svg libqt4-test libqt4-xmlpatterns libqtcore4 libqtgui4 qt4-qmake
10 upgraded, 4 newly installed, 1 to remove and 224 not upgraded.
19 not fully installed or removed.
Need to get 0B/15.4MB of archives.
After this operation, 23.7MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 315880 files and directories currently installed.)
Preparing to replace libqt4-help 4:4.6.3-0ubuntu1 (using .../libqt4-help_4%3a4.7.0-0ubuntu2~lucid1~ppa1_i386.deb) ...
Unpacking replacement libqt4-help ...
dpkg: error processing /var/cache/apt/archives/libqt4-help_4%3a4.7.0-0ubuntu2~lucid1~ppa1_i386.deb (--unpack):
trying to overwrite '/usr/share/qt4/translations/qt_help_cs.qm', which is also in package libqtcore4 4:4.6.3-0ubuntu1
Errors were encountered while processing:
/var/cache/apt/archives/libqt4-help_4%3a4.7.0-0ubuntu2~lucid1~ppa1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
brian@defiant:~$

Raul
Established Member
Posts: 11
Joined: Thu Nov 11, 2010 11:50 am

Errors since upgrade to 10.04.3 or it's me?

Postby Raul » Thu Dec 23, 2010 6:55 pm

Hello,
Gtklick worked properly before, but since Kxstudio 10.4.3 upgrade I have this message: Gtklick error: "timeout while waiting for klick to start" and nothing happens.

Now I've tryied to use kmetronome and when open Qsynth I've got this error message:
[i]"Qsynth1: Failed to create the audio driver (jack).
Cannot continue without it".[/i]

Some help, please?

Raul
Established Member
Posts: 11
Joined: Thu Nov 11, 2010 11:50 am

Re: KXStudio 10.04.2 is out!

Postby Raul » Sat Dec 25, 2010 12:43 pm

Hello, today, after an update, Qsynth and gtklick works nice!
Updated: jack2-simple-config

sic
Posts: 1
Joined: Sun Mar 13, 2011 8:09 am

Re: jack connection refused

Postby sic » Sun Mar 13, 2011 8:43 am

thank you thank you thank you. it finally works. in case others are reading. open Jack (it should open "stopped"). goto setup. change periods/buffer from 3 to 2. hit ok. press start on jack control. if it stays running, your good.


Return to “Linux Music News”

Who is online

Users browsing this forum: No registered users and 2 guests