Worse performance when power supply plugged in!

Optimize your system for ultimate performance.

Moderators: khz, MattKingUSA

Jack Winter
Established Member
Posts: 350
Joined: Sun May 28, 2017 3:52 pm

Re: Worse performance when power supply plugged in!

Postby Jack Winter » Tue Apr 16, 2019 8:26 am

You can have a look at the output of dmesg, if it contains entries saying something like thermal throttling (don't remember the exact wording) it's because the cpu gets too hot and throttles in order to avoid overheating. I have an asus i7 laptop that does exactly this, but does it when on battery too :( It's simply not able to cool the cpu enough when it's running full tilt...:S Though I prefer lower max performance to xruns...

Have a look at /sys/devices/system/cpu/intel_pstate, which contains several files that you can use to set max multiplier, turn turbo off, etc. Documentation at: https://www.kernel.org/doc/html/v4.12/a ... state.html

For instance if you write 1 to no_turbo (as root), it won't try to set any turbo P state.
Reaper/KDE/Archlinux. i7-2600k/16GB + i7-4700HQ/16GB, RME Multiface/Babyface, Behringer X32, WA273-EQ, 2 x WA-412, ADL-600, Tegeler TRC, etc 8) For REAPER on Linux information: https://wiki.cockos.com/wiki/index.php/REAPER_for_Linux

Musicteacher
Established Member
Posts: 121
Joined: Mon Nov 13, 2017 5:54 am

Re: Worse performance when power supply plugged in!

Postby Musicteacher » Tue Apr 16, 2019 1:38 pm

Hi Jack, I had answered this in the other thread (KDE for music stuff).

Of course a modern cpu cannot permanently run on the highest turbo-boost frequency. So I have made a test with prime95 do find out, what the highest frequency is that my cpu can run when on 100% multithreaded use. That is 1.8 gHz. So I have set the frequency to that value instead of using the performance-governor.

If I disable turbo-boost completely, I get 1.6 gHz only.

The only other thing that would be possible is to de-activate 3 of the 4 cores. Then the last core can run on 3.4 gHz permanently. But as music-stuff usually is multithreaded, this probably does not make sense.

Summary: Disable higher c-states than c1, keep the cpu running on a constant rate (highest rate does not really make sense) gives good audio-performance.

Jack Winter
Established Member
Posts: 350
Joined: Sun May 28, 2017 3:52 pm

Re: Worse performance when power supply plugged in!

Postby Jack Winter » Tue Apr 16, 2019 2:07 pm

I seem to have no problem to let the intel pstate driver change frequency, it causes no xruns, but of course makes it hard to compare CPU/DSP load between different scenarios as numbers become kind of meaningless.

Even my laptop is happy with changing frequencies. The only problem I have with this on the laptop is when the CPU becomes too warm and it gets throttled. Using the sysfs entries I can set the max multiplier and disable turbo. So it kind of gives me the best as much as it can run at a lower freq and still scale up without causing thermal shutdowns. The latter which is what caused me xrun problems. YMMW and all that :) Still happy you found a solution.
Reaper/KDE/Archlinux. i7-2600k/16GB + i7-4700HQ/16GB, RME Multiface/Babyface, Behringer X32, WA273-EQ, 2 x WA-412, ADL-600, Tegeler TRC, etc 8) For REAPER on Linux information: https://wiki.cockos.com/wiki/index.php/REAPER_for_Linux


Return to “System Tuning and Configuration”

Who is online

Users browsing this forum: No registered users and 2 guests