KXStudio 18.04 Testing

Official support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: ___, khz, MattKingUSA

User avatar
sysrqer
Established Member
Posts: 1811
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: KXStudio 18.04 Testing

Postby sysrqer » Sun May 20, 2018 8:33 am

I will try to test this later.

Meanwhile, what does kmix offer that the standard applet doesn't? I just installed it and it gives sliders for the same things but has less functionality.

User avatar
sysrqer
Established Member
Posts: 1811
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: KXStudio 18.04 Testing

Postby sysrqer » Sun May 20, 2018 9:07 am

falkTX wrote:the plasma applet only works with pulse, and that is the issue.


But that's what I am confused about, if I have jack running then kmix offers no difference at all:

Image

What else is kmix supposed to work with?

User avatar
sysrqer
Established Member
Posts: 1811
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: KXStudio 18.04 Testing

Postby sysrqer » Sun May 20, 2018 7:00 pm

falkTX wrote:Is that on the ISO?/quote]
No, this was inside my installation of neon.

In order to make kmix usable, you need to set an environment variable.

falkTX wrote:On my system I have this:

Code: Select all

$ cat .bash_aliases | grep KMIX
export KMIX_PULSEAUDIO_DISABLE=1


Interesting, that does change it considerably and I can see why it would be useful if you run jack all the time.

I haven't had time to check the iso yet but will hopefully in the next day or two.

User avatar
sysrqer
Established Member
Posts: 1811
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: KXStudio 18.04 Testing

Postby sysrqer » Mon May 21, 2018 7:11 am

Just gave it a quick try. It booted fine, jack was started and I didn't encounter any graphics corruption. Opened up a few programs and didn't get any crashes, although I didn't try to do much when they were open. Basically, nothing seemed unusual except the plymouth issue.

User avatar
Shupacabras
Established Member
Posts: 58
Joined: Fri Jun 08, 2012 11:12 pm

Re: KXStudio 18.04 Testing

Postby Shupacabras » Tue May 22, 2018 2:53 am

Hi.
My PC is AMD A10 3Gb Ram
Video Radeon R7 onboard
Audio Behringer UCA222 and HD audio onboard
SSD Disk


1- start normally
2- Jack works correctly on both audio interfaces
3- No graphic problems
4- Everything fits normal without slowdowns
5- Muse is not starting

User avatar
thetotalchaos
Established Member
Posts: 146
Joined: Mon Sep 29, 2014 8:29 pm
Contact:

Re: KXStudio 18.04 Testing

Postby thetotalchaos » Wed May 23, 2018 8:26 am

The network didn't start. I am using dhcp connection, but not only the network manager didn't autoconnect as expected, but i didn't managed to start it throughout the whole session.
#systemctl start NetrorkManager and #systemctl start dhcpcd, didn't do anything.

I am not sure that the system makes sure that your soundcard is your main audio device on boot, instead of alsa-loop or for example the camera or the midi keyboard. Here is more on the topic:
https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture#Set_the_default_sound_card

Also the cpu governor is set on powersave by default, while performance is recommended for a realtime audio computing.

Jack seems to work fine. Unfortunately the problem with pulseaudio bridge defaulting on maximum outputs instead of 2-Stereo is still persistent. The solution is to limit the jack outputs to 2, while a scenario with pulseaudio outputting 2 or manually defined channels is entirely possible.
I couldn't manage to test some vulnerable apps like the web browser because the lack of internet connectivity.

In conclusion. This system in this form is not ready. There are places for improvement. Things that are an integral part of the out-of-the-box linux audio experience.

Keep up the good work falkTX,
cheers,
Totalchaos
Check out my latest music album The girl with the stars in her eyes
https://totalchaos-music.bandcamp.com/album/the-girl-with-the-stars-in-her-eyes

busuttils
Established Member
Posts: 3
Joined: Sat May 26, 2018 3:29 pm

Re: KXStudio 18.04 Testing

Postby busuttils » Sat May 26, 2018 3:45 pm

HI, Thanks for the great work.

My setup:

Fujitsu Esprimo Silent PC
Core 2 Quad Q8400
84GB RAM
M-Audio Fastrack pro 2x4

Testing:

No issues on boot
Cadence used to configure Jack 44.1k 256 Sam 2 Buffers, Asla and Pulsaudio -> all working

Guitarix
Hydorgen
Carla w Calf plugins and gx plugins all worked

Had problem with my new Wifi adapter (but I know I need to integrate it into the kernel later)
Used my old Wifi adapter (Realtek Semiconductor Corp. RTL8187 Wireless Adapter
) and it works.

Had to setup DNS by editing /etc/resolv.conf

Just added

nameserver 8.8.4.4


to the file. Network worked after that.

Will continue testing.

Cheers and thanks again.

Rodney
Established Member
Posts: 30
Joined: Mon May 28, 2018 3:56 pm

Re: KXStudio 18.04 Testing

Postby Rodney » Mon May 28, 2018 4:01 pm

I tested the ISO and I loved it! It's very stable and everything seems to work just fine. Congratulations for this awesome work! Can't wait for the actual release ;).

Cheers,

Rodney

millerthegorilla
Established Member
Posts: 70
Joined: Wed Oct 26, 2011 11:22 am

Re: KXStudio 18.04 Testing

Postby millerthegorilla » Sat Jun 16, 2018 10:24 am

I'm testing it on two machines at the moment, an Imac27 and an Acer desktop.
On the imac, which as usual I have to start with nomodeset, I can't connect to the internet. The network connects ok but Firefox fails to find the address.
I tried adding DNS info but to no avail, and I wonder if it is due to the Mac address randomisation that has been a problem. I shall try and find out more later.
The other problem that I had with the Mac was that after successfully connecting to my usb soundcard with cadence, I then tried to connect to the digital onboard Mac, out of curiosity and jack could not start. I checked the logs and then cadence crashed when I selected configure.
The error was a dbus.proxies.introspect.error did not receive a reply - tryCloseJackDBus() failed.
The iMac is connected to the router via WiFi, but the Acer is connected via cable and there is no interface showing at all in Network manager and there is no ifconfig tool available so I can't say much more.
Apart from that it looks fine and seems to work well. It's nice to see it coming together.
Ubuntu studio have just announced that they will drop support for 32 bit and will use plasma for their next release, and fedora jam are already using plasma, so there is some homogeneity I guess. Have you considered supporting one of the other distros like Ubuntu studio instead of maintaining a separate distro? Just out of interest, it seems like a lot of work plus the repos and software that I think is an invaluable addition to Linux audio.

millerthegorilla
Established Member
Posts: 70
Joined: Wed Oct 26, 2011 11:22 am

Re: KXStudio 18.04 Testing

Postby millerthegorilla » Fri Jul 13, 2018 2:44 pm

For anyone who has had problems connecting to the internet via wifi using the livecd, the file /etc/resolv.conf is a dead link.

The best thing to do is to make a new link to point at /run/NetworkManager/resolv.conf

So, the following commands :
sudo rm /etc/resolv.conf
sudo ln -s /run/NetworkManager/resolv.conf /etc/resolv.conf
sudo systemctl restart networking
sudo systemctl restart NetworkManager

That should fix it, I think. It works for me.

millerthegorilla
Established Member
Posts: 70
Joined: Wed Oct 26, 2011 11:22 am

Re: KXStudio 18.04 Testing

Postby millerthegorilla » Fri Jul 13, 2018 5:09 pm

Hi FalkTx,

I have been using the live kxstudio today and there are few, if any problems, once I've run an update, which installs mostly ok. It seems that a lot of neon issues have been sorted out.

If I try and install it, are there likely to be any boot issues or other problems that I might run into?
I'm reasonably competent with Linux, having used it for over ten years at a reasonably technical level.

Cheers

User avatar
sysrqer
Established Member
Posts: 1811
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: KXStudio 18.04 Testing

Postby sysrqer » Fri Jul 13, 2018 8:23 pm

falkTX wrote:Neon repos are ready for 18.04, so a installable beta ISO will come soon.

Oh really? Are they rolling that out to stable soon?

stanlea
Established Member
Posts: 550
Joined: Wed Apr 25, 2012 9:49 pm

Re: KXStudio 18.04 Testing

Postby stanlea » Fri Jul 13, 2018 9:13 pm

Is it (reasonably) safe to use the repos with Mate 18.04 ?

stanlea
Established Member
Posts: 550
Joined: Wed Apr 25, 2012 9:49 pm

Re: KXStudio 18.04 Testing

Postby stanlea » Sat Jul 14, 2018 5:03 am

Actually I'm using wine staging on 16.04 without any problems.

millerthegorilla
Established Member
Posts: 70
Joined: Wed Oct 26, 2011 11:22 am

Re: KXStudio 18.04 Testing

Postby millerthegorilla » Sat Jul 14, 2018 7:59 am

Thanks @falkTX,
I'm keen to install and it is my first mac dual boot, so I have extra effort of refind etc, so it would be good to have a known reasonably working install. At the moment, I'm working off the livecd, adding a swap (kind of unnecessary), and working off a partition.
I'm getting good results, but have a reasonably high DSP Load, reaching 27% with only Ardour (plus plugins) running. There are few enough Xruns with a 5ms latency to consider live recording, which I'm going to do in the next hour or so, to see if it can handle it.


Return to “KXStudio Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest