How to prevent autostart of the Pulse Audio bridge

Unofficial support for the KXStudio Linux distribution and applications.
More info at http://kxstudio.linuxaudio.org/

Moderators: MattKingUSA, khz

Aleks
Established Member
Posts: 268
Joined: Wed Nov 09, 2011 5:36 pm

How to prevent autostart of the Pulse Audio bridge

Post by Aleks »

I am using KX Studio repos on Ubuntu 16.04, and every time I start Jack with Cadence, the pulseaudio jack bridge module autostarts with it. How do I prevent that? The main problem is that I can't even stop it. Every time I stop, it loads itself on its own.

Aleks
Established Member
Posts: 268
Joined: Wed Nov 09, 2011 5:36 pm

Re: How to prevent autostart of the Pulse Audio bridge

Post by Aleks »

Yes, there is no such folder. Actually, I just rebuilt my system from scratch, and the only time I typed sudo and pulseaudio together was when I installed the module. Is there a way to fix that?

Aleks
Established Member
Posts: 268
Joined: Wed Nov 09, 2011 5:36 pm

Re: How to prevent autostart of the Pulse Audio bridge

Post by Aleks »

Will try that. In the mean time, I created the the .pulse folder myself, and after reboot, I lost the submenus in the cadence applet. Respawning still not solved.

Aleks
Established Member
Posts: 268
Joined: Wed Nov 09, 2011 5:36 pm

Re: How to prevent autostart of the Pulse Audio bridge

Post by Aleks »

I reinstalled the system again, and the autostart is solved, but I still don't have submenus in the applet indicator. I ran cadence from the terminal, but nothing much there...just this:

Code: Select all

$ cadence
Using Tray Engine 'Qt'
You do not have the required permissions to view the files attached to this post.

User avatar
lilith
Established Member
Posts: 1195
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: How to prevent autostart of the Pulse Audio bridge

Post by lilith »

I have the same issue currently on another machine (Laptop). I installed the KXStudio repos and everytime I stop the pulseaudio bridge in Cadence it starts automatically after 3 Seconds. On my main PC it is not restarting. Is there something misconfigured?
https://soundcloud.com/lilith_93
latest: https://soundcloud.com/lilith_93/deeper-and-deeper
_____________________________
Debian 10 - BUSTER (XFCE) & KXStudio repos

User avatar
khz
Established Member
Posts: 1270
Joined: Thu Apr 17, 2008 6:29 am
Location: German

Re: How to prevent autostart of the Pulse Audio bridge

Post by khz »

Code: Select all

echo "autospawn = no" >> ~/.config/pulse/client.conf
viewtopic.php?p=103154#p103154
FZ - Does humor belongs in Music?
GNU/LINUX@AUDIO ~ /Wiki $ Howto.Info && GNU/Linux Debian installing >> Linux Audio Workstation LAW
  • I don't care about the freedom of speech because I have nothing to say.

User avatar
lilith
Established Member
Posts: 1195
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: How to prevent autostart of the Pulse Audio bridge

Post by lilith »

khz wrote:
Thu Mar 19, 2020 1:55 pm

Code: Select all

echo "autospawn = no" >> ~/.config/pulse/client.conf
viewtopic.php?p=103154#p103154
Thanks! Now this thread makes sense, cause I didn't understand the posts.
https://soundcloud.com/lilith_93
latest: https://soundcloud.com/lilith_93/deeper-and-deeper
_____________________________
Debian 10 - BUSTER (XFCE) & KXStudio repos

User avatar
lilith
Established Member
Posts: 1195
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: How to prevent autostart of the Pulse Audio bridge

Post by lilith »

Not working for me. Does it need a reboot?
https://soundcloud.com/lilith_93
latest: https://soundcloud.com/lilith_93/deeper-and-deeper
_____________________________
Debian 10 - BUSTER (XFCE) & KXStudio repos

User avatar
khz
Established Member
Posts: 1270
Joined: Thu Apr 17, 2008 6:29 am
Location: German

Re: How to prevent autostart of the Pulse Audio bridge

Post by khz »

Yes, as far as I remember or as far as I have a technical overview, you have to log out the user and log in again, because this will read and apply the file ~/.config/pulse/client.conf. It is not necessary to restart the computer. IMHO

But I switch off with the command PA:
In qjackctl Setup:
  • Setup >> Options > [X] Execute script at startup: "systemctl --user stop pulseaudio.socket && systemctl --user stop pulseaudio.service"
  • Setup >> Options > [X] Run script after shutdown: "killall -9 jackdbus && systemctl --user start pulseaudio.socket && systemctl --user start pulseaudio.service")
FZ - Does humor belongs in Music?
GNU/LINUX@AUDIO ~ /Wiki $ Howto.Info && GNU/Linux Debian installing >> Linux Audio Workstation LAW
  • I don't care about the freedom of speech because I have nothing to say.

User avatar
khz
Established Member
Posts: 1270
Joined: Thu Apr 17, 2008 6:29 am
Location: German

Re: How to prevent autostart of the Pulse Audio bridge

Post by khz »

Permanently disabling PA via "client.conf" worked for me with Debian-9.
With Debian-10 it didn't work anymore.
Since then I use the systemctl command mentioned above.
FZ - Does humor belongs in Music?
GNU/LINUX@AUDIO ~ /Wiki $ Howto.Info && GNU/Linux Debian installing >> Linux Audio Workstation LAW
  • I don't care about the freedom of speech because I have nothing to say.

User avatar
lilith
Established Member
Posts: 1195
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: How to prevent autostart of the Pulse Audio bridge

Post by lilith »

Maybe I should uncommend the line :lol:
https://soundcloud.com/lilith_93
latest: https://soundcloud.com/lilith_93/deeper-and-deeper
_____________________________
Debian 10 - BUSTER (XFCE) & KXStudio repos

User avatar
lilith
Established Member
Posts: 1195
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: How to prevent autostart of the Pulse Audio bridge

Post by lilith »

khz wrote:
Thu Mar 19, 2020 2:59 pm
Permanently disabling PA via "client.conf" worked for me with Debian-9.
With Debian-10 it didn't work anymore.
Since then I use the systemctl command mentioned above.
That's strange. You mean preventing it to not restart does not work in Debian 10? It's working for sure on my Desktop PC, but not on the laptop.

Code: Select all

autospawn = no
does not work. I logged out and rebooted and it's still the same.
https://soundcloud.com/lilith_93
latest: https://soundcloud.com/lilith_93/deeper-and-deeper
_____________________________
Debian 10 - BUSTER (XFCE) & KXStudio repos

User avatar
khz
Established Member
Posts: 1270
Joined: Thu Apr 17, 2008 6:29 am
Location: German

Re: How to prevent autostart of the Pulse Audio bridge

Post by khz »

Last year I treated myself to my first laptop in my life. Conservative as I am I installed a Debian-stable (includes a smooth transition from stretch to buster). This is how I came across the problem with "client.conf". With buster it just didn't work anymore.
Is it related to https://wiki.debian.org/systemd or https://wiki.debian.org/Wayland or $foobar?
Thanks to you (posts in the link above) I got to know the "systemctl" and, since it just works, adapted it. Thanks for that.
The "systemctl" I have then also transferred to the desktop like this.
Direct console command for pulseaudio service on/off.

(Why does my post appear 2 times?)
FZ - Does humor belongs in Music?
GNU/LINUX@AUDIO ~ /Wiki $ Howto.Info && GNU/Linux Debian installing >> Linux Audio Workstation LAW
  • I don't care about the freedom of speech because I have nothing to say.

User avatar
lilith
Established Member
Posts: 1195
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: How to prevent autostart of the Pulse Audio bridge

Post by lilith »

It works on my Desktop PC running Buster. I'll check the settings there.
https://soundcloud.com/lilith_93
latest: https://soundcloud.com/lilith_93/deeper-and-deeper
_____________________________
Debian 10 - BUSTER (XFCE) & KXStudio repos

User avatar
lilith
Established Member
Posts: 1195
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: How to prevent autostart of the Pulse Audio bridge

Post by lilith »

On my Desktop PC I have also Cadence running and I can stop the Pulse Audio Bridge there and it does not restart again automatically.

Image

I even don't have a client.conf file in ~/.config/pulse/ and in /etc/pulse/client.conf everything is commented.

Debian 10 also here.
https://soundcloud.com/lilith_93
latest: https://soundcloud.com/lilith_93/deeper-and-deeper
_____________________________
Debian 10 - BUSTER (XFCE) & KXStudio repos

Post Reply