Rosegarden plugins

Support & discussion regarding DAWs and MIDI sequencers.

Moderators: MattKingUSA, khz

Post Reply
User avatar
funkmuscle
Established Member
Posts: 2467
Joined: Mon Jun 02, 2008 2:30 pm

Rosegarden plugins

Post by funkmuscle »

Hey, does anyone use Rosegarden's synth plugins or it's vst capability?
I do but I have a problem with the EDITOR button on the synth plugins.

For instance, the dssi-fluidsynth, I can't load any soundfonts. I would click on the editor button and nothing.

This Rosegarden-1.7.0. It all worked on earlier versions.

User avatar
studio32
Established Member
Posts: 2438
Joined: Mon Apr 07, 2008 5:09 pm

Post by studio32 »

have you installed dssi-fluidsynth etc?
Non-Session-Manager | FYI: Arch Linux / KXstudio do offer graphically less optimized packages (without NTK toolkit) of the original NSM GUI since June 2020. Original NSM GUI with NTK toolkit here

User avatar
funkmuscle
Established Member
Posts: 2467
Joined: Mon Jun 02, 2008 2:30 pm

Post by funkmuscle »

everything is installed.
the plugins are there, they just don't work.

fluidsynth will launch, I click on the editor button and nothing happens. I can't load the soundfonts. I would load a vst and try to load a wav sample, nothing happens.

brummer

Post by brummer »

did the plugins work in plain host's (jack-dssi-host, ghostess, or dssi-vst, vsthost)

are you shure that the audio connection to jack is work ?

could you play sound with extern synth's ?

here work everything with rosegarden 1.7.0 and dssi/ladspa/vst plugins.

User avatar
funkmuscle
Established Member
Posts: 2467
Joined: Mon Jun 02, 2008 2:30 pm

Post by funkmuscle »

I use vsthost to run vst as standalone all the time... I use fluidsynth with Qsynth all the time..
All that worked before I upgraded to the latest Rosegarden. In fact, when I install the older Rosegarden, everything works. 1.6.1 works, 1.7.0 plugins for synths work, the editor button doesn't.
If a synth or a vst doesn't need any files loaded with it, they work but to load the soundfonts in dssi-fluidsynth or to load an impulse response file in say, keFIR-vst, the editor button does not allow me to do so. All work on 1.6.1.
Otherwise, Rosegarden-1.7.0 rocks....

User avatar
raboof
Established Member
Posts: 1699
Joined: Tue Apr 08, 2008 11:58 am
Location: Deventer, NL
Contact:

Post by raboof »

Odd!

Have you brought this up on the rosegarden mailinglists/bugtracker yet? Might be worth a shot.

User avatar
schivmeister
Established Member
Posts: 95
Joined: Sat Apr 12, 2008 9:28 am
Location: Singapore
Contact:

Post by schivmeister »

hey funkmuscle good to see you here. I've seen your post on the Arch BBS but I'll reply here.

I don't use Rosegarden so I still have the one from [extra] which is 4.1.6.1, and it does work. I'll install the latest and check it out. I assume the problem might be distro-specific, in which case you may be missing some extra commands in the PKGBUILD. You can actually take a look at an ebuild and get some pointers.

User avatar
funkmuscle
Established Member
Posts: 2467
Joined: Mon Jun 02, 2008 2:30 pm

Post by funkmuscle »

schivmeister, the one from extra does work so you maybe right.
I think it could be distro specific that's why I was asking before doing a bugtracker at rosegarden...
I'll check the ebuild also

see ya at the proaudio repo schivmeister.

Post Reply