DrumGizmo v0.9.14 (LAC2017 version) released

DrumGizmo development and support forum.
http://drumgizmo.org/

Moderators: MattKingUSA, khz, muldjord, Glocke, deva

Post Reply
User avatar
deva
Established Member
Posts: 154
Joined: Sun Oct 23, 2016 10:15 am
Contact:

DrumGizmo v0.9.14 (LAC2017 version) released

Post by deva »

DrumGizmo version 0.9.14 now available!

Get it at http://www.drumgizmo.org/

DrumGizmo is an open source, multichannel, multilayered, cross-platform drum plugin and stand-alone application. It enables you to compose drums in midi and mix them with a multichannel approach. It is comparable to that of mixing a real drumkit that has been recorded with a multimic setup.

This is a bugfix release fixing a lot of bugs as reported from our last release 0.9.13[1] which was the first drumgizmo version ever supporting diskstreaming.
The release bears the version number 0.9.14 and can, as always, be downloaded here[2].

For the full list of changes, check the roadmap for 0.9.14[3].

The release of 0.9.14 is also known as "LAC2017 here we come!"

As is a bit of a tradition for the DrumGizmo team (and many other fine open source projects), we have prepared a special release for the upcoming Linux Audio Conference[4]. This year the conference takes place in Saint-Etienne, France from May 18-21 2017. And we'll be showing up! So be sure to take note of “The cool guys with the drumsticks”. You might just secure yourself one with a nice DG logo on it done with the custom made lasercutter of Open Space Aarhus[5].

See you at LAC! :)

[1]: http://www.drumgizmo.org/wiki/doku.php? ... rsion_0913
[2]: http://www.drumgizmo.org/wiki/doku.php? ... _drumgizmo
[3]: http://www.drumgizmo.org/wiki/doku.php? ... rsion_0914
[4]: http://lac.linuxaudio.org/2017
[5]: http://osaa.dk

User avatar
funkmuscle
Established Member
Posts: 2430
Joined: Mon Jun 02, 2008 2:30 pm

Re: DrumGizmo v0.9.14 (LAC2017 version) released

Post by funkmuscle »

way better streaming now! thanx guys. no xruns at all.

User avatar
deva
Established Member
Posts: 154
Joined: Sun Oct 23, 2016 10:15 am
Contact:

Re: DrumGizmo v0.9.14 (LAC2017 version) released

Post by deva »

funkmuscle wrote:way better streaming now! thanx guys. no xruns at all.
Great! :-)

chaot4
Established Member
Posts: 59
Joined: Sat Apr 16, 2016 9:59 am

Re: DrumGizmo v0.9.14 (LAC2017 version) released

Post by chaot4 »

As always, please report us any bug that you find. Otherwise we probably don't know about it and thus also cannot fix it. :)

User avatar
funkmuscle
Established Member
Posts: 2430
Joined: Mon Jun 02, 2008 2:30 pm

Re: DrumGizmo v0.9.14 (LAC2017 version) released

Post by funkmuscle »

chaot4 wrote:As always, please report us any bug that you find. Otherwise we probably don't know about it and thus also cannot fix it. :)
for sure. no issues so far.. all is super smooth. great work guys :D

slavikator
Established Member
Posts: 4
Joined: Thu Apr 20, 2017 8:52 pm

Re: DrumGizmo v0.9.14 (LAC2017 version) released

Post by slavikator »

Ardour 5.9.0 crashes after install Drumgizmo 0.9.14. After uninstall DG Ardour is OK.

User avatar
funkmuscle
Established Member
Posts: 2430
Joined: Mon Jun 02, 2008 2:30 pm

Re: DrumGizmo v0.9.14 (LAC2017 version) released

Post by funkmuscle »

slavikator wrote:Ardour 5.9.0 crashes after install Drumgizmo 0.9.14. After uninstall DG Ardour is OK.
Ardour 5.10 is out now. Try that. I've had no issues with 5.9 or 5.10 and DG.

slavikator
Established Member
Posts: 4
Joined: Thu Apr 20, 2017 8:52 pm

Re: DrumGizmo v0.9.14 (LAC2017 version) released

Post by slavikator »

My system is updated but version of Ardour still 5.09. How can I update it to 5.10 ?
When Drumgizmo installed, Ardour is crashing always, except Safe Mode. When all plugins are disabled (Safe Mode) Ardour starts and works, I can create midi track with Drumgizmo, but when I try to open plugin Drumgizmo for load kit Ardour crashes without any information.

User avatar
funkmuscle
Established Member
Posts: 2430
Joined: Mon Jun 02, 2008 2:30 pm

Re: DrumGizmo v0.9.14 (LAC2017 version) released

Post by funkmuscle »

slavikator wrote:My system is updated but version of Ardour still 5.09. How can I update it to 5.10 ?
When Drumgizmo installed, Ardour is crashing always, except Safe Mode. When all plugins are disabled (Safe Mode) Ardour starts and works, I can create midi track with Drumgizmo, but when I try to open plugin Drumgizmo for load kit Ardour crashes without any information.
I use Arch Linux. I just updated the package installer script for Ardour. I never had issues with either.

slavikator
Established Member
Posts: 4
Joined: Thu Apr 20, 2017 8:52 pm

Re: DrumGizmo v0.9.14 (LAC2017 version) released

Post by slavikator »

Clean reinstall was my solution. Now is working fine.

magnetophon
Posts: 1
Joined: Mon Jul 03, 2017 5:11 am

Re: DrumGizmo v0.9.14 (LAC2017 version) released

Post by magnetophon »

Hi,

Thanks for making this, great software!

I'm having trouble running 0.9,14 though; often, when I open the GUI in Ardour 5.10, I get:

Code: Select all

The program 'ardour-5.10.9c629c0c' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 50758 error_code 2 request_code 12 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
That crashes Ardour.

0.9.12 seems fine.

User avatar
deva
Established Member
Posts: 154
Joined: Sun Oct 23, 2016 10:15 am
Contact:

Re: DrumGizmo v0.9.14 (LAC2017 version) released

Post by deva »

magnetophon wrote:Hi,

Thanks for making this, great software!

I'm having trouble running 0.9,14 though; often, when I open the GUI in Ardour 5.10, I get:

Code: Select all

The program 'ardour-5.10.9c629c0c' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 50758 error_code 2 request_code 12 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
That crashes Ardour.

0.9.12 seems fine.
I think this has been fixed in git. Are you able to try that out?

User avatar
deva
Established Member
Posts: 154
Joined: Sun Oct 23, 2016 10:15 am
Contact:

Re: DrumGizmo v0.9.14 (LAC2017 version) released

Post by deva »

deva wrote:I think this has been fixed in git. Are you able to try that out?
It turned out it wasn't fixed in git after all... but it is now :-)

This is the fix in case you want to try and apply it manually:
http://cgit.drumgizmo.org/drumgizmo.git ... 3a5fcb6307

Post Reply