MuseScore «full buffer not available at start» error

Do you typeset your scores on Linux? Share your thoughts, tips, and tricks here.

Moderators: MattKingUSA, khz

Post Reply
ciacnorris
Established Member
Posts: 22
Joined: Sun May 25, 2014 8:20 pm

MuseScore «full buffer not available at start» error

Post by ciacnorris »

Hi,

I'm working on KXStudio 12.04. I changed something in MuseScore configuration, trying to get the MIDI input to work. Now MuseScore doesn't start at all. When starting it from a console i get

Code: Select all

Alsa_driver: buffer size requested 3342 got 3343
Alsa_driver: full buffer not available at start.
Errore di segmentazione
I tried

Code: Select all

sudo apt-get purge musescore
sudo apt-get install musescore
But it still gives the same error. What to do?

DepreTux
Established Member
Posts: 135
Joined: Tue Jul 23, 2013 9:36 am

Re: MuseScore «full buffer not available at start» error

Post by DepreTux »

I don't know about ubuntu (which kxstudio is based on) but on debian wheezy, the musescore compilation had a problem where you couldn't set it to JACK MIDI without the program crashing. Might be something similar.

Backup your old config and launch the program to get a new one created.

Code: Select all

mv ~/.config/MusE/MuseScore.ini ~/.config/MusE/MuseScore.ini.back
Then you can customize it bit by bit till you get to the troublesome bug.

Post Reply