Another deal gone down... XRUNS all over the place

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

Гага́рин
Established Member
Posts: 48
Joined: Tue Jan 01, 2013 3:12 pm

Re: Another deal gone down... XRUNS all over the place

Post by Гага́рин »

remove pulse shit from the system.

Shadow_7
Established Member
Posts: 175
Joined: Tue Jun 08, 2010 3:35 pm

Re: Another deal gone down... XRUNS all over the place

Post by Shadow_7 »

I don't really disagree with the sentiment. Many *buntu installs go something akin to installed *buntu, had audio troubles, removed pulse, don't have audio troubles.

But in reality, many other distro packages like the java runtime were compiled against pulseaudio and expect it to be there (in a perfect world), and to truly remove it, you'd have to recompile the java runtime and other things throughout the distro. Not that it'd have many symptoms on the audio side for production applications. But having a working pulseaudio has a few perks, like using teamspeak with your microphone in a port other than the first one with a card that has more than one input.

http://jackaudio.org/pulseaudio_and_jack

I basically had to follow that guide just to get pulse working on my laptop and in part for my desktop. Option 4 is my preferred mode of operation. But getting option 3 working has it's perks. And it looks like the guide I used for my Delta 44 post install configuration was purged. But the components seem to still exist via launchpad and other locations. The whole process could use a sanity check. As a reference, I had to (via guides) create and/or modify the following for a working pulseaudio on a relatively fresh install.

/etc/pulse/client.conf
/etc/udev/rules.d/ice1712-pulseaudio-workaround.rules
/usr/share/pulseaudio/alsa-mixer/profile-sets/via-ice1712.conf
~/.pulse/default.pa
~/.pulse/daemon.conf

And I might be missing a few I can't recall off the top of my head. Plus a custom /etc/modprobe.d/alsa_custom.conf to reindex my cards. From the old days when you needed such a thing to allow module auto-loading (and unloading) when you used (or failed to use for a period of time) your soundcard.

TheSafePlaces
Established Member
Posts: 200
Joined: Sat Nov 26, 2011 8:50 am

Re: Another deal gone down... XRUNS all over the place

Post by TheSafePlaces »

Wow. There's a much simpler way, can't believe no one mentioned it.
Install UbuntuStudio 12.04 (although maybe there's a KXStudio version for later Ubuntu versions, IDK)
Install the KXStudio repos.
-OR-
Grab the KXStudio ISO.
Use Cadence instead of qjackctl, click the 'Enable'/'Start' buttons for all three loops (ALSA Audio, ALSA MIDI, PulseAudio), add 'cadence --minimized' to system startup (Menu -> Settings -> Settings Manager -> Session and Startup -> Application Autostart -> Add).
Solved, no more PulseAudio problems. Period. ;)
Looking for the ideal distro. NixOS?
Newbie composer, somewhat-experienced classical guitarist.
Largely known as HisaoNakai/contrapunctus on IRC and other places.

Shadow_7
Established Member
Posts: 175
Joined: Tue Jun 08, 2010 3:35 pm

Re: Another deal gone down... XRUNS all over the place

Post by Shadow_7 »

As nice as that sounds, I doubt it works for "all" soundcards. Out of the box anyway. But I could be wrong. I remember adding configuration files to get pulseaudio to recognize that my soundcard had input channels. 4x outputs and 4x inputs and an internal 10 channel mixer and the default pulse configuration says stereo out only. So it's not just a matter of getting pulse to run in some cases.

Post Reply