Linux user got Ableton running in linux, made a video

Discuss running non-Linux applications and plugins on Linux, for example via wine

Moderators: MattKingUSA, khz

Post Reply
glowrak guy
Established Member
Posts: 2325
Joined: Sat Jun 21, 2014 8:37 pm
Been thanked: 256 times

Linux user got Ableton running in linux, made a video

Post by glowrak guy »

The video is in German, and a KVR member had success by following the video. But the terminal commands are in Englsh. Installing several vcruns and sundries with winetricks seems to have turned the key. They are shown in a terminal just after the 5 minute mark of the 14 minute video.

https://youtu.be/Fa2k0vvlAEI

Cheers

tavasti
Established Member
Posts: 2057
Joined: Tue Feb 16, 2016 6:56 am
Location: Kangasala, Finland
Has thanked: 373 times
Been thanked: 209 times
Contact:

Re: Linux user got Ableton running in linux, made a video

Post by tavasti »

I have also gotten Ableton Live Lite running with wine, but latency is huge. Did they got some decent latency?

Linux veteran & Novice musician

Latest track: https://www.youtube.com/watch?v=ycVrgGtrBmM

User avatar
Audiojunkie
Established Member
Posts: 402
Joined: Thu Feb 21, 2019 4:27 pm
Has thanked: 392 times
Been thanked: 157 times

Re: Linux user got Ableton running in linux, made a video

Post by Audiojunkie »

tavasti wrote: Tue Apr 02, 2024 10:09 am

I have also gotten Ableton Live Lite running with wine, but latency is huge. Did they got some decent latency?

Did you use WINEASIO?

tavasti
Established Member
Posts: 2057
Joined: Tue Feb 16, 2016 6:56 am
Location: Kangasala, Finland
Has thanked: 373 times
Been thanked: 209 times
Contact:

Re: Linux user got Ableton running in linux, made a video

Post by tavasti »

Audiojunkie wrote: Tue Apr 02, 2024 8:06 pm
tavasti wrote: Tue Apr 02, 2024 10:09 am

I have also gotten Ableton Live Lite running with wine, but latency is huge. Did they got some decent latency?

Did you use WINEASIO?

Yeah, and needed to bump jack buffers to 8192 to avoid xruns

Linux veteran & Novice musician

Latest track: https://www.youtube.com/watch?v=ycVrgGtrBmM

tavasti
Established Member
Posts: 2057
Joined: Tue Feb 16, 2016 6:56 am
Location: Kangasala, Finland
Has thanked: 373 times
Been thanked: 209 times
Contact:

Re: Linux user got Ableton running in linux, made a video

Post by tavasti »

Some people are/have been working for low-latency wine: https://github.com/nine7nine/Wine-NSPA/issues/4

Haven't tried, and no idea if work is still ongoing

Linux veteran & Novice musician

Latest track: https://www.youtube.com/watch?v=ycVrgGtrBmM

User avatar
Audiojunkie
Established Member
Posts: 402
Joined: Thu Feb 21, 2019 4:27 pm
Has thanked: 392 times
Been thanked: 157 times

Re: Linux user got Ableton running in linux, made a video

Post by Audiojunkie »

tavasti wrote: Wed Apr 03, 2024 8:11 am
Audiojunkie wrote: Tue Apr 02, 2024 8:06 pm
tavasti wrote: Tue Apr 02, 2024 10:09 am

I have also gotten Ableton Live Lite running with wine, but latency is huge. Did they got some decent latency?

Did you use WINEASIO?

Yeah, and needed to bump jack buffers to 8192 to avoid xruns

What kind of Kernel, and what distro are you using?

tavasti
Established Member
Posts: 2057
Joined: Tue Feb 16, 2016 6:56 am
Location: Kangasala, Finland
Has thanked: 373 times
Been thanked: 209 times
Contact:

Re: Linux user got Ableton running in linux, made a video

Post by tavasti »

Audiojunkie wrote: Thu Apr 04, 2024 4:20 am
tavasti wrote: Wed Apr 03, 2024 8:11 am

Yeah, and needed to bump jack buffers to 8192 to avoid xruns

What kind of Kernel, and what distro are you using?

That was with Ubuntu 18.04 + liquorix kernel. Haven't tried recently, after biting the bullet and getting Bitwig I haven't been investigating running windows DAWs.

Linux veteran & Novice musician

Latest track: https://www.youtube.com/watch?v=ycVrgGtrBmM

User avatar
Audiojunkie
Established Member
Posts: 402
Joined: Thu Feb 21, 2019 4:27 pm
Has thanked: 392 times
Been thanked: 157 times

Re: Linux user got Ableton running in linux, made a video

Post by Audiojunkie »

tavasti wrote: Thu Apr 04, 2024 6:06 am
Audiojunkie wrote: Thu Apr 04, 2024 4:20 am
tavasti wrote: Wed Apr 03, 2024 8:11 am

Yeah, and needed to bump jack buffers to 8192 to avoid xruns

What kind of Kernel, and what distro are you using?

That was with Ubuntu 18.04 + liquorix kernel. Haven't tried recently, after biting the bullet and getting Bitwig I haven't been investigating running windows DAWs.

Oh! I misunderstood! :) I was under the impression that you were trying to get things to work right now. I didn't realize you were sharing a past experience from a while ago. :D

Post Reply