Will this midi-keyboard work in 10.04

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: MattKingUSA, khz

dchurch24
Established Member
Posts: 170
Joined: Tue Dec 02, 2008 7:44 pm

Re: Will this midi-keyboard work in 10.04

Post by dchurch24 »

Ooops, sorry, yes I meant Ubuntu 10.04.

I will look at amidi when I get home later.

Thanks for the pointers guys, I'll post the results here.

dchurch24
Established Member
Posts: 170
Joined: Tue Dec 02, 2008 7:44 pm

Re: Will this midi-keyboard work in 10.04

Post by dchurch24 »

Here's the output from amidi -l:

Code: Select all

dave@dave-studio32:~$ amidi -l 
Dir Device    Name
IO  hw:0,0    M Audio Delta 1010LT MIDI
dave@dave-studio32:~$ 
Sadly, it's not listed, but the fact that the Delta is listed implies that there's some sort of 'break out box' that I could buy with a midi adapter no?

EDIT: no, it appears not. The Delta 66 (which this card is, NOT the 1010LT that it thinks it is, has no MIDI capability :-( )

User avatar
autostatic
Established Member
Posts: 1728
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands
Contact:

Re: Will this midi-keyboard work in 10.04

Post by autostatic »

There's an exact same thread about this MIDI-USB cable on LinuxMAO, a French community site. It should work and the output of cat /proc/asound/cards should return something like

Code: Select all

 1 [Cable          ]: USB-Audio - USB Midi Cable
                      USB Midi Cable at usb-0000:00:1d.1-1, full speed
How do you connect your MIDI keyboard to the cable? Apparently you have to connect the IN plug of the cable to the OUT port of your keyboard.

User avatar
funkmuscle
Established Member
Posts: 2473
Joined: Mon Jun 02, 2008 2:30 pm

Re: Will this midi-keyboard work in 10.04

Post by funkmuscle »

since the world thinks that linux is Ubuntu and it's pretty popular now, you'd think that drivers would be made for all hardware now...
especially now that linux is starting to make a name for itself in the proaudio world. Issue like this should not be happening still...

User avatar
raboof
Established Member
Posts: 1713
Joined: Tue Apr 08, 2008 11:58 am
Location: Deventer, NL
Contact:

Re: Will this midi-keyboard work in 10.04

Post by raboof »

funkmuscle wrote:you'd think that drivers would be made for all hardware now... especially now that linux is starting to make a name for itself in the proaudio world. Issue like this should not be happening still...
http://kerneltrap.org/mailarchive/git-c ... /3/1/25070 suggests this device would've worked out-of-the-box if the manufacturer wouldn't have produced a buggy firmware. And even with that buggy firmware, it looks like the driver has been adapted to work with this device - though apparently this fix hasn't made it into every system just yet...

User avatar
autostatic
Established Member
Posts: 1728
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands
Contact:

Re: Will this midi-keyboard work in 10.04

Post by autostatic »

That could be possible, the user on LinuxMAO who got it to work uses Mandriva2010.

User avatar
Capoeira
Established Member
Posts: 1278
Joined: Tue May 12, 2009 1:01 pm
Location: Brazil

Re: Will this midi-keyboard work in 10.04

Post by Capoeira »

I would prefere buying something like this: http://cgi.ebay.co.uk/BEHRINGER-UMX49-U ... 675wt_1139
the M-Audio doesn't even have a mod- and pitchwheel

dchurch24
Established Member
Posts: 170
Joined: Tue Dec 02, 2008 7:44 pm

Re: Will this midi-keyboard work in 10.04

Post by dchurch24 »

Woooah - I like the look of that.

Are you bidding on it?

I just dont want to bid against you.

dchurch24
Established Member
Posts: 170
Joined: Tue Dec 02, 2008 7:44 pm

Re: Will this midi-keyboard work in 10.04

Post by dchurch24 »

AutoStatic wrote:There's an exact same thread about this MIDI-USB cable on LinuxMAO, a French community site. It should work and the output of cat /proc/asound/cards should return something like

Code: Select all

 1 [Cable          ]: USB-Audio - USB Midi Cable
                      USB Midi Cable at usb-0000:00:1d.1-1, full speed
How do you connect your MIDI keyboard to the cable? Apparently you have to connect the IN plug of the cable to the OUT port of your keyboard.
Yes, IN to the OUT in the keyboard.

dchurch24
Established Member
Posts: 170
Joined: Tue Dec 02, 2008 7:44 pm

Re: Will this midi-keyboard work in 10.04

Post by dchurch24 »

Capoeira wrote:I would prefere buying something like this: http://cgi.ebay.co.uk/BEHRINGER-UMX49-U ... 675wt_1139
the M-Audio doesn't even have a mod- and pitchwheel
Well, I think you're quite right.

Hence I just bid 36 quid and won it ;-)

dchurch24
Established Member
Posts: 170
Joined: Tue Dec 02, 2008 7:44 pm

Re: Will this midi-keyboard work in 10.04

Post by dchurch24 »

...although I'm starting to wonder if this is supported in Ubuntu, it's arrived, but isn't being seen as a midi device.

It's in lsusb, but not in Jack or amidi -l, or even in aplay.

Even my duff midi-usb converter was seen. I think I've just wasted yet more cash on this project, and still I am unable to record even the simplest of things.

Sadly, after my debarcle with recording in Windows, and now my slightly less troublesome time with Linux, I think I may be dragging the old Tascam 4-track out of the loft. It seems it was the only reliable way to record music.

:-(

User avatar
autostatic
Established Member
Posts: 1728
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands
Contact:

Re: Will this midi-keyboard work in 10.04

Post by autostatic »

Weird... The UMX49 is a USB 1.1. class compliant device so it should work out of the box:
1.2 System requirements
For USB operation, a current WINDOWS® PC or MAC® with a
USB connection is sufficient. Both USB 1.1 and USB 2.0 are
supported.
The UMX supports the USB MIDI compatibility of
WINDOWS® XP and MAC OS® X operating systems.

...

5. SPECIFICATIONS
USB connections Type B; USB1.1
Type
What does lsusb report?

User avatar
raboof
Established Member
Posts: 1713
Joined: Tue Apr 08, 2008 11:58 am
Location: Deventer, NL
Contact:

Re: Will this midi-keyboard work in 10.04

Post by raboof »

dchurch24 wrote:isn't being seen as a midi device.

It's in lsusb, but not in Jack or amidi -l, or even in aplay.
When you connect the device, do any lines get added to /var/log/messages and/or /var/log/syslog ? Could you paste them?

Does 'lsmod' show 'snd_usb_audio'? Does manually doing 'sudo modprobe snd_usb_audio' help?

dchurch24
Established Member
Posts: 170
Joined: Tue Dec 02, 2008 7:44 pm

Re: Will this midi-keyboard work in 10.04

Post by dchurch24 »

Hi, thanks for the replies.

Thankfully, when I updated to 10.04 (32 bit), I installed to a new hard drive. This meant that I could plug in the old drive that had 9.10 (64 bit) running on it.

I did this in desperation last night, and in 9.10 the 49 is recognised and I can see it in Jack and map it to Hexter etc...(can't get midi in/out of LMMS though for some reason - maybe too old a version?).

Is it that this device is not supported in 10.04?

I have no problem using 9.10, but I can't get LinuxSampler working (64 bit issues?), or LMMS midi in/out, although I do get sound when using the mouse to click the on-screen keys.

Also, I had Bristol working on 10.04 (obviously not ideal using a mouse to play), but now back in 9.10 Bristol complains about not being able to connect to Midi, if I start it "startBristol -jack" I get an error telling me that it was not compiled for use with Jack.

PS. Are you the same AutoStatic who has this: https://launchpad.net/~autostatic/+arch ... /+packages ?
If so, then you Sir, are a God. Thanks very much for that, I'm going to try the .deb file for LinuxSampler.

Ironically, I can only seem to get Midi in/out through Hexter - I say ironically, as I couldn't get my *real life* DX7 midi'ed into the box, but now with the UMX49 I can play DX7 sounds! ;-)

EDIT: Interestingly, if I load up the ZynAddSubFX synth in LMMS, I can controll it from the UMX49 and I get output. If I try any of the other 'synths' I get nothing.

User avatar
autostatic
Established Member
Posts: 1728
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands
Contact:

Re: Will this midi-keyboard work in 10.04

Post by autostatic »

dchurch24 wrote:Is it that this device is not supported in 10.04?
No, it should be fully supported in 10.04 too. And if you run the realtime 2.6.31 kernel for Lucid it really should work as this is almost the exact same realtime kernel as in Karmic 9.10.
dchurch24 wrote:I have no problem using 9.10, but I can't get LinuxSampler working (64 bit issues?)
Can't be 64bit issues, I use LinuxSampler on 9.10 64bits too and works like a charm
dchurch24 wrote:or LMMS midi in/out, although I do get sound when using the mouse to click the on-screen keys.
I think that's a LMMS MIDI connection problem. Did you set up any MIDI devices in LMMS? Gee, it's been a while since I used LMMS. Is 0.4.7 any good?
dchurch24 wrote:Also, I had Bristol working on 10.04 (obviously not ideal using a mouse to play), but now back in 9.10 Bristol complains about not being able to connect to Midi, if I start it "startBristol -jack" I get an error telling me that it was not compiled for use with Jack.
Bristol is a pita to get working. I barely use it, I can hardly get any decent sound out of it and sometimes out of nowhere it starts producing massive xruns. Bristol can be a bit picky when it comes to your settings. Running it from the CLI it is very informative though and should provide you the necessary info to troubleshoot any issues.
dchurch24 wrote:PS. Are you the same AutoStatic who has this: https://launchpad.net/~autostatic/+arch ... /+packages ?
If so, then you Sir, are a God. Thanks very much for that, I'm going to try the .deb file for LinuxSampler.
Do try, it should work, both the 9.10 and 10.04 versions. the 10.04 version comes with SFZ support so you can use it with the awesome Grand Salamander piano sample pack. And yes, it's the same AutoStatic. No Sir and no God though ;)
dchurch24 wrote:EDIT: Interestingly, if I load up the ZynAddSubFX synth in LMMS, I can controll it from the UMX49 and I get output. If I try any of the other 'synths' I get nothing.
Check your JACK connections, I suspect something iffy is going on there. Maybe post the outcome of jack_lsp -c with all the stuff hooked up and connected?

Post Reply