KXStudio 10.04.2 is out!

Discuss anything new and newsworthy! See http://planet.linuxaudio.org for more Linux Audio News!

Announcements of proprietary software may fit better in the Marketplace.

Moderators: raboof, MattKingUSA, khz

Grep
Established Member
Posts: 23
Joined: Wed Jan 07, 2009 7:32 pm
Location: Canada

Re: KXStudio - The KDE Multimedia distro

Post by Grep »

Thanks for command and tips falkTX. Yakauake is always at hand,I have missed it during all these Gnome years :D
I have installed 2.6.32-21 right after fresh install, I will try 2.6.31 sometime soon. Also I run all the updates I can get.For some reason ,latest vst package update was blocked.Vst version of Ardour works just fine.I keep on recording test tracks and trying various vst plugins. Im still looking for the optimal setup in Jack control interface,since settings I was using in 64Studio beta3 dont work so well now. I have just added following lines to /etc/security/limits.conf
@audio - rtprio 99
@audio - memlock unlimited
I will e-mail more logs to you in few days :wink:

munny
Established Member
Posts: 7
Joined: Thu May 06, 2010 7:44 am

Re: KXStudio - The KDE Multimedia distro

Post by munny »

Hi all and falTX!

After many tries attemps finally my system works, simply i enable capture in mixer, and after jack finally starts and so pulseaudio.
I don't know if this is jack bug or simply jack for start must have caputure enabled, i discovered this in kubuntu because for me jack worked only without realtime mode and i had many xruns also with high periods/frames...
After i try to enable Capture also in kxstudio and after i type:

Code: Select all

kxstudio-session-start -restart
and all is perfect.
KXStudio is really great, and again, i hope it will continue in the future!!!

A little idea for the future: In KXStudio Setting would be nice a window to configure file .config/jack/conf.xml and start, stop to help user to optimize jack.

Grep
Established Member
Posts: 23
Joined: Wed Jan 07, 2009 7:32 pm
Location: Canada

Re: KXStudio - The KDE Multimedia distro

Post by Grep »

Im glad install worked for you munny :D
falkTX,downgrading to 2.6.31 failed but I made sure I have everything ready prior to that so it can roll back new kernel if that fails and it did.I suspect it was nvidia issue preventing it from boot (esc button does not interrupt new grub,or is it just me? )In the end all was goodbut I will check the logs when I find some time and do some googling. It would be nice to have it so I might look for the card that will support Molnar's kernel if thats the case.As I am writing this Im editing /etc/security/limits.conf back the way it was :D .Can Serpentine audio cd creator be added to the repository?
I know it is Gnome app but I dont mind installing the rest that comes with it,because of ease of use it is worth to me and maybe to the others as well? I searched ubntu rep for it,could not find it.
I have installed Kid audio tag editing tool.
Just checked, there are more updates but vst plugins update is still blocked,running other ones . I dont have 32bit box around to test ArdourVST 32bit falkTX :(
Found good article :lol:
http://www.tuxradar.com/content/how-it- ... -explained

User avatar
Saftpackl
Established Member
Posts: 9
Joined: Mon Apr 19, 2010 4:34 pm

Re: KXStudio - The KDE Multimedia distro

Post by Saftpackl »

Helloo!

I'm running kxstudio now and it all works out pretty well =)

After Installation I chose the realtime-kernel (2.6.31-rt) and run into some problems at the beginning:
  • The dummy output was chosen, jack could not start - as mentioned before
  • I am using a firewire audio device and had to write an udev rule for /dev/raw1394 to be in the "audio" group (I believe there was a rule while setup or when I first booted into kxstudio with generic kernel, but it seems to have vanished ^^) -> /etc/udev/rules.d/40-permissions.rules:

Code: Select all

KERNEL=="raw1394", GROUP="audio"
  • After installing the rt-kernel, the nice kxstudio-bootscreen didn't show up and there was this ugly lucid-purple screen :P It's not a huge problem, but I'm now trying to get your kx-plymouth-theme(?) back ^^
  • A point that makes me crazy is that jack starts up randomly, only if it wants to, and I have no clue why
    Everytime I boot the system I have no sound because "jack could not be started". Only if I try a few times with qjackctl, it works after a while without reconfiguring it o.O
    My Config is: Image
    and the messages return:

Code: Select all

10:25:49.933 Start-Skript beendet mit Rückgabewert = 32512.
10:25:49.933 JACK startet...
10:25:49.933 /usr/bin/jackd -P80 -dfirewire -r48000 -p256 -n2
10:25:49.935 JACK wurde mit PID = 5697 gestartet.
10:25:51.945 Keine Verbindungsaufnahme als Client zum JACK-Server möglich. - Gesamtbetrieb schlug fehl. - Verbindungsaufnahme zum Server gescheitert. Bitte sehen Sie im Meldungsfenster nach weiteren Informationen.
Cannot connect to server socket err = Connection refused
Cannot connect to server socket
jack server is not running or cannot be started
no message buffer overruns
no message buffer overruns
jackdmp 1.9.5
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2009 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 80
libffado 2.0.0 built Mar 31 2010 16:21:44
10:25:57.194 Keine Verbindungsaufnahme als Client zum JACK-Server möglich. - Gesamtbetrieb schlug fehl. - Server-Kommunikationsfehler. Bitte sehen Sie im Meldungsfenster nach weiteren Informationen.
libiec61883 warning: iec61883_cmp_create_p2p_output: Failed to set the oPCR[0] plug for node 1.
firewire ERR: Could not start streaming threads
Cannot start driver
JackServer::Start() failed with -1
Cannot connect to server socket err = Connection refused
Cannot connect to server socket
Cannot connect to the server
no message buffer overruns
Failed to start server
10:25:57.308 JACK wurde angehalten mit Rückgabewert = 255.
10:25:57.309 Nach-Herunterfahr-Skript...
10:25:57.309 killall jackd lashd ladishd
ladishd: no process found
10:25:57.566 Schaubild der ALSA-Verbindungen geändert.
10:25:57.717 Nach-Herunterfahr-Skript beendet mit Rückgabewert = 256.
10:26:06.005 Keine Verbindungsaufnahme als Client zum JACK-Server möglich. - Gesamtbetrieb schlug fehl. - Verbindungsaufnahme zum Server gescheitert. Bitte sehen Sie im Meldungsfenster nach weiteren Informationen.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
10:26:23.615 Keine Verbindungsaufnahme als Client zum JACK-Server möglich. - Gesamtbetrieb schlug fehl. - Verbindungsaufnahme zum Server gescheitert. Bitte sehen Sie im Meldungsfenster nach weiteren Informationen.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
10:26:58.836 Keine Verbindungsaufnahme als Client zum JACK-Server möglich. - Gesamtbetrieb schlug fehl. - Verbindungsaufnahme zum Server gescheitert. Bitte sehen Sie im Meldungsfenster nach weiteren Informationen.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
10:27:01.884 Start-Skript...
10:27:01.885 artsshell -q terminate
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
sh: artsshell: not found
10:27:02.286 Start-Skript beendet mit Rückgabewert = 32512.
10:27:02.286 JACK startet...
10:27:02.286 /usr/bin/jackd -P80 -dfirewire -r48000 -p256 -n2
10:27:02.294 JACK wurde mit PID = 5760 gestartet.
10:27:04.453 Keine Verbindungsaufnahme als Client zum JACK-Server möglich. - Gesamtbetrieb schlug fehl. - Verbindungsaufnahme zum Server gescheitert. Bitte sehen Sie im Meldungsfenster nach weiteren Informationen.
Cannot connect to server socket err = Connection refused
Cannot connect to server socket
jack server is not running or cannot be started
no message buffer overruns
no message buffer overruns
jackdmp 1.9.5
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2009 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 80
libffado 2.0.0 built Mar 31 2010 16:21:44
10:27:10.468 Serverkonfiguration nach "/home/martin/.jackdrc" gespeichert.
10:27:10.471 Statistik zurückgesetzt.
10:27:10.479 Client aktiviert
10:27:10.479 Nach-Start-Skript...
10:27:10.480 lashd &
10:27:10.881 Nach-Start-Skript beendet erfolgreich.
10:27:10.882 JACK-Verbindung geändert.
Here the qjackctl tried it some times and after a few times it worked, maybe you know something that i don't :D
Just one more thing: Do I need "Ladi"? I have never heard of it but there is a configure-gui in the menu, which tells me, that "JACK can only be configured with a loaded and stopped studio. Please create a new studio or load and stop an existing one."

Thank you for your effort in making a new studio-distro, I like it very much! =)
My Stuff:
  • Kxstudio / Ubuntu Studio (10.04)
    Terratec Phase X24
    Icon Logicon 6air
    Rode NT-2A


munny
Established Member
Posts: 7
Joined: Thu May 06, 2010 7:44 am

Re: KXStudio - The KDE Multimedia distro

Post by munny »

Thanks FalkTX, your new version of

Code: Select all

kxstudio-session-start
is really good, now we can configure jack2 very well!

Great work and again thanks!
In the future i hope to contribute to this project!

Munny

Updated! :D
Last edited by munny on Wed May 12, 2010 12:17 pm, edited 2 times in total.

User avatar
Saftpackl
Established Member
Posts: 9
Joined: Mon Apr 19, 2010 4:34 pm

Re: KXStudio - The KDE Multimedia distro

Post by Saftpackl »

Thanks for your help, after an update everything seems to work with jack2 =)

How is a2jmidid integrated into the system? In qjackctl i can't find an a2j port and in gladish my midikeyboard doesn't show up, is midi processed by ladish?
My Stuff:
  • Kxstudio / Ubuntu Studio (10.04)
    Terratec Phase X24
    Icon Logicon 6air
    Rode NT-2A


User avatar
raboof
Established Member
Posts: 1718
Joined: Tue Apr 08, 2008 11:58 am
Location: Deventer, NL
Contact:

Re: KXStudio - The KDE Multimedia distro

Post by raboof »

falkTX wrote:Abogani, a Ubuntu Kernel dev, has compiled Linux kernel 2.6.33 with real-time patch, and it's available in it's PPA.
I downloaded them manually from http://ppa.launchpad.net/abogani/ppa/ub ... -realtime/ and tried installing it under Debian - it seems to boot until X is started, then my screen remains blank (and I can't ctrl-alt-f1 back to the console either).

The ones from http://www.pengutronix.de/software/linu ... an_en.html seem to work well

User avatar
Saftpackl
Established Member
Posts: 9
Joined: Mon Apr 19, 2010 4:34 pm

Re: KXStudio - The KDE Multimedia distro

Post by Saftpackl »

Hey, has someone else got a problem with nvidia-current and the new realtime-kernel(2.6.33-1-realtime)?

At first i was told that "module "nvidia" is not available" blablabla, so i tried to reinstalling and reconfiguring nvidia-current, but this error came up:

Code: Select all

Loading new nvidia-current-195.36.15 DKMS files...
Building only for 2.6.33-1-realtime
Building for architecture x86_64
Building initial module for 2.6.33-1-realtime

Error! Bad return status for module build on kernel: 2.6.33-1-realtime (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/nvidia-current/195.36.15/build/ for more information.
dpkg: Fehler beim Bearbeiten von nvidia-current (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 10 zurück
Verarbeite Trigger für initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.33-1-realtime
Fehler traten auf beim Bearbeiten von:
 nvidia-current
E: Sub-process /usr/bin/dpkg returned an error code (1)
does nvidia not like the new kernel?
My Stuff:
  • Kxstudio / Ubuntu Studio (10.04)
    Terratec Phase X24
    Icon Logicon 6air
    Rode NT-2A


morko
Established Member
Posts: 45
Joined: Thu Mar 25, 2010 8:08 am
Location: Finland

Re: KXStudio - The KDE Multimedia distro

Post by morko »

I dont have nvidia either, but I think you need a patch for the rt-kernel if you want to have nvidia drivers working with it.

brummer

Re: KXStudio 10.04.1 is out!

Post by brummer »

falkTX wrote:jillcullen wrote:
This bot seems really know what is well written. :mrgreen:

User avatar
Saftpackl
Established Member
Posts: 9
Joined: Mon Apr 19, 2010 4:34 pm

Re: KXStudio 10.04.1 is out!

Post by Saftpackl »

Hey hey, I found a new way to combine alsa and jack using a "loopback-bridge":
http://alsa.opensrc.org/index.php/Jack_ ... ack_bridge

I already tried it and it works like a charm! :D
With this, applications like skype or firefox can't crash anymore in case of sound issues (because jack or pulseaudio crashed or anything) and they don't have to be restarted if you have to restart jack.
Maybe this would be an option for kxstudio, just thought i would forward this idea so others could try it, too. =)

greetz, Saftpackl
My Stuff:
  • Kxstudio / Ubuntu Studio (10.04)
    Terratec Phase X24
    Icon Logicon 6air
    Rode NT-2A


User avatar
autostatic
Established Member
Posts: 1728
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands
Contact:

Re: KXStudio 10.04.1 is out!

Post by autostatic »


User avatar
angelsguitar
Established Member
Posts: 145
Joined: Sat May 31, 2008 10:30 am
Location: Florida
Contact:

Re: KXStudio 10.04.1 is out!

Post by angelsguitar »

Hi falkTX!

Saw your commentaries on the AV Linux 4's thread, and decided to drop by...

I've been playing around with KXStudio too, and is really amazing. Running jackd at startup as the system's main sound engine seems like a great idea. I always had some trouble with Ubuntu Studio's latency (a lot of xruns) on my main audio workstation, but KXStudio is running great here. And the package selection is awesome.

Keep up the great work! :D
Ángel A. Candelaria Colón
Guitar Professor
https://angelsguitar.com

User avatar
angelsguitar
Established Member
Posts: 145
Joined: Sat May 31, 2008 10:30 am
Location: Florida
Contact:

Re: KXStudio 10.04.1 is out!

Post by angelsguitar »

Hi again.

I'm noticing that, after running an apt-get dist-upgrade, backfire-dkms gives an error. Apparently, the module won't install on the new RT kernel 2.6.33.

Doesn't seem t affect performance in anyway (backfire has something to do with benchmarking, no?) but the error just pops up every time you update or install something, as the system keeps trying to build and install the module without success.
Ángel A. Candelaria Colón
Guitar Professor
https://angelsguitar.com

alexoest
Established Member
Posts: 17
Joined: Sun Jun 27, 2010 6:32 pm

Re: KXStudio 10.04.1 is out! - Jack won't start - SOLVED

Post by alexoest »

Hi again

Apparently, I've solved the problem: I went into setup on Jack Audio Connection Kit and changed the periods/buffer parameter from 3 to 2. That seems to do the trick.

/Alex

Hi people

I just installed KXStudio and it looks good. There's one problem, however. On startup I get a notification saying that "the audio playback device Jack Audio Connection Kit does not work. Falling back to SB Audigy 1 [SB0092]

When I try to start Rackarrack, I get an error message suggesting that Jack isn't running.

When I try to start Jack in the Jack Audio Connection Kit, it fails, giving me the message pasted in below.

I do have sound, so at least in some (perhaps all) respects, the sound card works.

I've tried the suggestions earlier in this thread without success. Any suggestions on how to fix this problem are welcome.

/Alex

Error message mentioned earlier:
10:17:40.010 Startup script...
10:17:40.010 artsshell -q terminate
Cannot connect to server socket err = Connection refused
Cannot connect to server socket
jack server is not running or cannot be started
sh: artsshell: not found
10:17:40.413 Startup script terminated with exit status=32512.
10:17:40.414 JACK is starting...
10:17:40.415 /usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n3
10:17:40.429 JACK was started with PID=1982.
could not open driver .so '/usr/lib/jack/jack_freebob.so': libfreebob.so.0: cannot open shared object file: No such file or directory
no message buffer overruns
could not open component .so '/usr/lib/jack/jack_freebob.so': libfreebob.so.0: cannot open shared object file: No such file or directory
no message buffer overruns
jackdmp 1.9.5
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2009 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
audio_reservation_init
Failed to acquire device name : Audio0 error : Device or resource busy
Audio device hw:0 cannot be acquired, trying to open it anyway...
creating alsa driver ... hw:0|hw:0|1024|3|44100|0|0|nomon|swmeter|-|32bit
Using ALSA driver Audigy running on card 0 - SB Audigy 1 [SB0092] (rev.3, serial:0x531102) at 0xb400, irq 17
configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 3 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: got smaller periods 2 than 3 for capture
ALSA: cannot configure capture channel
Cannot initialize driver
JackServer::Open() failed with -1
Failed to start server
10:17:40.810 JACK was stopped with exit status=255.
10:17:40.811 Post-shutdown script...
10:17:40.812 killall jackd lashd ladishd
jackd: no process found
lashd: no process found
ladishd: no process found
10:17:41.227 Post-shutdown script terminated with exit status=256.
10:17:42.570 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket

Post Reply