lexicon omega: 2 channels instead of 4 ?

Still new to all of this? Feel free to post in any of the subforums on this site, but in this subforum newbie questions are especially encouraged!

Moderators: khz, MattKingUSA

spadan
Established Member
Posts: 6
Joined: Sat Apr 25, 2020 9:42 pm
Contact:

lexicon omega: 2 channels instead of 4 ?

Post by spadan »

Hello everyone,
I'm new here in LinuxMusicians.

After few years I am back with my old Lexicon Omega but I am in trouble with it on my Dell XPS laptop, Debian Buster.
I usually work on Ardour through QjackCtl.
The system recognize the device and it works. The problem is that I can't distinguish the 4 input channels; just 2.
I mean, connecting 2 microphones (Mic 1 and 2) and the piano-keyboard (line 1 and 2) I get everything coming in one stereo channel only.
Could you please help me in order to get it work correctly ?

Thank you very much for your attention !
User avatar
bluebell
Established Member
Posts: 1480
Joined: Sat Sep 15, 2012 11:44 am
Location: Saarland & Frankfurt, Germany

Re: lexicon omega: 2 channels instead of 4 ?

Post by bluebell »

How many inputs (capture_xx) does Qjackctl show (Connect -> system)?
Linux – MOTU UltraLite AVB – Qtractor – https://soundcloud.com/suedwestlicht
spadan
Established Member
Posts: 6
Joined: Sat Apr 25, 2020 9:42 pm
Contact:

Re: lexicon omega: 2 channels instead of 4 ?

Post by spadan »

bluebell wrote: Sun Apr 26, 2020 2:01 pm How many inputs (capture_xx) does Qjackctl show (Connect -> system)?
Hi bluebell.

Just two, both for capture and playback.
User avatar
bluebell
Established Member
Posts: 1480
Joined: Sat Sep 15, 2012 11:44 am
Location: Saarland & Frankfurt, Germany

Re: lexicon omega: 2 channels instead of 4 ?

Post by bluebell »

You can set in Qjackctl (settings -> advanced) the number of the channels. Maybe that helps.
Linux – MOTU UltraLite AVB – Qtractor – https://soundcloud.com/suedwestlicht
spadan
Established Member
Posts: 6
Joined: Sat Apr 25, 2020 9:42 pm
Contact:

Re: lexicon omega: 2 channels instead of 4 ?

Post by spadan »

I did it but the server "cannot be started"

Code: Select all

JACK server starting in realtime mode with priority 10
self-connect-mode is "Don't restrict self connect requests"
audio_reservation_init
Acquire audio card Audio1
creating alsa driver ... hw:Omega|hw:Omega|256|2|44100|4|2|nomon|swmeter|-|32bit
configuring for 44100Hz, period = 256 frames (5.8 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 24bit little-endian in 3bytes format
ALSA: cannot set channel count to 4 for capture
ALSA: cannot configure capture channel
Released audio card Audio1
audio_reservation_finish
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server
11:17:00.059 JACK was stopped
11:17:02.164 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
musciencia
Posts: 1
Joined: Fri Jun 26, 2020 11:05 am

Re: lexicon omega: 2 channels instead of 4 ?

Post by musciencia »

I have the same problem. But here is what I have found so far:

I have used Lexicon Omega with Ubuntu Studio for years without any problems until I upgraded to Ubuntu Studio 20.04.
After tryting diferent versions of Ubuntu Studio I notticed that the 2 channels instead of 4 issue started with kernel 4.15.0-101.

In other words:
On Ubuntu Studio 18.04.4 with kernel 4.15.0-20, Lexicon Omega works great. No problems at all.
On Ubuntu Studio 18.04.4 with kernel 4.15.0-101 (and later), Lexicon Omega can only capture 2 channels. Or at least I can only see 2 capture channels in qjackctl.

I'm still using Ubuntu Studio 18.04.4 with kernel 4.15.0-20, but it would be nice to be able to upgrade.
User avatar
nikgnomicradio
Established Member
Posts: 99
Joined: Wed Feb 07, 2018 9:31 pm
Contact:

Re: lexicon omega: 2 channels instead of 4 ?

Post by nikgnomicradio »

spadan wrote: Mon Apr 27, 2020 9:19 am

Code: Select all

ALSA: cannot set channel count to 4 for capture
ALSA: cannot configure capture channel
if JACK cannot start with 4 capture channels, try starting with only 2 channels and add the other 2 later

This interface will probably have 2 subdevices in ALSA (see aplay -l)
each subdevice will be capable of 2 channels of audio capture

change JACK settings to:
  • Input Device: hw:Omega,0 channels: 2
  • Output Device: hw:Omega,0 channels: 2
(hw:Omega,0 is first subdevice, instead of hw:Omega for the whole device)

if JACK can be started with 2 capture channels, the additional 2 capture channels from the 2nd subdevice could be added with:

Code: Select all

/usr/bin/alsa_in -d hw:Pro,1 > /dev/null 2>&1 &
also suggest periods/buffer = 3 is usually optimal setting for a USB device

and try using Sample Rate = 48000Hz instead of 44100Hz - JACK always seems to run better at 48000Hz
spadan
Established Member
Posts: 6
Joined: Sat Apr 25, 2020 9:42 pm
Contact:

Re: lexicon omega: 2 channels instead of 4 ?

Post by spadan »

Thank you nikgnomicradio.

I have just tried the code you suggest:

Code: Select all

/usr/bin/alsa_in -d hw:Pro,1 > /dev/null 2>&1 &
without any error.

But starting up qjackctl it stops with this message:

Code: Select all

17:17:46.891 /usr/bin/jackd -dalsa -r44100 -p256 -n2 -D -Chw:Omega -Phw:Omega -i4 -o2
17:17:46.893 JACK was started with PID=9939.
no message buffer overruns
no message buffer overruns
no message buffer overruns
jackdmp 1.9.12
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2017 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
self-connect-mode is "Don't restrict self connect requests"
audio_reservation_init
Acquire audio card Audio1
creating alsa driver ... hw:Omega|hw:Omega|256|2|44100|4|2|nomon|swmeter|-|32bit
configuring for 44100Hz, period = 256 frames (5.8 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 24bit little-endian in 3bytes format
ALSA: cannot set channel count to 4 for capture
ALSA: cannot configure capture channel
Released audio card Audio1
audio_reservation_finish
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server
17:17:46.978 JACK was stopped
17:17:49.056 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
User avatar
nikgnomicradio
Established Member
Posts: 99
Joined: Wed Feb 07, 2018 9:31 pm
Contact:

Re: lexicon omega: 2 channels instead of 4 ?

Post by nikgnomicradio »

same error as before

Code: Select all

ALSA: cannot set channel count to 4 for capture
check if QjackCtl settings changed to 2 capture channels
reboot system if new settings are not being recognised

when JACK is started with 2 capture channels, the alsa_in command can add the other 2 channels
HarryR
Posts: 1
Joined: Thu Dec 22, 2016 2:10 pm

Re: lexicon omega: 2 channels instead of 4 ?

Post by HarryR »

Hi everybody,

seems i ran into this problem too ..

I was nearby a heart attack, it took me a whole weekend
to find out this problem has nothing to do with my hardware or configuration.

I found one system on a multi-boot system,
which has not been updated for long (Ubuntustudio 18.04)
.. it won't be updated till this problem gets a solution in the actual kernel ..

How can we tell the kernel-maintainers
that this problem needs a solution ?

Best regards
spadan
Established Member
Posts: 6
Joined: Sat Apr 25, 2020 9:42 pm
Contact:

Re: lexicon omega: 2 channels instead of 4 ?

Post by spadan »

nikgnomicradio wrote: Sun Jul 12, 2020 7:56 am when JACK is started with 2 capture channels, the alsa_in command can add the other 2 channels
How could I verify the number of channels ?
In fact the Ardour's input are still 2 :-(
bengan
Established Member
Posts: 3
Joined: Mon Jun 29, 2009 7:18 am

Re: lexicon omega: 2 channels instead of 4 ?

Post by bengan »

HarryR wrote: Wed Nov 04, 2020 7:33 am How can we tell the kernel-maintainers
that this problem needs a solution ?
You need to file a bug report to the alsa/kernel maintainers at Ubuntu.

Start here:
https://help.ubuntu.com/stable/ubuntu-h ... ug.html.en
@nnms
Established Member
Posts: 5
Joined: Wed Nov 18, 2015 4:29 pm

Re: lexicon omega: 2 channels instead of 4 ?

Post by @nnms »

nikgnomicradio wrote: Sun Jun 28, 2020 6:09 am
spadan wrote: Mon Apr 27, 2020 9:19 am

Code: Select all

ALSA: cannot set channel count to 4 for capture
ALSA: cannot configure capture channel
if JACK cannot start with 4 capture channels, try starting with only 2 channels and add the other 2 later

This interface will probably have 2 subdevices in ALSA (see aplay -l)
each subdevice will be capable of 2 channels of audio capture

change JACK settings to:
  • Input Device: hw:Omega,0 channels: 2
  • Output Device: hw:Omega,0 channels: 2
(hw:Omega,0 is first subdevice, instead of hw:Omega for the whole device)

if JACK can be started with 2 capture channels, the additional 2 capture channels from the 2nd subdevice could be added with:

Code: Select all

/usr/bin/alsa_in -d hw:Pro,1 > /dev/null 2>&1 &
also suggest periods/buffer = 3 is usually optimal setting for a USB device

and try using Sample Rate = 48000Hz instead of 44100Hz - JACK always seems to run better at 48000Hz
Hello I have the same issue with lexicon omega and ubuntu studio 20.04, (same problem on debian 10, work with debian 9)

@nikgnomicradio I try to do what you say, indeed I see two entry with the aplay -l command

Code: Select all

**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: Omega [Lexicon Omega], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 0/1
  Sous-périphérique #0: subdevice #0
carte 0: Omega [Lexicon Omega], périphérique 1: USB Audio [USB Audio #1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
I have configured jack as you said but when I enter the command

Code: Select all

/usr/bin/alsa_in -d hw:Pro,1 > /dev/null 2>&1 &
alsa_in start and stop instantely

Code: Select all

10:34:44.292 Changement du graphique des connexions JACK.
Tue Jan 12 10:34:44 2021: New client 'alsa_in' with PID 4522
Tue Jan 12 10:34:44 2021: Client 'alsa_in' with PID 4522 is out
Can you explain the command

Code: Select all

/usr/bin/alsa_in -d hw:Pro,1 > /dev/null 2>&1 &

I know -d is for set the device what "Pro" signify ? and "> /dev/null 2>&1 &"

(sorry for my bad english :oops: )
User avatar
nikgnomicradio
Established Member
Posts: 99
Joined: Wed Feb 07, 2018 9:31 pm
Contact:

Re: lexicon omega: 2 channels instead of 4 ?

Post by nikgnomicradio »

I know -d is for set the device what "Pro" signify ? and "> /dev/null 2>&1 &"
I must apologise for a silly error on my part :oops:
I must have overlooked changing the name when I copied this
'Pro' was the name of the audio device used where i had first seen this idea mentioned

the correct command should have been:

Code: Select all

/usr/bin/alsa_in -d hw:Omega,1 > /dev/null 2>&1 &
"-d hw:Omega,1" is for the 2nd ALSA subdevice

"> /dev/null 2>&1" discards any terminal messages or errors (by redirecting them to /dev/null)

"&" makes the command run as a background process (the ALSA connection will remain if the terminal is closed)
spadan
Established Member
Posts: 6
Joined: Sat Apr 25, 2020 9:42 pm
Contact:

Re: lexicon omega: 2 channels instead of 4 ?

Post by spadan »

Thank you nikgnomicradio.
I'm sorry but I am a bit lost. What should I expect after

Code: Select all

/usr/bin/alsa_in -d hw:Omega,1 > /dev/null 2>&1 &

Maybe better, what should I do ?
I do not get any error both with qjackd and ardour but I still find the 2in - and not 4in - channels.
Post Reply