Matching Equalizer

All your LV2 and LADSPA goodness and more.

Moderators: khz, MattKingUSA

tramp
Established Member
Posts: 1452
Joined: Mon Jul 01, 2013 8:13 am

Re: Matching Equalizer

Postby tramp » Fri Jul 12, 2019 4:58 am

ufug wrote:Looking forward to seeing what I can do with this one!

Glad you are back at it, tramp. I was just wondering what you were up to the other day when gxSVT saved the day for me on a weak bass track...


Hi ufug

I'm a freelancer, some times I need to do stuff for money. Some times then I've out of time for month's :(
On the road again.

tramp
Established Member
Posts: 1452
Joined: Mon Jul 01, 2013 8:13 am

Re: Matching Equalizer

Postby tramp » Fri Jul 12, 2019 5:39 am

@funkmuscle

So I've followed @sadko4u's suggestion and implement a new denormal protection routine, please check out if that helps.

@sadko4u
This is the commit :
https://github.com/brummer10/GxMatchEQ. ... 3cbf28a0a3

Do you think it's right done this time?
On the road again.

User avatar
sadko4u
Established Member
Posts: 701
Joined: Mon Sep 28, 2015 9:03 pm

Re: Matching Equalizer

Postby sadko4u » Fri Jul 12, 2019 8:01 am

tramp wrote:@funkmuscle

So I've followed @sadko4u's suggestion and implement a new denormal protection routine, please check out if that helps.

@sadko4u
This is the commit :
https://github.com/brummer10/GxMatchEQ. ... 3cbf28a0a3

Do you think it's right done this time?


Yes, it seems to be much prettier now but there are some things that I've commented directly on GitHub. When it's ready, it would be interesting to see how funkmuscle's machine will handle the final change.
According to my experience, LSP Parametric Equalizer x32 wouldn't work well if DAZ and FTZ flags were flushed. Without setting them, I got around 100% CPU load when there was no data at the input of plugin with pretty simple settings.
LSP (Linux Studio Plugins) Developer and Maintainer.

tramp
Established Member
Posts: 1452
Joined: Mon Jul 01, 2013 8:13 am

Re: Matching Equalizer

Postby tramp » Fri Jul 12, 2019 9:33 am

A shiny new denormal protection is now sponsored by sadko4u. Thanks a lot @sadko4u.

Now, @funkmuscle it 's a good time to do a new checkout and tell us, if that solved your issue.

When done, we could go forward to implement some of the suggestions from this thread. Thank's therefore as well, to all.
On the road again.

User avatar
funkmuscle
Established Member
Posts: 2289
Joined: Mon Jun 02, 2008 2:30 pm

Re: Matching Equalizer

Postby funkmuscle » Fri Jul 12, 2019 10:40 am

tramp wrote:Now, @funkmuscle it 's a good time to do a new checkout and tell us, if that solved your issue.

When done, we could go forward to implement some of the suggestions from this thread. Thank's therefore as well, to all.

Mixbus 32C I can only mix with as it uses up too much resources so I do get higher dsp percentages.
I just tried matchEQ in Ardour with just recorded track, no plugins. DSP load was 4%. Added matchEQ and it jumped to 8%. Hit play and it jumped up between 8% and 14%.
I don't really use Carla that much or jalv. Only if I need a plugin in a standalone mode.

tramp
Established Member
Posts: 1452
Joined: Mon Jul 01, 2013 8:13 am

Re: Matching Equalizer

Postby tramp » Fri Jul 12, 2019 10:56 am

funkmuscle wrote:I just tried matchEQ in Ardour with just recorded track, no plugins. DSP load was 4%. Added matchEQ and it jumped to 8%. Hit play and it jumped up between 8% and 14%.


So is that now with the latest git checkout, or before? As that isn't that bad (stereo track?).
Could you use it in Mixbus without receiving Xruns after a fresh checkout?
On the road again.

User avatar
funkmuscle
Established Member
Posts: 2289
Joined: Mon Jun 02, 2008 2:30 pm

Re: Matching Equalizer

Postby funkmuscle » Fri Jul 12, 2019 11:02 am

tramp wrote:
funkmuscle wrote:I just tried matchEQ in Ardour with just recorded track, no plugins. DSP load was 4%. Added matchEQ and it jumped to 8%. Hit play and it jumped up between 8% and 14%.


So is that now with the latest git checkout, or before? As that isn't that bad (stereo track?).
Could you use it in Mixbus without receiving Xruns after a fresh checkout?

fresh checkout won't build:

Code: Select all

$ make
. . \033[1;34m, clean up\033[0m
g++ -D_FORTIFY_SOURCE=2 -I. -I./dsp -I./plugin -fPIC -DPIC -O2 -Wall -fstack-protector -funroll-loops -ffast-math -fomit-frame-pointer -fstrength-reduce -fdata-sections -Wl,--gc-sections -Wl,-z,relro,-z,now -msse3 -mfpmath=sse plugin/gx_matcheq.cpp  -I. -shared -lm -lm -Wl,-z,noexecstack  -o gx_matcheq.so
In file included from plugin/gx_matcheq.cpp:31:
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/include/fxsrintrin.h:25:3: error: #error "Never use <fxsrintrin.h> directly; include <immintrin.h> instead."
   25 | # error "Never use <fxsrintrin.h> directly; include <immintrin.h> instead."
      |   ^~~~~
make: *** [Makefile:104: gx_matcheq] Error 1

That was my next question, will the plugin be stereo so it could be used in the Master bus as a mixing tool?

tramp
Established Member
Posts: 1452
Joined: Mon Jul 01, 2013 8:13 am

Re: Matching Equalizer

Postby tramp » Fri Jul 12, 2019 11:32 am

funkmuscle wrote:25 | # error "Never use <fxsrintrin.h> directly; include <immintrin.h> instead."


Umpf, those Arch users, always on the blending age. 8)
Okay, I've pushed a fix, please try again.
On the road again.

User avatar
funkmuscle
Established Member
Posts: 2289
Joined: Mon Jun 02, 2008 2:30 pm

Re: Matching Equalizer

Postby funkmuscle » Fri Jul 12, 2019 11:49 am

tramp wrote:
funkmuscle wrote:25 | # error "Never use <fxsrintrin.h> directly; include <immintrin.h> instead."


Umpf, those Arch users, always on the blending age. 8)
Okay, I've pushed a fix, please try again.

so it built! Better performance too. DSP started at 54% and jumped to 65% Before it was hitting 70% to 90%

User avatar
sadko4u
Established Member
Posts: 701
Joined: Mon Sep 28, 2015 9:03 pm

Re: Matching Equalizer

Postby sadko4u » Fri Jul 12, 2019 12:56 pm

funkmuscle wrote:
tramp wrote:
funkmuscle wrote:25 | # error "Never use <fxsrintrin.h> directly; include <immintrin.h> instead."


Umpf, those Arch users, always on the blending age. 8)
Okay, I've pushed a fix, please try again.

so it built! Better performance too. DSP started at 54% and jumped to 65% Before it was hitting 70% to 90%


Do I right understand that before you added a plugin, you had low DSP utilization (<= 5%).
When you've added a new version of plugin, you get minimum 54% and maximum 65% of the DSP load?
And previous version of plugin had minimum 70% and maximum 90% CPU load?
LSP (Linux Studio Plugins) Developer and Maintainer.

User avatar
funkmuscle
Established Member
Posts: 2289
Joined: Mon Jun 02, 2008 2:30 pm

Re: Matching Equalizer

Postby funkmuscle » Fri Jul 12, 2019 1:05 pm

sadko4u wrote:
funkmuscle wrote:
tramp wrote:
Umpf, those Arch users, always on the blending age. 8)
Okay, I've pushed a fix, please try again.

so it built! Better performance too. DSP started at 54% and jumped to 65% Before it was hitting 70% to 90%


Do I right understand that before you added a plugin, you had low DSP utilization (<= 5%).
When you've added a new version of plugin, you get minimum 54% and maximum 65% of the DSP load?
And previous version of plugin had minimum 70% and maximum 90% CPU load?

Sorry I made a mistake and I clicked on the wrong thing Vladimir so it may look like I reported your post. Sorry about that. To answer your question yes with the old version it jumped anywhere starting at about 54% and it would jump up to about 70% to 90%. Now with the new version it jumped from 54% up to 65% and it's running smoothly and I'm not getting any popping sounds.
Once again sorry for clicking the wrong button and it going as if I'm reporting the post.

tramp
Established Member
Posts: 1452
Joined: Mon Jul 01, 2013 8:13 am

Re: Matching Equalizer

Postby tramp » Fri Jul 12, 2019 3:02 pm

funkmuscle wrote:To answer your question yes with the old version it jumped anywhere starting at about 54% and it would jump up to about 70% to 90%. Now with the new version it jumped from 54% up to 65% and it's running smoothly and I'm not getting any popping sounds.


To get it right in context, you said, you've a Mixbus session using 54% DSP load, then you add GxMatchEQ and archive a DSP load around 65%.
So, GxMatchEQ using 10% DSP load on this session?

Or, did the dsp load jump from ~5% to 54% just when loading GxMatchEQ?
On the road again.

User avatar
funkmuscle
Established Member
Posts: 2289
Joined: Mon Jun 02, 2008 2:30 pm

Re: Matching Equalizer

Postby funkmuscle » Fri Jul 12, 2019 3:20 pm

tramp wrote:
funkmuscle wrote:To answer your question yes with the old version it jumped anywhere starting at about 54% and it would jump up to about 70% to 90%. Now with the new version it jumped from 54% up to 65% and it's running smoothly and I'm not getting any popping sounds.


To get it right in context, you said, you've a Mixbus session using 54% DSP load, then you add GxMatchEQ and archive a DSP load around 65%.
So, GxMatchEQ using 10% DSP load on this session?

Or, did the dsp load jump from ~5% to 54% just when loading GxMatchEQ?

The mix bus session started at 54% and jumped 10% when the matching equalizer was added and while it's running it may sometimes go up to about 67% but it stayed roughly between 64 + 65%
I'm not having an issue right now because yesterday when it was going all the way up to 90 I was getting a popping cracking sound but now it's running as it normally would.

tramp
Established Member
Posts: 1452
Joined: Mon Jul 01, 2013 8:13 am

Re: Matching Equalizer

Postby tramp » Fri Jul 12, 2019 3:24 pm

Okay, thanks. Means sadko4u's fix work very well.
Thanks again sadko4u. :D
On the road again.

User avatar
funkmuscle
Established Member
Posts: 2289
Joined: Mon Jun 02, 2008 2:30 pm

Re: Matching Equalizer

Postby funkmuscle » Fri Jul 12, 2019 3:27 pm

tramp wrote:Okay, thanks. Means sadko4u's fix work very well.
Thanks again sadko4u. :D

Whenever you two guys put out a plug-in, it's exciting for my end. Can't stop thanking the two of you guys and everyone else that chips in to help you guys and all the other guys that are investing time making plugins.


Return to “Plugins, Effects and Instruments”

Who is online

Users browsing this forum: No registered users and 8 guests