unable to install muse-3.0.2. on debian 9

MusE is a MIDI/Audio sequencer with recording and editing capabilities, aiming to be a complete multitrack virtual studio for Linux. https://muse-sequencer.org/

Moderators: MattKingUSA, khz, spamatica

Post Reply
hdr
Established Member
Posts: 121
Joined: Sun Feb 03, 2019 1:47 pm

unable to install muse-3.0.2. on debian 9

Post by hdr »

It's not possible to install muse-3.0.2. on my debian 9 system

What I did:
  1. download: https://sourceforge.net/projects/lmuse/ ... rror=netix
  2. follow the steps 'Building MusE under Ubuntu:' in the README file:

    Code: Select all

    apt-get install build-essential cmake libsndfile1-dev libsamplerate0-dev libjack-jackd2-dev ladspa-sdk qt5-default qttools5-dev qttools5-dev-tools liblo-dev dssi-dev lv2-dev libsamplerate0-dev libsndfile1-dev git libfluidsynth-dev libgtkmm-2.4-dev librtaudio-dev libqt5svg5-dev libinstpatch-dev
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    build-essential is already the newest version (12.3).
    cmake is already the newest version (3.7.2-1).
    ladspa-sdk is already the newest version (1.13-3).
    libsamplerate0-dev is already the newest version (0.1.8-8+b2).
    libsndfile1-dev is already the newest version (1.0.27-3).
    lv2-dev is already the newest version (2:1.15.5+git20190124v5).
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     qt5-default : Depends: qtbase5-dev but it is not going to be installed
     qttools5-dev : Depends: qtbase5-dev but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    
  3. trying to install the unmet dependencies manually:

    Code: Select all

    apt-get install qtbase5-dev
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     qtbase5-dev : Depends: libgl1-mesa-dev but it is not going to be installed or
                            libgl-dev
                   Depends: libglu1-mesa-dev but it is not going to be installed or
                            libglu-dev
    E: Unable to correct problems, you have held broken packages.
    
That doesn't help, see also viewtopic.php?f=61&t=19713#p103853

Does anybody have an idea?
OS: Debian 10 DAW: Ardour 6.2

hdr
Established Member
Posts: 121
Joined: Sun Feb 03, 2019 1:47 pm

Re: unable to install muse-3.0.2. on debian 9

Post by hdr »

I am using backports. Might this be a reason for this problem?
OS: Debian 10 DAW: Ardour 6.2

User avatar
Linuxmusician01
Established Member
Posts: 702
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: unable to install muse-3.0.2. on debian 9

Post by Linuxmusician01 »

You've run into dependency hell. Did you run apt-get update first? Do you use the unstable, stable or testing version of Debian?

hdr
Established Member
Posts: 121
Joined: Sun Feb 03, 2019 1:47 pm

Re: unable to install muse-3.0.2. on debian 9

Post by hdr »

Yes I ran

Code: Select all

apt-get update
apt-get upgrade
apt-get dist-upgrade
I'm using the stable version
OS: Debian 10 DAW: Ardour 6.2

Post Reply