Scarlett 2i2 could not reconnect to audio/MIDI engine

Still new to all of this? Feel free to post in any of the subforums on this site, but in this subforum newbie questions are especially encouraged!

Moderators: khz, MattKingUSA

Post Reply
Dablackdog
Established Member
Posts: 8
Joined: Sun May 10, 2020 1:13 am

Scarlett 2i2 could not reconnect to audio/MIDI engine

Post by Dablackdog »

Hi, im wondering if anyone could help me.

Originally the audio interface was working just fine..im not sure if I changed a setting but when trying to olen Ardour now n using the scarlet solo 2i2 and creating a new session it presents me with the message "could not reconnect to audio/MIDI engine".

I also cant seem to record via audacity cuz all of the outputs come up with weird names instead of just saying the name of the interface.

Has anyone had experience with this issue before ?

User avatar
bluebell
Established Member
Posts: 1426
Joined: Sat Sep 15, 2012 11:44 am
Location: Saarland & Frankfurt, Germany

Re: Scarlett 2i2 could not reconnect to audio/MIDI engine

Post by bluebell »

There is a Solo and a 2i2, but no Solo 2i2.

I had never such issues.

Do you use jack?
Linux – MOTU UltraLite AVB – Qtractor – https://soundcloud.com/suedwestlicht

Death
Established Member
Posts: 191
Joined: Sun Oct 11, 2015 1:43 pm

Re: Scarlett 2i2 could not reconnect to audio/MIDI engine

Post by Death »

This might be something to do with exporting hardware ports. I know I did that recently (Can't remember why) and it the names for audio & midi ports changed when I looked at them in Patchage (Or maybe they had two names). When I look at them in Claudia, I think it maybe shows two entries for each, each with a different name.

So what I'm saying is, maybe this change has happened and screwed up your connections. Have a look with Claudia, Patchage or some other similar program that can do this kind of routing (Qjackctl?) to see if things are connected. Maybe post a screenshot. You are using Jack though, right? I assumed so..

Anyway, I'm no expert with this stuff. I'm usually the one asking for help but I think this is a worth a quick look if you haven't checked already :wink:

User avatar
milo
Established Member
Posts: 741
Joined: Wed Sep 06, 2017 2:55 am
Location: Southern Utah, USA
Contact:

Re: Scarlett 2i2 could not reconnect to audio/MIDI engine

Post by milo »

Also make sure the Scarlett is still plugged in. I've made that mistake before. :)

Post Reply