USB Mic fuzzy only when using alsa_in

Still new to all of this? Feel free to post in any of the subforums on this site, but in this subforum newbie questions are especially encouraged!

Moderators: khz, MattKingUSA

Post Reply
wattahay
Established Member
Posts: 4
Joined: Wed Jul 08, 2020 6:20 pm

USB Mic fuzzy only when using alsa_in

Post by wattahay »

Hi, I posted this in a different forum, because I'm very new at this. Anyway, that forum does not allow deleting, so I am still posting this here as a newb. Thank you.

My USB Mic works/sounds great over Alsa to Pulse.

My problem however is when I use it with Jack, using alsa_in, I get a LOT of noise/fuzz/static/crackle.

The noise interference is triggered by my voice, and the smallest bits of rubbing against any part of the mic.


Command:
  • alsa_in -j 'USB Mic' -q 4 -c 1 -d hw:USB &
Testing
  • I have fiddled around with various quality and period size/number settings with no difference.
  • The mic sounds fantastic when connected through other means (in audacity and other applications)
  • Yet the mic sounds terrible in both audacity and ardour when connected through alsa_in
Thank you. Any leads, advice, and/or links would be greatly appreciated. Have a great day!
:mrgreen: :P :mrgreen: :P :mrgreen: :P :mrgreen: :P :mrgreen:

wattahay
Established Member
Posts: 4
Joined: Wed Jul 08, 2020 6:20 pm

Re: USB Mic fuzzy only when using alsa_in

Post by wattahay »

So the answer was in looking at the mic's max sample rate which was in the file:

/proc/asound/USB/stream0

There it listed all the possible sample rates for the mic:

Rates: 8000, 11025, 22050, 44100, 48000

so I changed the alsa_in command:

alsa_in -r 48000 -j 'USB Mic' -q 4 -c 1 -d hw:USB &


needless to say I am a little disappointed that the mic doesn't have a higher rate
:mrgreen: :P :mrgreen: :P :mrgreen: :P :mrgreen: :P :mrgreen:

TygerTung
Established Member
Posts: 26
Joined: Sun Dec 22, 2019 11:12 pm
Location: Christchurch, New Zealand

Re: USB Mic fuzzy only when using alsa_in

Post by TygerTung »

48k is a pretty high rate anyway, CDs are only 44.1k and they sound pretty good!

Post Reply