Waves_x11 with LinVST3: it seems possible!!!

Discuss running non-Linux applications and plugins on Linux, for example via wine

Moderators: MattKingUSA, khz

Post Reply
Codesound
Established Member
Posts: 23
Joined: Mon Aug 12, 2019 12:21 pm

Waves_x11 with LinVST3: it seems possible!!!

Post by Codesound »

Hi,

This link indicates the procedure for installing WavesCentral_x11, BUT as always I find it difficult to do ...
someone is kind enough to help me in the various steps?

https://github.com/osxmidi/LinVst3/tree/master/Waves

Thanks .....

Codesound
Established Member
Posts: 23
Joined: Mon Aug 12, 2019 12:21 pm

Re: Waves_x11 with LinVST3: it seems possible!!!

Post by Codesound »

Hi,
I try to install Wavecentral_x11 with the poor guide by LinVST3: please help me.......

1: Install Wine Staging (Ubuntu needs libfaudio0) and install winetricks cmd (to workaround possible cmd problems that can cause hangs).

at this moment I installed wineHQ-staging with these commands:

sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'
sudo apt update
sudo apt upgrade
sudo add-apt-repository ppa:cybermax-dexter/sdl2-backport
sudo apt update
sudo apt upgrade
sudo apt install --install-recommends winehq-staging

and (for winetricks cmd) I simply write in the terminal this command (I hope this operation is right.....):

winetricks cmd

2: Install the mfc42 and mfc42u 32bit dll overrides into ~/.wine/drive_c/windows/syswow64 (and optionally add the dll names in winecfg's Libraries tab)

for install these dll's i write in the terminal :

winetricks -q mfc42

BUT is already installed..... AND

winetricks -q mfc42u

BUT this is the output of the terminal...

Code: Select all

kernel@kernel:~$ winetricks -q mfc42u
------------------------------------------------------
You are using a 64-bit WINEPREFIX. Note that many verbs only install 32-bit versions of packages. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug.
------------------------------------------------------
Using winetricks 20180217 - sha256sum: 1b156c616174f41df79d72a90c52eb2b110c63a6e8ecb865d303a8f9f0908924 with wine-5.0-rc4 (Staging) and WINEARCH=win64
Unknown arg mfc42u
Usage: /usr/bin/winetricks [options] [command|verb|path-to-verb] ...
Executes given verbs.  Each verb installs an application or changes a setting.

Options:
    --force           Don't check whether packages were already installed
    --gui             Show gui diagnostics even when driven by commandline
    --isolate         Install each app or game in its own bottle (WINEPREFIX)
-k, --keep_isos       Cache isos (allows later installation without disc)
    --no-clean        Don't delete temp directories (useful during debugging)
-q, --unattended      Don't ask any questions, just install automatically
-r, --ddrescue        Retry hard when caching scratched discs
    --showbroken      Even show verbs that are currently broken in wine
-t  --torify          Run downloads under torify, if available
    --verify          Run (automated) GUI tests for verbs, if available
-v, --verbose         Echo all commands as they are executed
-h, --help            Display this message and exit
-V, --version         Display version and exit

Commands:
list                  list categories
list-all              list all categories and their verbs
apps list             list verbs in category 'applications'
benchmarks list       list verbs in category 'benchmarks'
dlls list             list verbs in category 'dlls'
games list            list verbs in category 'games'
settings list         list verbs in category 'settings'
list-cached           list cached-and-ready-to-install verbs
list-download         list verbs which download automatically
list-manual-download  list verbs which download with some help from the user
list-installed        list already-installed verbs
prefix=foobar         select WINEPREFIX=/home/kernel/.local/share/wineprefixes/foobar
what I wrong?


thanks for those who want to help me.....

ubuntuuser
Established Member
Posts: 295
Joined: Mon Jan 02, 2017 9:46 am

Re: Waves_x11 with LinVST3: it seems possible!!!

Post by ubuntuuser »

Waves Central v10 used to be ok but Waves have changed to using Windows Powershell for v11 which doesn't work with Wine.

Waves Central v11 needs windows powershell which does not currently work.

User avatar
raboof
Established Member
Posts: 1727
Joined: Tue Apr 08, 2008 11:58 am
Location: Deventer, NL
Contact:

Re: Waves_x11 with LinVST3: it seems possible!!!

Post by raboof »

(moved to 'Running non-linux software' subsection, seems a bit more appropriate)

Codesound
Established Member
Posts: 23
Joined: Mon Aug 12, 2019 12:21 pm

Re: Waves_x11 with LinVST3: it seems possible!!!

Post by Codesound »

Hi,

thanks for reply....

ubuntuuser wrote:Waves Central v10 used to be ok but Waves have changed to using Windows Powershell for v11 which doesn't work with Wine.
Waves Central v11 needs windows powershell which does not currently work.
ok thanks, but I don't understand why the LinVST3 developer wrote the instructions to install waves_x11 anyway....
https://github.com/osxmidi/LinVst3/tree/master/Waves

Now I installed the wine staging version:

Code: Select all

kernel@kernel:~$ wine --version
wine-5.0-rc5 (Staging)
I hope this version is right... then I have installed the cmd, (indicated in the istructions):
winetricks cmd

Now I have trouble to install the mfc42u.dll and I don't understand how to go on
I believe that these instructions are for installing and running waves_x11 without powershell.... is right? Has anyone managed to install waves_x11 and can you help me (and help all users who would like to use waves_x11 on Linux) with the installation?

Thanks....

User avatar
TheYke
Established Member
Posts: 28
Joined: Mon Dec 16, 2019 3:57 pm

Re: Waves_x11 with LinVST3: it seems possible!!!

Post by TheYke »

Hi there,
concerning:
Codesound wrote: I believe that these instructions are for installing and running waves_x11 without powershell.... is right?
Thanks....
if you read the README on your github link carefully, you'll see that it states
Waves Central v11 needs windows powershell which does not currently work.

Codesound
Established Member
Posts: 23
Joined: Mon Aug 12, 2019 12:21 pm

Re: Waves_x11 with LinVST3: it seems possible!!!

Post by Codesound »

Codesound wrote:if you read the README on your github link carefully, you'll see that it states

Waves Central v11 needs windows powershell which does not currently work.
Ok ok, this is right; BUT is there one way to install powershell? I tried a few days ago but to no avail. I opened a thread in the WineHQ forum, but nobody answered me ....

https://forum.winehq.org/viewtopic.php?f=8&t=33326



but surely there is a way to install WavesCentral_x11, otherwise I don't understand what the developer of LinVST3 means ...
what do you think? Am I wrong? Or have I misunderstood?

Thanks for now....

ubuntuuser
Established Member
Posts: 295
Joined: Mon Jan 02, 2017 9:46 am

Re: Waves_x11 with LinVST3: it seems possible!!!

Post by ubuntuuser »

Codesound wrote:
Codesound wrote:if you read the README on your github link carefully, you'll see that it states

Waves Central v11 needs windows powershell which does not currently work.
Ok ok, this is right; BUT is there one way to install powershell? I tried a few days ago but to no avail. I opened a thread in the WineHQ forum, but nobody answered me ....

https://forum.winehq.org/viewtopic.php?f=8&t=33326



but surely there is a way to install WavesCentral_x11, otherwise I don't understand what the developer of LinVST3 means ...
what do you think? Am I wrong? Or have I misunderstood?

Thanks for now....
The previous version of Waves Central was version 10 (Waves Central v10).

The new version of Waves Central is version 11 (Waves Central v11).

Waves Central v11 needs Windows Powershell.

The previous Waves Central v10 didn't need Powershell.

Windows Powershell does not currently run under Wine in a compatible way for Waves Central v11.

The instructions in the LinVst Waves file are for Waves Central v10 (which Waves doesn't support anymore).

A notice was put at the top of the LinVst Waves file saying that Waves Central v11 does not currently work with Wine because of Windows Powershell being needed.

The rest of the instructions in the LinVst Waves file are defunct for Waves Central v11, which the notice at the top of the LinVst Waves file makes pretty clear.

Codesound
Established Member
Posts: 23
Joined: Mon Aug 12, 2019 12:21 pm

Re: Waves_x11 with LinVST3: it seems possible!!!

Post by Codesound »

@ubuntuuser thanks, especially for your patience!

At this point it is better to hope that the day will come when the windows powershell will be integrated into wine ....

Post Reply