LinVST - working plugs / libraries you use for compatibility (March 2019)

Discuss running non-Linux applications and plugins on Linux, for example via wine

Moderators: MattKingUSA, khz

Kott
Established Member
Posts: 279
Joined: Thu Mar 21, 2013 12:55 am
Location: Vladivostok

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Post by Kott »

D16 Nithonat (crashes on double click in preset browser, not critical because selection works fine without double click)
Celemony Melodyne4 Essential

ubuntuuser
Established Member
Posts: 286
Joined: Mon Jan 02, 2017 9:46 am

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Post by ubuntuuser »

gennargiu wrote:hi with av linux 64 and pre installed lin vst i stay test my plug in licenced on windows.....crystal grenoak,waldorf edition 2.1,korg m1, korg monopoly,korg ms 20,korg wavestation,free alpha (lin plug in) arturia jupiter 8v2 and prophet v2 works.....native instruments i have some problems with native access and various plug in (absynth 5,reaktor 5 and other)

gennaro
You could try the latest version that's on GitHub and see if that helps.

pedrobotero
Established Member
Posts: 19
Joined: Thu Oct 18, 2018 10:08 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Post by pedrobotero »

pedrobotero wrote:Hi everyone,

When I load the windows plugins NAdIR2.0 and Emissary2.0 on Reaper linux version they load with black background and they don't load with their graphic interface.

I used LinVst-2.5 to convert this plugins.

With lepoul plugins this doesn't happen and they load correctly.

Can anybody help me?

link to download the plugins https://www.stltones.com/products/stl-i ... -in-bundle

thanks so much and sorry for my english :-D

Regards
I have uninstalled wine-rt and installed wine-4.10 Staging.

Now Emissary 2.0 and NadIR 1.0 plugins load correctly but NadIR 2.0 doesn't load well (I tried activating and deactivating d2d1 library)

tavasti
Established Member
Posts: 1082
Joined: Tue Feb 16, 2016 6:56 am
Location: Kangasala, Finland
Contact:

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Post by tavasti »

I have few plugins from Ugritone that work ok:
- Anarchy Drums (minor glitch in UI, tab labels in UI are empty)
- Riot Drums (minor glitch in UI, tab labels in UI are empty)
- Trve Cab IR loader

Edit:
- Assault Drums, great 80s-90s metal/rock drums, works perfectly!
- KVLT II drums, great drums for various styles, works perfectly

Others than Ugritone.
- Fathom Synth, works perfectly, but does not work if your vst directory is symlinked. Heavy on cpu usage.
Last edited by tavasti on Sun May 10, 2020 10:53 am, edited 3 times in total.
Linux veteran & Novice musician

Latest track: https://www.youtube.com/watch?v=ycVrgGtrBmM
More my music https://audiu.net/users/tawaste

User avatar
GMaq
Established Member
Posts: 1638
Joined: Fri Sep 25, 2009 1:42 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Post by GMaq »

Hi,

Not sure if this a place to report plugins that stopped working or not, if not please direct me where to post that info..

I had CamelCrusher (great overdrive saturation plugin) working well without any extra fonts or overrides but it has stopped working and I think perhaps wine-staging 5+ is the culprit. Anyone else using CamelCrusher or noticed that it quit working?

carlv
Established Member
Posts: 165
Joined: Tue Jul 12, 2016 6:10 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Post by carlv »

GMaq wrote:
Mon Apr 20, 2020 9:46 pm
...I think perhaps wine-staging 5+ is the culprit.
Just tried in both Ardour and Mixbus, no problem running under LinVst/winehq-devel_5.6 (Ubuntu 18.04.4 LTS). Been using it since the earlier part of last summer, accepting all updates. Had only one hiccup with an update.
CamelCrusher (by Camel Audio)_008.png
You do not have the required permissions to view the files attached to this post.

User avatar
GMaq
Established Member
Posts: 1638
Joined: Fri Sep 25, 2009 1:42 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Post by GMaq »

Thanks for the info @carlv

Post Reply