LinVST - working plugs / libraries you use for compatibility (March 2019)

Discuss running non-Linux applications and plugins on Linux, for example via wine

Moderators: khz, MattKingUSA

Mk2
Established Member
Posts: 69
Joined: Sat Sep 10, 2016 8:28 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby Mk2 » Fri Mar 08, 2019 6:18 pm

sysrqer wrote:
Linuxmusician01 wrote:In Qtractor I can get no synthesizer .dll plugin whatsoever working with LinVST. All the buttons and knobs of the synths go berserk (keep on turning frantically, go on and off 1.000 times a second etc.). So my list is empty. LinVST bridged plugins might work in other DAW's though...

Just my 2 cents. :roll:

I can load all of my win vsts (synths make sound) in qtractor but none of the guis will show. Seems like there are a few problems there.


it maybe related to the daw..

Mk2
Established Member
Posts: 69
Joined: Sat Sep 10, 2016 8:28 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby Mk2 » Fri Mar 08, 2019 6:21 pm

sysrqer wrote:Dune, Dune 2, The Glue, Ozone 6/7/8, Analogic Delay (and the others in the series), all the fabfilter plugins, kclip, psp plugins, Sony Oxford, Stillwell, Tokyo Dawn plugins, Toneboosters, URS, Valhalla, Variety of Sound, Wavearts5, Nova67p, Synth1, Diversion, FM8, Massive, Kairatune, Surge, Serum, Waves (not sure which version it was).

Had all those working before without any effort (I think Serum needed something but don't remember what). From my experience it's an exception if something doesn't work.


thx sysrqer ! added your list to post #1, + for Serum you must use "D2D1" library (disabled or native... at choice...) for it to work. (read post #1 "Serum" and/with "Omnisphere".)

for all plugs i use "d2d1" & "gdiplus". sometimes the audio engine freezes in Bitwig, maybe when CPU/DSP goes high... but i can compose/plugins work.

User avatar
Linuxmusician01
Established Member
Posts: 683
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby Linuxmusician01 » Fri Mar 08, 2019 6:30 pm

sysrqer wrote:
Linuxmusician01 wrote:In Qtractor I can get no synthesizer .dll plugin whatsoever working with LinVST. All the buttons and knobs of the synths go berserk (keep on turning frantically, go on and off 1.000 times a second etc.). So my list is empty. LinVST bridged plugins might work in other DAW's though...

Just my 2 cents. :roll:

I can load all of my win vsts (synths make sound) in qtractor but none of the guis will show. Seems like there are a few problems there.

I added this to my post above: "Correction: 32 bit VST's bridged via LinVST don't work in Qtractor. Downloaded a 64 bit one from here and it does work... For 32 bit (Windows) VST's in Qtractor you can use the DSSI bridged one or the Carla bridged one."

What version of Qtractor do you use? I use 0.9.1 from the KXStudio repository.

User avatar
sysrqer
Established Member
Posts: 1835
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby sysrqer » Fri Mar 08, 2019 6:41 pm

Mk2 wrote:
sysrqer wrote:
Linuxmusician01 wrote:In Qtractor I can get no synthesizer .dll plugin whatsoever working with LinVST. All the buttons and knobs of the synths go berserk (keep on turning frantically, go on and off 1.000 times a second etc.). So my list is empty. LinVST bridged plugins might work in other DAW's though...

Just my 2 cents. :roll:

I can load all of my win vsts (synths make sound) in qtractor but none of the guis will show. Seems like there are a few problems there.


it maybe related to the daw..

Definitely, they work in renoise, reaper, ardour.

User avatar
sysrqer
Established Member
Posts: 1835
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby sysrqer » Fri Mar 08, 2019 6:42 pm

Linuxmusician01 wrote:What version of Qtractor do you use? I use 0.9.1 from the KXStudio repository.

Yeah I'm using the kxstudio version as well. All my vsts are 32 bit so that makes sense.

Mk2
Established Member
Posts: 69
Joined: Sat Sep 10, 2016 8:28 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby Mk2 » Fri Mar 08, 2019 7:51 pm

sysrqer wrote:
Linuxmusician01 wrote:What version of Qtractor do you use? I use 0.9.1 from the KXStudio repository.

Yeah I'm using the kxstudio version as well. All my vsts are 32 bit so that makes sense.


i have impression 32 bits works better than 64 bits in general.... apart Omnisphere that is x64 since 2.5.

i gonna add some verb plugs... some works, protoverb ask for a .txt file / permissions, wont work.. any fix ?

also, did u successfully installed ILOK anyone ?

User avatar
sysrqer
Established Member
Posts: 1835
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby sysrqer » Fri Mar 08, 2019 8:19 pm

Yeah my experience was that 32 bit works better overall, but that experience was a while ago so may not be up to date now. It works for me so I haven't had any need to experiment.

Mk2
Established Member
Posts: 69
Joined: Sat Sep 10, 2016 8:28 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby Mk2 » Fri Mar 29, 2019 4:23 am

MPX Lexicon > OK.......;

use "winetricks" to include the library. I am using wine version 4.2 (not staging).
1 - go to your terminal
2 - digit "winetricks"
3 - check mark "select default wineprefix"
4 - press OK
5 - check mark "install a windows dll or component"
6- press OK
7 - choose mfc42.dll
8-then follow with OK and you are done.
_____________************************
9-just install mpx lexicon


TY "M...."..........

(ilok / pace installer has no worked.)

Vrangor
Established Member
Posts: 37
Joined: Fri Apr 25, 2014 11:47 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby Vrangor » Tue Apr 23, 2019 5:59 am

Variety of Sound, LePou, Voxengo(only free ones tested), Kjaerhus classic series, Damage Audio Rough Rider and Ignite Amps with no tweaks in Reaper and Mixbus using LinVst, KxStudio wine-rt and LMDE2.

Mk2
Established Member
Posts: 69
Joined: Sat Sep 10, 2016 8:28 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby Mk2 » Fri Apr 26, 2019 6:36 am

badly, i had to left the mpx on a lexicon usb dongle... coz they never respect libertad... so u got to deal with that.

3..............

stanlea
Established Member
Posts: 602
Joined: Wed Apr 25, 2012 9:49 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby stanlea » Sat May 04, 2019 7:47 am

NI Reaktor works

Zplane Vielklang can't show GUI

glowrak guy
Established Member
Posts: 1380
Joined: Sat Jun 21, 2014 8:37 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby glowrak guy » Tue May 14, 2019 9:18 pm

Fathom modular synth (newest 2.31) seems fine by linvst,
latest linux Reaper and wine-staging. There is a free mono version,
a CM magazine version (many tutorials in the last two mag issues,
and if you buy the full version, any small-dollah updates you buy
will reduce your good customers price of the super-deluxe edition later on.

It's rare to have a plugin work in wine/reaper, but not work
in linux/reaper when wrapped by linvst.
Cheers

User avatar
gennargiu
Established Member
Posts: 276
Joined: Sun Dec 18, 2016 9:56 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby gennargiu » Tue May 28, 2019 5:27 pm

hi with av linux 64 and pre installed lin vst i stay test my plug in licenced on windows.....crystal grenoak,waldorf edition 2.1,korg m1, korg monopoly,korg ms 20,korg wavestation,free alpha (lin plug in) arturia jupiter 8v2 and prophet v2 works.....native instruments i have some problems with native access and various plug in (absynth 5,reaktor 5 and other)

gennaro
Hp Elite 8200 3,1 Ghz - 16 Giga Ram Hd 2 Terabyte - studiomusic64-Ubuntu Studio 18.04-Ardour 5,12 - Mixbus 5
Asus X54c - studiomusic64- Mx Linux 19.3-Ardour 5.12- Mixbus 5-RPI3 + Raspbian Buster- Rpi4 (4giga ram)

artofmusic
Established Member
Posts: 89
Joined: Mon Mar 17, 2014 8:01 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby artofmusic » Wed May 29, 2019 10:04 am

ARIA Player/sforzando sfz player work great if you install corefonts and tahoma via winetricks. Works with linvst or carla bridges and can get down to buffer sizes of 64/128 if you have a recent i5 or ryzen 5 system.

User avatar
gennargiu
Established Member
Posts: 276
Joined: Sun Dec 18, 2016 9:56 pm

Re: LinVST - working plugs / libraries you use for compatibility (March 2019)

Postby gennargiu » Thu May 30, 2019 9:16 pm

Hi update list of plug in lin vst work in avlinux 64 - arturia jupiter 8v2 - 8v3 - prophet vs 2 - prophet vs 3 - absynth 4 - fm8 :wink:

gennaro

PS: i have used for test Waveform 9 trackion daw . In Ardour 5.12 and mixbus 5.2 i must start new testing....
Hp Elite 8200 3,1 Ghz - 16 Giga Ram Hd 2 Terabyte - studiomusic64-Ubuntu Studio 18.04-Ardour 5,12 - Mixbus 5
Asus X54c - studiomusic64- Mx Linux 19.3-Ardour 5.12- Mixbus 5-RPI3 + Raspbian Buster- Rpi4 (4giga ram)


Return to “Running non-linux software”

Who is online

Users browsing this forum: No registered users and 1 guest