[SOLVED] Can't get linvst to work on Mint 20

Discuss running non-Linux applications and plugins on Linux, for example via wine

Moderators: MattKingUSA, khz

Post Reply
kirjis
Established Member
Posts: 6
Joined: Mon Sep 07, 2020 8:24 am

[SOLVED] Can't get linvst to work on Mint 20

Post by kirjis »

I was using linvst with great success on Mint 18.3 for a couple of years, but after I got my new laptop, I just can't get it to work at all. Carla runs my WinVST's (v. 2 and 3) happily.
I've installed and purged and reinstalled Wine and .wine many times and use only two plugins to test (one 64 bit and other 32 bit). I have the multiarch libs installed. I've tried linvst 3.0 and 2.8 from DEB package and tarball. I'm using now linvstmanager to help in testing, but the result is the same. No joy. I'm very puzzled.

The error I'm getting is this one (and the similar one for 64 bit):
002b:err:module:__wine_process_init failed to load L"Z:\\usr\\bin\\lin-vst-servertrack32.exe.so", error c000012f

Has anyone got a working Mint 20 linvst installation? What am I missing?
Last edited by kirjis on Thu Sep 10, 2020 10:41 am, edited 1 time in total.
My 2020 instrumental funk album (Kumikäki - Le Bob): https://komitea.fi/lebob/
Reaper - Mixbus - Linux Mint

ubuntuuser
Established Member
Posts: 295
Joined: Mon Jan 02, 2017 9:46 am

Re: Can't get linvst to work on Mint 20

Post by ubuntuuser »

kirjis wrote:
Mon Sep 07, 2020 9:07 am
I was using linvst with great success on Mint 18.3 for a couple of years, but after I got my new laptop, I just can't get it to work at all. Carla runs my WinVST's (v. 2 and 3) happily.
I've installed and purged and reinstalled Wine and .wine many times and use only two plugins to test (one 64 bit and other 32 bit). I have the multiarch libs installed. I've tried linvst 3.0 and 2.8 from DEB package and tarball. I'm using now linvstmanager to help in testing, but the result is the same. No joy. I'm very puzzled.

The error I'm getting is this one (and the similar one for 64 bit):
002b:err:module:__wine_process_init failed to load L"Z:\\usr\\bin\\lin-vst-servertrack32.exe.so", error c000012f

Has anyone got a working Mint 20 linvst installation? What am I missing?
One way to get that error is apparently due to a corrupt exe file https://askubuntu.com/questions/1215103 ... s-init-fai

If you havn't already, try installing the LinVst zip from https://github.com/osxmidi/LinVst/releases

The usual thing, copy the lin-vst-serverxxxxxx files to /usr/bin and then linvst.so gets renamed to the vst dll's name (where the vst file is located) via linvstconvert or maybe manually.

kirjis
Established Member
Posts: 6
Joined: Mon Sep 07, 2020 8:24 am

Re: Can't get linvst to work on Mint 20

Post by kirjis »

Thanks, I've already tried all that before, but I tried it again anyway -- still the same result.
My 2020 instrumental funk album (Kumikäki - Le Bob): https://komitea.fi/lebob/
Reaper - Mixbus - Linux Mint

ubuntuuser
Established Member
Posts: 295
Joined: Mon Jan 02, 2017 9:46 am

Re: Can't get linvst to work on Mint 20

Post by ubuntuuser »

kirjis wrote:
Mon Sep 07, 2020 4:15 pm
Thanks, I've already tried all that before, but I tried it again anyway -- still the same result.
As far as I know the LinVst binary files are not corrupt.

Is your wineprefix 64 bit?

Have you installed any dll overrides?

If something is corrupt in your wineprefix then you might get that error.

----------

Error 0xc000012f means “Bad image” denoting that the program’s executable or one of the supporting modules are corrupt. Or there is probably a DLL mismatch and especially seen in programs that use Microsoft Visual C++ 2015 Redistributables.

In developer’s terms, 0xC000012F means STATUS_INVALID_IMAGE_NOT_MZ, which means the specified image file did not have the correct format. It did not have an initial MZ. It’s possible that the runtime libraries versions are mismatched. For example, the 64-bit version of a DLL may have been accidentally copied to C:\Windows\SysWOW64 directory which is meant to store 32-bit modules.

kirjis
Established Member
Posts: 6
Joined: Mon Sep 07, 2020 8:24 am

Re: Can't get linvst to work on Mint 20

Post by kirjis »

As far as I know the LinVst binary files are not corrupt.

Is your wineprefix 64 bit?
Yes, and I also have 32-bit libs installed.
Have you installed any dll overrides?
No, nothing.
If something is corrupt in your wineprefix then you might get that error.
I have tried to remove .wine, install Wine and run winecfg for a fresh prefix. Nope.
My 2020 instrumental funk album (Kumikäki - Le Bob): https://komitea.fi/lebob/
Reaper - Mixbus - Linux Mint

ubuntuuser
Established Member
Posts: 295
Joined: Mon Jan 02, 2017 9:46 am

Re: Can't get linvst to work on Mint 20

Post by ubuntuuser »

kirjis wrote:
Wed Sep 09, 2020 10:07 am
As far as I know the LinVst binary files are not corrupt.

Is your wineprefix 64 bit?
Yes, and I also have 32-bit libs installed.
Have you installed any dll overrides?
No, nothing.
If something is corrupt in your wineprefix then you might get that error.
I have tried to remove .wine, install Wine and run winecfg for a fresh prefix. Nope.
I tried the LinVst Debian Buster version on Manjaro and I got the same error that you got.

I've put a Manjaro version on the LinVst 3.0 release page, try that.

kirjis
Established Member
Posts: 6
Joined: Mon Sep 07, 2020 8:24 am

Re: Can't get linvst to work on Mint 20

Post by kirjis »

That Manjaro version works perfectly, thank you! So Debian version problems, huh? :?
My 2020 instrumental funk album (Kumikäki - Le Bob): https://komitea.fi/lebob/
Reaper - Mixbus - Linux Mint

ubuntuuser
Established Member
Posts: 295
Joined: Mon Jan 02, 2017 9:46 am

Re: Can't get linvst to work on Mint 20

Post by ubuntuuser »

kirjis wrote:
Thu Sep 10, 2020 10:14 am
That Manjaro version works perfectly, thank you! So Debian version problems, huh? :?
Yes, looks like it.

Post Reply