I messed up my WINE

Discuss running non-Linux applications and plugins on Linux, for example via wine

Moderators: khz, MattKingUSA

User avatar
ZestieBumwhig
Established Member
Posts: 28
Joined: Fri May 20, 2016 4:56 pm

I messed up my WINE

Postby ZestieBumwhig » Sun Jul 07, 2019 3:08 am

Somehow I seem to have really messed up my WINE installation. I've had it running with no problems for a few years, but today I botched everything. I'm using AVLinux2016.

I did a standard Synaptic "Mark All Upgrades," but some WINE packages didn't download. I didn't think much of it, tried to open something and failed, then ran Synaptic again... And now, whenever I try to open a plugin in Carla, I get an error in a Windows-looking popup:

"The program (unidentified) has encountered a serious problem and needs to close."

This comes up twice, but then the plugin seems to load and work properly.

In trying to remedy things, I made it EVEN WORSE again... at first, Reaper (Windows version) would load (after the same error), but now, after re-installing my various WINEs, it won't load at all - "There is no Windows program configured to open this type of file." I've tried re-downloading the 64 bit Windows Reaper, but the installer warns me that I'm on a 32 bit system (though I've been using 64 bit all along). And it won't re-install.

Any suggestions? I really don't understand WINE; I've been looking up these errors, but I'm feeling pretty lost.

Carla logs include:

Code: Select all

wine: Unhandled page fault on write access to 0x0040c900 at address 0x402565 (thread 0017), starting debugger...
0019:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0019:fixme:dbghelp:elf_search_auxv can't find symbol in module
0019:fixme:dbghelp:elf_search_auxv can't find symbol in module
(... about 20 times...)
0019:fixme:dbghelp:elf_search_auxv can't find symbol in module
CarlaThread setup with realtime priority successful

Carla assertion failure: "index < static_cast<int32_t>(pData->prog.count)" in file CarlaPluginBridge.cpp, line 2104, v1 0, v2 0
Carla assertion failure: "index >= -1 && index < static_cast<int32_t>(pData->prog.count)" in file CarlaPlugin.cpp, line 1739
Carla Bridge Ready!

User avatar
Linuxmusician01
Established Member
Posts: 630
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: I messed up my WINE

Postby Linuxmusician01 » Sun Jul 07, 2019 11:52 am

Try to update those Wine packages again today: the repo's that you use might have been down. Then, try to run a Wine related program, not something that "uses" Wine (like a DAW or Carla). So for instance: does the Wine configuration utility, winecfg, work? Do this and post errors in forum:

Code: Select all

winecfg


Good luck!

User avatar
ZestieBumwhig
Established Member
Posts: 28
Joined: Fri May 20, 2016 4:56 pm

Re: I messed up my WINE

Postby ZestieBumwhig » Sun Jul 07, 2019 3:33 pm

Geez, you were completely right! There were new updates today, I ran "winecfg," and that fixed everything. In my rush to blame myself, I didn't pause to think that it might not have been my own doing!

Thanks, and sorry for the panicked false alarm.

glowrak guy
Established Member
Posts: 1348
Joined: Sat Jun 21, 2014 8:37 pm

Re: I messed up my WINE

Postby glowrak guy » Mon Jul 08, 2019 6:26 am

I've seen extremely strange behaviors by win audio apps in their
native haunts lately, and I think some Visual C++ Redistributable packages
have hit the future's fan, and were brown inside, instead of golden.
Companies that rely on them are dancing with a sticky and smelly partner,
and the heat of commercial competition just makes it worse.
I can imagine the developer community having more very large
and very small shops, with fewer in the mid-range,
the large shops will roll with the blows, the lone-wolf and small shops
will manage their overheads and project choices with great scrutiny
with few(er) employee obligations.

I have an manjaro arch linux setup, getting lots of synptoms like
zbw mentioned, along with jackd getting zombified whenever something
useful is attempted...
this is continuing from wine 4.9 to the updated 4.11, maybe the maintainers
should switch to the even numbered releases. 4.12 in Mint is running well :wink:
Cheers

User avatar
Linuxmusician01
Established Member
Posts: 630
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: I messed up my WINE

Postby Linuxmusician01 » Mon Jul 08, 2019 12:17 pm

glowrak guy wrote:I've seen extremely strange behaviors by win audio apps in their
native haunts lately, and I think some Visual C++ Redistributable packages
have hit the future's fan, and were brown inside, instead of golden.
Companies that rely on them are dancing with a sticky and smelly partner,
and the heat of commercial competition just makes it worse.
I can imagine the developer community having more very large
and very small shops, with fewer in the mid-range,
the large shops will roll with the blows, the lone-wolf and small shops
will manage their overheads and project choices with great scrutiny
with few(er) employee obligations.

I have an manjaro arch linux setup, getting lots of synptoms like
zbw mentioned, along with jackd getting zombified whenever something
useful is attempted...
this is continuing from wine 4.9 to the updated 4.11, maybe the maintainers
should switch to the even numbered releases. 4.12 in Mint is running well :wink:
Cheers

It appears that I use a Wine version from KXStudio (ver. 3.02). Thanks for the warning. Like I always say considering updating anything: if it ain't broken don't try to fix it. My official Mint's versiopn of Wine is "only" ver. 1.8.

Death
Established Member
Posts: 157
Joined: Sun Oct 11, 2015 1:43 pm

Re: I messed up my WINE

Postby Death » Wed Jul 10, 2019 11:16 am

Not sure if this is of much use to you for future situations like this, but I've been using a program called "Timeshift" and it's been amazing for saving me a load of hassle in these situations. It's similar to system restore on Windows if you're familiar with that.


Return to “Running non-linux software”

Who is online

Users browsing this forum: No registered users and 1 guest