Issue with V4 master

MusE is a DAW for Linux with both MIDI and Audio editing. https://muse-sequencer.github.io

Moderators: khz, MattKingUSA, spamatica

Post Reply
saturnin51
Established Member
Posts: 84
Joined: Sat Mar 02, 2019 5:10 am

Issue with V4 master

Post by saturnin51 »

No Simpledrum in MESS list. I verify the path and presence of the soundfont. It's with OPRE1
No loading of sound fonts with Fluidsynth: Impossible to load the sound font, so no sound on the tracks. OK with OPRE1.
spamatica
Established Member
Posts: 412
Joined: Mon Feb 08, 2010 10:38 am

Re: Issue with V4 master

Post by spamatica »

This is with the AppImage, right?
Tried it here and I cannot see ŚimpleDrums either.

Edit: Well, what do you know I can't see it with a self built MusE master either. The file is there but MusE does not seem to recognize it.
MusE DAW
kybos
Established Member
Posts: 86
Joined: Wed Oct 23, 2019 5:50 am

Re: Issue with V4 master

Post by kybos »

No idea why that happens, but this seems to be the problem:

Code: Select all

pluginScan: Standard error output from scan:
muse_plugin_scan: dlopen(/tmp/.mount_MusE-mL1qNUh/usr/lib/muse-4.0/synthi/simpledrums.so) failed: 
/tmp/.mount_MusE-mL1qNUh/usr/lib/libmuse_widgets.so: undefined symbol: _ZTIN7MusEGui15RasterizerModelE
I also tested Fluidsynth (with latest AppImage), no problem to be found there.
kybos
Established Member
Posts: 86
Joined: Wed Oct 23, 2019 5:50 am

Re: Issue with V4 master

Post by kybos »

I assume simpledrums.so is dependent on libmuse_widgets.so, which is supposed to be self-contained for this to work.
But RasterizerModel is declared outside of libmuse_widgets.so.
I suppose it's connected to Tim's recent changes to the raster grid.

It seems to be difficult to keep that under control, as there is no compilation error or other hint. Probably the plugins themselves should optimally be self-contained and not rely on core components...
spamatica
Established Member
Posts: 412
Joined: Mon Feb 08, 2010 10:38 am

Re: Issue with V4 master

Post by spamatica »

kybos wrote: Fri Jan 08, 2021 6:57 pm I assume simpledrums.so is dependent on libmuse_widgets.so, which is supposed to be self-contained for this to work.
But RasterizerModel is declared outside of libmuse_widgets.so.
I suppose it's connected to Tim's recent changes to the raster grid.
It seems to me it exists in libmuse_core.so, tried to add it to the link list but something more is needed.
kybos wrote: Fri Jan 08, 2021 6:57 pm It seems to be difficult to keep that under control, as there is no compilation error or other hint. Probably the plugins themselves should optimally be self-contained and not rely on core components...
It should still be possible to link them correctly. It IS odd that the link stage does not complain.
MusE DAW
kybos
Established Member
Posts: 86
Joined: Wed Oct 23, 2019 5:50 am

Re: Issue with V4 master

Post by kybos »

spamatica wrote: Fri Jan 08, 2021 7:55 pm It seems to me it exists in libmuse_core.so, tried to add it to the link list but something more is needed.
Yes, it exists in core (otherwise it wouldn't compile). But I remember the discussion with Tim where he insisted that the /widgets component have to be self-contained and independent of core. There are also similar comments in the code.
kybos
Established Member
Posts: 86
Joined: Wed Oct 23, 2019 5:50 am

Re: Issue with V4 master

Post by kybos »

This is now fixed (both AppImage and normal build).
Kind of (harmless) workaround, static linkage of the main exe. Seems even to be good for the AppImage, it got some MBs smaller.
Post Reply