Wave editor: Weird time scale after cut and paste

MusE is a MIDI/Audio sequencer with recording and editing capabilities, aiming to be a complete multitrack virtual studio for Linux. https://muse-sequencer.org/

Moderators: MattKingUSA, khz, spamatica

Post Reply
dailybug2
Established Member
Posts: 44
Joined: Tue May 28, 2019 2:33 pm
Location: Germany
Contact:

Wave editor: Weird time scale after cut and paste

Post by dailybug2 »

Hi, I got a weird time scale after performing these steps:
  • Set signature from 4/4 to 16/16
  • Cut seleection
  • Silence this selection
  • Paste selection a little to the left (where the red marker is)
The audible output is fine / as expected!

Switching the signature back to 4/4 does not fix the time scale. The issue persists after save project / restart MusE / load project. A known issue maybe?
wave-bug.png
I can send the .med if considered useful.
PS: Anybody else actually using MusE? Nomen est omen (regarding my user name) :wink:
You do not have the required permissions to view the files attached to this post.
/* Drunk, 'll fix later ... well, usability is anyway only of interest to those who got beyond the crashes! :P */

spamatica
Established Member
Posts: 307
Joined: Mon Feb 08, 2010 10:38 am

Re: Wave editor: Weird time scale after cut and paste

Post by spamatica »

dailybug2 wrote:
Wed Jun 17, 2020 8:42 pm
Hi, I got a weird time scale after performing these steps:
  • Set signature from 4/4 to 16/16
  • Cut seleection
  • Silence this selection
  • Paste selection a little to the left (where the red marker is)
The audible output is fine / as expected!

Switching the signature back to 4/4 does not fix the time scale. The issue persists after save project / restart MusE / load project. A known issue maybe?

wave-bug.png

I can send the .med if considered useful.
PS: Anybody else actually using MusE? Nomen est omen (regarding my user name) :wink:
I'm having trouble following the instructions, do send the med file if the below does not help you.

It looks like you might MusE might have changed time-scale in the middle, which may be expected, I think the default is that the mastertrack is enabled, which means that tempo changes will happen at the point where it was changed, this can be turned off in the Transport Panel by clicking on the button next to the tempo field (if it is green it is enabled)
Try opening View->Mastertrack->List you should be able to see if there has been any tempo-changes in the song.

dailybug2
Established Member
Posts: 44
Joined: Tue May 28, 2019 2:33 pm
Location: Germany
Contact:

Re: Wave editor: Weird time scale after cut and paste

Post by dailybug2 »

Yep, it's the master track. I - as a MusE newbie - did not yet care about the master track at all.
I understand that changing the signature in the wave editor creates this master track entry. So I abused the signature just to get the 16th grid. Wow can I change the grid in the editors without changing the time signature? Without the grid it is not possible to place a selection.
/* Drunk, 'll fix later ... well, usability is anyway only of interest to those who got beyond the crashes! :P */

spamatica
Established Member
Posts: 307
Joined: Mon Feb 08, 2010 10:38 am

Re: Wave editor: Weird time scale after cut and paste

Post by spamatica »

dailybug2 wrote:
Thu Jun 18, 2020 12:02 pm
Yep, it's the master track. I - as a MusE newbie - did not yet care about the master track at all.
I understand that changing the signature in the wave editor creates this master track entry. So I abused the signature just to get the 16th grid. Wow can I change the grid in the editors without changing the time signature? Without the grid it is not possible to place a selection.
Ah, yes, the Snap function in the toolbar selects what granularity you want in the piano roll or drum editor.

snap.png

Edit: And writing that I saw that you made a bug in reference, and it's really the wave editor that you want better control. This is indeed lacking.
You do not have the required permissions to view the files attached to this post.

dailybug2
Established Member
Posts: 44
Joined: Tue May 28, 2019 2:33 pm
Location: Germany
Contact:

Re: Wave editor: Weird time scale after cut and paste

Post by dailybug2 »

Just for the records: This is not a bug; I was informed that switching the time signature creates a master track entry with a tempo change. I abused the time signature to get a finer grid and for now there is not other option to achieve this. I filed a feature request on github.com and the issue is discussed there / End of thread here.
/* Drunk, 'll fix later ... well, usability is anyway only of interest to those who got beyond the crashes! :P */

Post Reply