Note on tick 0 not played

MusE is a MIDI/Audio sequencer with recording and editing capabilities, aiming to be a complete multitrack virtual studio for Linux. https://muse-sequencer.org/

Moderators: MattKingUSA, khz, spamatica

Post Reply
User avatar
oscillator
Established Member
Posts: 226
Joined: Sat Jan 17, 2015 6:07 pm
Location: SWEDEN
Contact:

Note on tick 0 not played

Post by oscillator »

Hi,

I have sequences starting on tick 0 (see screenshot, list is of drum track).

I have a 2 bar pattern that I loop while editing (see screenshot for Left and Right Mark).

When looping the first note (on tick 0) is not played.

How can I check which tick the clip starts on? Is this the value for "Cursor" when I select the clip? In that case, it is at the same tick as the Left Mark (and the first note).

EDIT: The note on tick 0 is not played even when starting on the previous bar, so I must be doing something drastically wrong here...

/Staffan

PS Running latest pre4. DS
You do not have the required permissions to view the files attached to this post.
MusE DAW running on Debian 10 Stable/XFCE4.
https://oscillator.se/musik

User avatar
oscillator
Established Member
Posts: 226
Joined: Sat Jan 17, 2015 6:07 pm
Location: SWEDEN
Contact:

Re: Note on tick 0 not played

Post by oscillator »

This problem totally disappears if I enable "Enable Input Monitor" (the green donut) on ANY MIDI track... I thought this button only was for letting eg an external MIDI keyboard play the softsynths...?

If I have not enabled any input monitoring, not only is the first event skipped, most midi data is played back with a very short note length...
MusE DAW running on Debian 10 Stable/XFCE4.
https://oscillator.se/musik

User avatar
oscillator
Established Member
Posts: 226
Joined: Sat Jan 17, 2015 6:07 pm
Location: SWEDEN
Contact:

Re: Note on tick 0 not played

Post by oscillator »

The problem also disappears if I disable Latency compensation in settings...
MusE DAW running on Debian 10 Stable/XFCE4.
https://oscillator.se/musik

Tim E. Real
Established Member
Posts: 382
Joined: Sat Sep 15, 2012 12:36 am

Re: Note on tick 0 not played

Post by Tim E. Real »

Oh. Yes I was going to mention that.
The latency setting has a bug in that the first fraction of second is silent.
It also has a bug in that if looping with wave tracks, errors will appear. Although you don't appear to be using wave tracks.
I am working hard to solve these issues. It may take some time, it's a tough problem.

For now either
a) don't use latency correction or
b) start playback of your material slightly ahead of the desired start point. Try to leave say, one bar empty at song start for this purpose.

User avatar
oscillator
Established Member
Posts: 226
Joined: Sat Jan 17, 2015 6:07 pm
Location: SWEDEN
Contact:

Re: Note on tick 0 not played

Post by oscillator »

Aha, thanks for the info (and I have some distant memory of you mentioning this in another topic)...
MusE DAW running on Debian 10 Stable/XFCE4.
https://oscillator.se/musik

Post Reply