Latest git pull build fails. [SOLVED]

MusE is a MIDI/Audio sequencer with recording and editing capabilities, aiming to be a complete multitrack virtual studio for Linux. http://muse-sequencer.org/

Moderators: khz, MattKingUSA, spamatica

alex stone
Established Member
Posts: 147
Joined: Fri Jun 06, 2008 7:39 am

Latest git pull build fails. [SOLVED]

Postby alex stone » Sun Apr 14, 2019 10:06 am

Tim, i've pulled git this morning, and the build fails with:

[ 80%] Building CXX object muse/CMakeFiles/core.dir/app.o
In file included from /home/alex/github/muse/muse3/muse/mixer/routedialog.h:360:0,
from /home/alex/github/muse/muse3/muse/mixer/amixer.h:33,
from /home/alex/github/muse/muse3/muse/app.cpp:50:
/home/alex/github/muse/muse3/./ui_routedialogbase.h:13:10: fatal error: QtGui/QAction: No such file or directory
#include <QtGui/QAction>
^~~~~~~~~~~~~~~
compilation terminated.
muse/CMakeFiles/core.dir/build.make:412: recipe for target 'muse/CMakeFiles/core.dir/app.o' failed
make[2]: *** [muse/CMakeFiles/core.dir/app.o] Error 1
CMakeFiles/Makefile2:525: recipe for target 'muse/CMakeFiles/core.dir/all' failed
make[1]: *** [muse/CMakeFiles/core.dir/all] Error 2
Makefile:151: recipe for target 'all' failed
make: *** [all] Error 2



Is this me or you?

Alex.

[SOLVED]
I wiped the git directory, and downloaded with git clone again. That worked.

Tim E. Real
Established Member
Posts: 181
Joined: Sat Sep 15, 2012 12:36 am

Re: Latest git pull build fails. [SOLVED]

Postby Tim E. Real » Sun Apr 14, 2019 4:56 pm

Whew. That's a relief. Not another bug - I'm all bugged out!
Yeah, cmake gets confused sometimes. especially with major changes, and you have to 'purge' the build folder.
I use KDevelop and it has a 'Purge' button which I use a lot.


Return to “MusE Sequencer”

Who is online

Users browsing this forum: No registered users and 2 guests