Crackling noise on USB interface in certain apps

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: MattKingUSA, khz

User avatar
kaimerra
Established Member
Posts: 91
Joined: Sun Jan 04, 2009 9:41 am
Location: Minnesota, USA

Crackling noise on USB interface in certain apps

Post by kaimerra »

I am getting some crackling noise during playback in Renoise. This is only happening when using my USB audio interface through Jack and not my internal IntelHDA chip. I am not getting XRuns during these crackles. I don't get the crackles in other audio apps(ardour, hydrogen, guitarix). I changed the USB cable and my headphones to make sure they weren't culprit. I ran the realtimeconfig script from the wiki and I pass on all accounts.
I got this crackling noise before when distro hopping to DreamStudio, but then it was happening in Ardour and Renoise. I gave switched distros before figuring it out there.

I am running Jack 1.9.6 on Fedora 14.

Any ideas?

Havoc
Established Member
Posts: 179
Joined: Sat Oct 04, 2008 6:57 pm

Re: Crackling noise on USB interface in certain apps

Post by Havoc »

You say you don't get it through the internal chip, but are you using jack or not in that case? If not through jack, then please check if you get the same noise with the internal chip when you use jack.

Is there a relation between somthing else that happens on the pc and the noise? Like disk access or scrolling on the screen? I know my laptop has a crackling noise when I scroll the screen with the internal chip and headphones. Could also be disk access.

User avatar
kaimerra
Established Member
Posts: 91
Joined: Sun Jan 04, 2009 9:41 am
Location: Minnesota, USA

Re: Crackling noise on USB interface in certain apps

Post by kaimerra »

I booted my AVLinux install and the same audio interface setup works with Renoise perfectly. So that leads me to believe it either lies in something Gnome is loading or a usb driver issue. AVLInux is using 2.6.36, while Fedora is using 2.6.35. AVlinux is using ext3 whereas my Fedora is using ext4.

I killed gnome-power-manager, still crackles.

It is on its own direct usb port, and I made sure it isn't sharing the IRQ with anything resource hungry like my graphics card.

The crackling seems fairly random and crackles a few times a second, but only while there is audio being played back. If I mute all tracks while a song is playing, it stops.

User avatar
Capoeira
Established Member
Posts: 1278
Joined: Tue May 12, 2009 1:01 pm
Location: Brazil

Re: Crackling noise on USB interface in certain apps

Post by Capoeira »

obviously a jack-problem.
i had st like this before with FST ans VSTis.

try another jackversion and/or Jack1 or uper latency.
or perhaps there is a latancysetting in renoise wich doesn't cooperate with jack?
I think it's a latency-problem and xruns are not reported for any reason
best place to ask would be on a renoise page/forum

User avatar
autostatic
Established Member
Posts: 1728
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands
Contact:

Re: Crackling noise on USB interface in certain apps

Post by autostatic »

Are the JACK settings in AV Linux and Fedora the same? You could try the -S option for Jack2 on your Fedora machine.

Best,

Jeremy

User avatar
kaimerra
Established Member
Posts: 91
Joined: Sun Jan 04, 2009 9:41 am
Location: Minnesota, USA

Re: Crackling noise on USB interface in certain apps

Post by kaimerra »

Switched to LXDE in Fedora, still crackling.

Started jack in 16bit(-S), and still crackling.

It is not Renoise, because this same setup does not crackle in AVLinux.

I do get this warning when I plug my USB device in, I'll check if this happens in AVLInux. Could this be causin it?

[ 92.973230] ALSA sound/usb/clock.c:219: 3:1:1: endpoint lacks sample rate attribute bit, cannot set.

User avatar
kaimerra
Established Member
Posts: 91
Joined: Sun Jan 04, 2009 9:41 am
Location: Minnesota, USA

Re: Crackling noise on USB interface in certain apps

Post by kaimerra »

I am not getting that sample rate attribute message in AVLinux. I am pretty sure that has something to do with it, because I have disabled or uninstalled everything else that could be causing it.

Maybe my issue:
https://bugs.launchpad.net/ubuntu/+sour ... mments=all

Going to try updating ALSA...

User avatar
kaimerra
Established Member
Posts: 91
Joined: Sun Jan 04, 2009 9:41 am
Location: Minnesota, USA

Re: Crackling noise on USB interface in certain apps

Post by kaimerra »

I tried ALSA 1.0.23 and 1.0.24, both have the issue.

User avatar
kaimerra
Established Member
Posts: 91
Joined: Sun Jan 04, 2009 9:41 am
Location: Minnesota, USA

Re: Crackling noise on USB interface in certain apps

Post by kaimerra »

Tried openSuse 11.4, Fedora 14 and Arch. All of them get the crackling noise.

I tried a DIFFERENT usb audio interface, a M-Audio Ozone, and I get the crackling noise.

I installed KXStudio 10.04.3 and it doesn't get the noise.

So i have narrowed it down to having to do with USB Audio interfaces through Jack, but only on certain distro/kernels. Really wish I could figure this out and move on to make some music. The only two distros that work, are the two that don't work well on my system. AVLinux hard freezes on boot and KXStudio is too old to support my video card with external monitor. Sigh. :(

User avatar
kaimerra
Established Member
Posts: 91
Joined: Sun Jan 04, 2009 9:41 am
Location: Minnesota, USA

Re: Crackling noise on USB interface in certain apps

Post by kaimerra »

Installed UbuStu Natty now....and still have the issue. Lots of these in the Renoise log:
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3
JackActivationCount::Signal value = 0 ref = 3

User avatar
kaimerra
Established Member
Posts: 91
Joined: Sun Jan 04, 2009 9:41 am
Location: Minnesota, USA

Re: Crackling noise on USB interface in certain apps

Post by kaimerra »

Okay, now its worse on Ubuntu Studio Natty, because the issue happens on Ardour too.

Scenario:
Jack running on my USB audio interface, guitarix running and all sounds great!
Open ardour, and pops and crackles start, and its not even recording! Close ardour and the issue goes away. :( WTF

User avatar
GMaq
Established Member
Posts: 1670
Joined: Fri Sep 25, 2009 1:42 pm

Re: Crackling noise on USB interface in certain apps

Post by GMaq »

kaimerra wrote:Tried openSuse 11.4, Fedora 14 and Arch. All of them get the crackling noise.

I tried a DIFFERENT usb audio interface, a M-Audio Ozone, and I get the crackling noise.

I installed KXStudio 10.04.3 and it doesn't get the noise.

So i have narrowed it down to having to do with USB Audio interfaces through Jack, but only on certain distro/kernels. Really wish I could figure this out and move on to make some music. The only two distros that work, are the two that don't work well on my system. AVLinux hard freezes on boot and KXStudio is too old to support my video card with external monitor. Sigh. :(
Hi,

If AV Linux freezes on boot, you should ask for help on the AV Linux forum, obviously this is not normal or expected behaviour. AV Linux has some known boot issues with certain Video hardware due to modesetting which most times is easily fixed by a simple boot cheatcode. Complaining about any distro on a 3rd party forum or a mailing list like LAU is pretty pointless if you want to actually get some help from the developers. :wink:

blablack
Established Member
Posts: 22
Joined: Sun Feb 22, 2009 7:18 pm

Re: Crackling noise on USB interface in certain apps

Post by blablack »

Hi kaimerra,

Did you do more investigation on that issue?
I'm facing the exact same problem as you.

Distrib: Ubuntu Natty 64
USB SoundCard: M-Audio Fast Track Ultra (USB 2.0)
USB Port on my Laptop: EHCI (this info might be important)

Kernel 2.6.38 coming with Ubuntu -> get loads of crackling noise when using Ardour or Jack in general.
Kernel 2.6.35 with XHCI, Graphic Acceleration and Wifi deactivated (my laptop has USB 3, and Graphich Acceleration and Wifi just don't work with 2.6.35 in Natty... didn't really investigate why yet) -> sound is perfect
Kernel 2.6.37 with XHCI and Wifi deactivated and Ubuntu Classic no acceleration -> Crackling Noise.
Kernel 2.6.38 with XHCI and Wifi deactivated and Ubuntu Classic no acceleration -> Crackling Noise.

I'll try this evening with 2.6.36.

My thoughts so far:
- or 2.6.35 has some missing modules compared to 2.6.38, and when these modules are activated, they disturb the wifi.
- or they are just difference in the code of USB Audio that makes these crackling noise happen (I read somewhere that a huge part of the code was re-written?).

Pablo
Established Member
Posts: 1270
Joined: Thu Apr 17, 2008 9:57 pm

Re: Crackling noise on USB interface in certain apps

Post by Pablo »

Autostatic suggested you could try "-S" option.

I think he was referring to the synchronous mode (general option, only applicable to jackd2) , not to "force 16 bits" (option for the alsa backend). In qjackctl, you have to append "-S" to the jackd command, in the "server path" field.

Cheers, Pablo

StudioDave
Established Member
Posts: 753
Joined: Sat Nov 01, 2008 1:12 pm

Re: Crackling noise on USB interface in certain apps

Post by StudioDave »

What sample rate are you using on your USB interface ? What period size in JACK ? My USB interface (UA25, the old one) is very sensitive to those settings.

Post Reply