agere systems fw322/323......

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

User avatar
southpaw
Established Member
Posts: 28
Joined: Wed Jun 24, 2009 8:36 am

agere systems fw322/323......

Postby southpaw » Tue Sep 21, 2010 6:30 pm

Hello good people....

I am currently using a HP slimline desktop s3400f, along with Ubuntu64 Studio. The PC uses an Agere Systems FW322/323 firewire chip. It is plugged in to a Focusrite Saffire Pro24. However Jack nor FFDAO will recognize the chip.....

Code: Select all

uname -a
Linux ubuntu 2.6.32-21-preempt #32-Ubuntu SMP PREEMPT Fri Apr 16 10:23:59 UTC 2010 x86_64 GNU/Linux

Code: Select all

lspci
01:05.0 FireWire (IEEE 1394): Agere Systems FW322/323 (rev 70)


I am wondering if I should disable the onboard firewire and install a TI firewire PCI or is there a way to make this work?

This is still kind of new to me so if there is any more info I need to post, let me know. Thanks for your help.

sp
"The modern day composer refuses to die" - FZ

User avatar
autostatic
Established Member
Posts: 1728
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands
Contact:

Re: agere systems fw322/323......

Postby autostatic » Wed Sep 22, 2010 7:50 am

Hello southpaw,

You need a version of FFADO with support for the DICE chipset: https://launchpad.net/~autostatic/+archive/ffado

The Agere chipset should work, my main machine has one too. Please let me know if the above packages work for you, I'm planning to buy a 24 also.

Best,

Jeremy

User avatar
southpaw
Established Member
Posts: 28
Joined: Wed Jun 24, 2009 8:36 am

Re: agere systems fw322/323......

Postby southpaw » Mon Sep 27, 2010 6:51 pm

Hey auto,
unfortunately by the time you posted I had already picked up a firewire PCI card with a VIAVT6307. I did try your patch but it didn't work. However, after I installed the new card I still can't get FFADO to work with it. I have tried disabling/enabling the Agere chip. So with or without the Agere chip enabled along with the Firewire PCI card installed, this is what Jack keeps telling me.....

Code: Select all

14:29:56.591 Startup script...
14:29:56.593 artsshell -q terminate
sh: artsshell: not found
14:29:56.997 Startup script terminated with exit status=32512.
14:29:56.997 JACK is starting...
14:29:56.998 /usr/bin/jackd -P70 -dfirewire -dhw:0 -r44100 -p128 -n2
jackd 0.118.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
Memory locking is unlimited - this is dangerous. You should probably alter the line:
     @audio   -  memlock    unlimited
in your /etc/limits.conf to read:
     @audio   -  memlock    2946297
no message buffer overruns
JACK compiled with System V SHM support.
14:29:57.026 JACK was started with PID=2024.
loading driver ..
Enhanced3DNow! detected
SSE2 detected
libffado 2.0.0 built Mar 31 2010 16:21:44
firewire ERR: Error creating FFADO streaming device
cannot load driver module firewire
no message buffer overruns
14:29:57.087 JACK was stopped successfully.
14:29:57.087 Post-shutdown script...
14:29:57.087 killall jackd
jackd: no process found
14:29:57.497 Post-shutdown script terminated with exit status=256.
14:29:59.171 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.


There are some other issues I have been noticing in reference to ./QuickScan.pl. I have noticed that even after I make the necessary corrections, I find that after I reboot I have to do it all over again.

I have tried several kernels including the two latest Preemt kernels as well as the RT kernels and I keep getting the same results. Here is what my lspci looks like now with the Agere disabled....

Code: Select all

00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 6150SE nForce 430] (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:0a.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev 46)


I have been a Slackware user for years and this is my first run at Ubuntu. It has been frustrating so far and I am considering going back. I know it might sound crazy but it seems like this sort of thing is easier for me to pinpoint in Slack than in Ubuntu.

Thanks for all your help btw....
"The modern day composer refuses to die" - FZ

User avatar
autostatic
Established Member
Posts: 1728
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands
Contact:

Re: agere systems fw322/323......

Postby autostatic » Tue Sep 28, 2010 8:26 am

Code: Select all

firewire ERR: Error creating FFADO streaming device
cannot load driver module firewire


Did you add the raw1394 module to /etc/modules ? And do you have an udev rule that allows a user or the audio group to acces /dev/raw1394 ?
And you really need my updated FFADO package or compile FFADO yourself from trunk otherwise your Focusrite Saffire Pro 24 will not work. The FFADO package that comes with 10.04 simply doesn't support the DICE chipset of your device.

User avatar
southpaw
Established Member
Posts: 28
Joined: Wed Jun 24, 2009 8:36 am

Re: agere systems fw322/323......

Postby southpaw » Tue Sep 28, 2010 5:24 pm

Thanks for the tip auto. I will update the ffado and post back the results.

much appreciated,
sp
"The modern day composer refuses to die" - FZ

User avatar
autostatic
Established Member
Posts: 1728
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands
Contact:

Re: agere systems fw322/323......

Postby autostatic » Wed Sep 29, 2010 8:47 am

Concerning the udev rule and /etc/modules: http://wiki.linuxmusicians.com/doku.php ... g_firewire

User avatar
southpaw
Established Member
Posts: 28
Joined: Wed Jun 24, 2009 8:36 am

Re: agere systems fw322/323......

Postby southpaw » Wed Sep 29, 2010 9:46 pm

Hey auto,
okay so I am all good as far modules and permissions. raw1394 is in my audio group and it's set to load when I boot.
I went ahead and compiled the FFADO source, like you recommended. I also compiled Jack from source, as it was recommended in the link you posted and here is what I am getting now....

Code: Select all

17:20:03.538 Patchbay deactivated.
17:20:03.561 Statistics reset.
17:20:03.580 ALSA connection graph change.
17:20:03.777 ALSA connection change.
17:20:23.009 Startup script...
17:20:23.010 artsshell -q terminate
sh: artsshell: not found
17:20:23.413 Startup script terminated with exit status=32512.
17:20:23.413 JACK is starting...
17:20:23.414 /usr/bin/jackd -P70 -m -dfirewire -dhw:0 -r44100 -p128 -n2
jackd 0.120.1
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
Memory locking is unlimited - this is dangerous. You should probably alter the line:
     @audio   -  memlock    unlimited
in your /etc/limits.conf to read:
     @audio   -  memlock    2946405
17:20:23.432 JACK was started with PID=10059.
no message buffer overruns
JACK compiled with System V SHM support.
loading driver ..
01716429774:  (ffado.cpp)[  92] ffado_streaming_init: libffado 2.999.0-1904 built Sep 29 2010 16:40:09
01716594748: Warning (dice_eap.cpp)[1398] read: No routes found. Base 0x7, offset 0x4000
01716621426: Warning (dice_eap.cpp)[ 881] updateNameCache: What is this function about?
firewire ERR: Error creating FFADO streaming device
cannot load driver module firewire
no message buffer overruns
17:20:24.107 JACK was stopped successfully.
17:20:24.107 Post-shutdown script...
17:20:24.108 killall jackd
jackd: no process found
17:20:24.517 Post-shutdown script terminated with exit status=256.
17:20:25.943 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.


So I also noticed that when I ran ffado-bus-server, I get a mismatch....

Code: Select all

$ -----------------------------------------------
FFADO Control DBUS service
Part of the FFADO project -- www.ffado.org
Version: 2.0.0
(C) 2008, Pieter Palmers
This program comes with ABSOLUTELY NO WARRANTY.
-----------------------------------------------

Library version mismatch. (required: libffado 2.0.0, present: libffado 2.999.0-1904)
Please run this application against the exact corresponding library
it was compiled for. The most common cause for this is having more
than one version of libffado installed.

no message buffer overruns

Now I was under the impression that this would take care of that......

Code: Select all

$ sudo apt-get build-dep libffado
$ sudo apt-get install build-essential libavc1394-dev python-qt4-dev subversion libtool

....but it hasn't. So do I have to recompile everything that corresponds to it or did I miss something?

Thanks again for all your help,
sp
"The modern day composer refuses to die" - FZ

User avatar
southpaw
Established Member
Posts: 28
Joined: Wed Jun 24, 2009 8:36 am

Re: agere systems fw322/323......

Postby southpaw » Wed Sep 29, 2010 10:26 pm

I might as well add this bit of info also....

Code: Select all

$ ffado-test Discover
-----------------------------------------------
FFADO test and diagnostic utility
Part of the FFADO project -- www.ffado.org
Version: 2.999.0-1904
(C) 2008, Daniel Wagner, Pieter Palmers
This program comes with ABSOLUTELY NO WARRANTY.
-----------------------------------------------

01342572389: Warning (dice_eap.cpp)[1398] read: No routes found. Base 0x7, offset 0x4000
01342597901: Warning (dice_eap.cpp)[ 881] updateNameCache: What is this function about?
01342599669: Error (saffire_pro24.cpp)[ 114] discover: This is a Focusrite Saffire Pro24 but not the right firmware. Better stop here before something goes wrong.
01342599719: Error (saffire_pro24.cpp)[ 115] discover: This device has firmware 0x10002 while we only know about version 0x10004.
01342599758: Error (devicemanager.cpp)[ 632] discover: could not discover device


I am going to try and see if I can update the firmware. I will post back shortly...

sp
"The modern day composer refuses to die" - FZ

User avatar
autostatic
Established Member
Posts: 1728
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands
Contact:

Re: agere systems fw322/323......

Postby autostatic » Thu Sep 30, 2010 8:01 am

southpaw wrote:So I also noticed that when I ran ffado-bus-server, I get a mismatch....

Code: Select all

$ -----------------------------------------------
FFADO Control DBUS service
Part of the FFADO project -- www.ffado.org
Version: 2.0.0
(C) 2008, Pieter Palmers
This program comes with ABSOLUTELY NO WARRANTY.
-----------------------------------------------

Library version mismatch. (required: libffado 2.0.0, present: libffado 2.999.0-1904)
Please run this application against the exact corresponding library
it was compiled for. The most common cause for this is having more
than one version of libffado installed.

no message buffer overruns

Now I was under the impression that this would take care of that......

Code: Select all

$ sudo apt-get build-dep libffado
$ sudo apt-get install build-essential libavc1394-dev python-qt4-dev subversion libtool

....but it hasn't. So do I have to recompile everything that corresponds to it or did I miss something?
I think you don't need the DBUS service simply because the mixer doesn't work if you compile it against the Python libs/modules of 10.04. The mixer needs some newer stuff, not exactly sure what. But a sudo apt-get build-dep libffado ffado-dbus-server should pull in all dependencies. And make sure you uninstall the ffado stuff in Synaptic first. This is one of the reasons why I really prefer installing debs ;)

Good luck with upgrading your firmware!

User avatar
southpaw
Established Member
Posts: 28
Joined: Wed Jun 24, 2009 8:36 am

Re: agere systems fw322/323......

Postby southpaw » Thu Sep 30, 2010 7:53 pm

Hey auto,
I have pretty much hit a wall here with this, very frustrating because I know I am so close :roll: . Anyway, you said something that caught my attention and I was hoping that you could elaborate....
This is one of the reasons why I really prefer installing debs ;)

Now I had done the install using ubuntu 10.04 as a base and then upgraded everything to this point. Is there something I am not understanding with the "debs"? I thought Ubuntu was a tweaked version of Deb or are you referring to a set of repo's that I am not aware of?

Thanks again for taking the time to answer my questions, much appreciated.

sp
"The modern day composer refuses to die" - FZ

User avatar
autostatic
Established Member
Posts: 1728
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands
Contact:

Re: agere systems fw322/323......

Postby autostatic » Thu Sep 30, 2010 8:06 pm

With debs I mean Ubuntu .deb packages. And did you manage to upgrade the firmware successfully? What do ffado-test ListDevices and ffado-diag output now?

User avatar
southpaw
Established Member
Posts: 28
Joined: Wed Jun 24, 2009 8:36 am

Re: agere systems fw322/323......

Postby southpaw » Thu Sep 30, 2010 9:15 pm

Not yet. I have to go to see a friend that has a windows pc because I don't have windows installed on my pc. So I can't upgrade my firmware until later tonight, go figure. As soon as I do though I will post back my results.

sp
"The modern day composer refuses to die" - FZ

User avatar
autostatic
Established Member
Posts: 1728
Joined: Wed Dec 09, 2009 5:26 pm
Location: Beverwijk, The Netherlands
Contact:

Re: agere systems fw322/323......

Postby autostatic » Thu Sep 30, 2010 9:24 pm

Ok, cool.
I always have a BartPE CD lying around for stuff like that (firmware, BIOS): http://www.nu2.nu/pebuilder/

User avatar
southpaw
Established Member
Posts: 28
Joined: Wed Jun 24, 2009 8:36 am

Re: agere systems fw322/323......

Postby southpaw » Thu Sep 30, 2010 9:37 pm

Holy crap!!! I didn't know that a disc like that existed, thanks for the link auto.

sp
"The modern day composer refuses to die" - FZ

User avatar
southpaw
Established Member
Posts: 28
Joined: Wed Jun 24, 2009 8:36 am

Re: agere systems fw322/323......

Postby southpaw » Fri Oct 01, 2010 9:00 pm

Firmware update did the trick. Dice chipset seems to be working well now. Everything is looking good so far. I will post some of the diagnostic info shortly.

sp
"The modern day composer refuses to die" - FZ


Return to “Computer Related Hardware”

Who is online

Users browsing this forum: No registered users and 3 guests