Presonus 1818VSL SMUX mode

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

Post Reply
JonS
Established Member
Posts: 3
Joined: Fri Aug 15, 2014 11:01 pm

Presonus 1818VSL SMUX mode

Post by JonS »

I recently bought an original Focusrite Platinum Octopre at a very good price. It supports 24bit 96Khz over ADAT using SMUX.
My audio interface is a Presonus 1818VSL, which supports SMUX, but I've found that it's ADAT ports need to be switched into SMUX mode. The pair work well together at 48khz, but if I attempt to use the Octopre at 96khz I get terrible digital distortion.
I've confirmed that the 1818VSL and Octopre work together at 96khz under Windows using version 1.3 of the Presonus VSL software, where you choose 4 x 4 mode. There are instructions on how to enable SMUX mode on a Mac, which doesn't seem to require the VSL software, at https://support.presonus.com/hc/en-us/a ... n-Mac-OS-X.
Is it possible to enable SMUX mode on the 1818VSL in Linux?

merlyn
Established Member
Posts: 752
Joined: Thu Oct 11, 2018 4:13 pm

Re: Presonus 1818VSL SMUX mode

Post by merlyn »

I had a look at the link you posted. On a Mac the 1818 can be controlled with software built into the OS. On Linux there is alsamixer which may or may not offer the controls you need. Type alsamixer into a terminal, select the 1818 with F6 and see what controls there are.

JonS
Established Member
Posts: 3
Joined: Fri Aug 15, 2014 11:01 pm

Re: Presonus 1818VSL SMUX mode

Post by JonS »

Thanks Merlyn,

I have looked at alsamixer, where I can choose clock source and have sliders for inputs and outputs, but no switch for ADAT SMUX mode. I've tried setting up the 1818VSL as slave to the Octopre at 96khz, but I just get digital distortion.

I'm guessing, because the VSL software doesn't seem to be required for Macs, that it should be possible, but I haven't found any information on how to enable SMUX mode on the 1818vsl in Linux.

merlyn
Established Member
Posts: 752
Joined: Thu Oct 11, 2018 4:13 pm

Re: Presonus 1818VSL SMUX mode

Post by merlyn »

I just noticed that was your first post. Welcome to the forum!

Sorry to hear that didn't work. From my reading of the Mac instructions I got the impression it's 14 input mode. Are you using JACK? JACK defaults to the maximum number of inputs. Would starting JACK with 14 inputs and outputs work?

JonS
Established Member
Posts: 3
Joined: Fri Aug 15, 2014 11:01 pm

Re: Presonus 1818VSL SMUX mode

Post by JonS »

Thank you Merlyn - doubly so!

I've been using Mixbus directly with ALSA. I tried opening qjackctl to test your suggestion, but unfortunately it completely ignored my settings. I'm running AVLinux and I suspect that I've done something to break qjackctl and/or JACK.

The more I tried to fix it the more broken it became, so eventually I booted into the live image of AVLinux on a USB stick. In the live image qjackctl and JACK worked faultlessly and I had nice clear synced audio at 24bit / 96khz - thank you!

For the benefit of anyone else looking for this solution, I'm using the Audiobox 1818VSL with JACK. Under Setup in qjackctl I have the interface chosen as hw:VSL and the sample rate set to 96000hz. In my particular case the Frames/Period is set to 256 and Periods/Buffer is set to to 2, as these settings were nice and stable for me when using ALSA directly. Most importantly, of course, on the Advanced tab Channels I/O are both set to 14. The 1818VSL is acting as master and is connected to the Octopre using both an ADAT optical cable and a 75 ohm BNC wordclock cable.

Thanks again! I'm off to reinstall AVLinux.

merlyn
Established Member
Posts: 752
Joined: Thu Oct 11, 2018 4:13 pm

Re: Presonus 1818VSL SMUX mode

Post by merlyn »

Glad you got it working. If you're happy using JACK all is good. It will be possible to use ALSA and that will involve creating and editing .asoundrc which honestly I find a bit of a nightmare. The solution will be a simple couple of lines. Unfortunately due to what I consider to be the obscure syntax of .asoundrc I don't know exactly what they are.

Post Reply