MOTU 828mkII MIDI issues

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

Post Reply
dystrust
Established Member
Posts: 3
Joined: Tue Aug 11, 2020 3:29 pm

MOTU 828mkII MIDI issues

Post by dystrust »

I've been using a MOTU 828mkII on both a desktop and laptop running Linux Mint 19.3 with a 4.15 low latency kernel, and audio has been working great. The issue I'm having is that Jack crashes with an unhandled xrun within 8-10 seconds of starting the ALSA midi bridge in Cadence or via the terminal. I don't normally use the bridge while tracking, but I have a keyboard / percussion controller that I'd like to be able to use with Ardour. I confirmed that the controller and MIDI bridge work great with the integrated sound (Intel PCH) on the laptop, but no luck with the 828 on either computer. I've tried searching everywhere I can find, and I've tried different sample rates from 44.1-96k as well as buffer settings from 64 on up to 2048. Jack seems to crash with exactly the same issue every time.

If any of the logs would be helpful, please let me know. I'm also willing to try just about anything in terms of configuration to get this to work. Lastly if nothing else will work, I guess I need a new interface.

User avatar
VennStone
Established Member
Posts: 11
Joined: Tue May 28, 2019 5:19 pm
Location: Athens
Contact:

Re: MOTU 828mkII MIDI issues

Post by VennStone »

I just picked up a 828mkII for testing. While I have not had a chance to plug anything into them the MIDI ports detect and export without crashing. Started with a2jmidid -ue.

Image

dystrust
Established Member
Posts: 3
Joined: Tue Aug 11, 2020 3:29 pm

Re: MOTU 828mkII MIDI issues

Post by dystrust »

I have it working in JACK using the ALSA driver now without the bridge. I’ve also noticed that JACK only crashes when using the FFADO driver and the midi bridge when set to hardware export. Do I need to do additional ALSA config somewhere?

At the very least I have a viable work-around now where I can use the ALSA driver with its higher latency when working on MIDI, and the FFADO driver when tracking.

User avatar
VennStone
Established Member
Posts: 11
Joined: Tue May 28, 2019 5:19 pm
Location: Athens
Contact:

Re: MOTU 828mkII MIDI issues

Post by VennStone »

I'm launching Jack with the following.

jackd -S -R -P 70 -t 1000 -d firewire -r 48000 -p 128 -n 3

And the MIDI bridge with.

a2jmidid -ue

dystrust
Established Member
Posts: 3
Joined: Tue Aug 11, 2020 3:29 pm

Re: MOTU 828mkII MIDI issues

Post by dystrust »

This is what happens when I try using the same commands. The unhandled xrun occurs ~10 seconds after starting the MIDI bridge.

$ jackd -S -R -P 70 -t 1000 -d firewire -r 48000 -p 128 -n 3
jackdmp 1.9.14
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2019 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
no message buffer overruns
JACK server starting in realtime mode with priority 70
self-connect-mode is "Don't restrict self connect requests"
1598465897456448: (ffado.cpp)[ 92] ffado_streaming_init: libffado 2.3.9999- built Dec 30 2016 15:15:44
JackFFADODriver::ffado_driver_wait - unhandled xrun
firewire ERR: wait status < 0! (= -1)
JackAudioDriver::ProcessSync: read error, stopping...

Post Reply