Scarlett 2i4 2nd Gen Ubuntu 18.04

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: MattKingUSA, khz

Post Reply
r00t123
Posts: 1
Joined: Sat Feb 15, 2020 2:11 pm

Scarlett 2i4 2nd Gen Ubuntu 18.04

Post by r00t123 »

Hello,
I'm running Ubuntu 18.04 and I have no sound coming through my audio card. The audio settings in the Ubuntu show that the profile for this card is Analog Surround 4.0 output. I think this might be the cause of this problem. How can I change this profile to just Stereo output? I don't have any stereo profile option.

Thanks in advance.

User avatar
bluebell
Established Member
Posts: 1332
Joined: Sat Sep 15, 2012 11:44 am
Location: Saarland & Frankfurt, Germany

Re: Scarlett 2i4 2nd Gen Ubuntu 18.04

Post by bluebell »

I am afraid since most people in this forum use JACK as their main sound system and not Pulseaudio you might get more support in other Linux forums.
Linux – MOTU UltraLite AVB – Qtractor – https://soundcloud.com/suedwestlicht

puleglot
Established Member
Posts: 102
Joined: Thu Jan 23, 2020 3:14 pm

Re: Scarlett 2i4 2nd Gen Ubuntu 18.04

Post by puleglot »

r00t123 wrote:Hello,
I'm running Ubuntu 18.04 and I have no sound coming through my audio card.
If you have no sound from headphones, make sure that the "source" switch is set to "1-2". Also check that the outputs are not muted in alsamixer.
Last edited by puleglot on Sun Feb 16, 2020 2:41 pm, edited 1 time in total.

puleglot
Established Member
Posts: 102
Joined: Thu Jan 23, 2020 3:14 pm

Re: Scarlett 2i4 2nd Gen Ubuntu 18.04

Post by puleglot »

r00t123 wrote:The audio settings in the Ubuntu show that the profile for this card is Analog Surround 4.0 output. I think this might be the cause of this problem.
The only problem with 4.0 output is that pulseaudio upmixes/downmixes everything to 4.0. This is OK for stereo sources since pulseaudio just duplicate channels 1-2 to channels 3-4. But for multichannel sources like 5.1 or 7.1 this is bad, because as a result of downmixing, you will have different sound in channels 1-2 and 3-4. So, for example, if you are watching movies in headphones, you need to force video player to output in stereo.
r00t123 wrote:How can I change this profile to just Stereo output?
You can't :) (see "pactl list cards" output for available profiles).
You can use "module-remap-sink". But it causes a huge delay and after plugging/replugging the card, you need to restart pulseadio. So this is not very convenient. Here is an example from my ~/.config/pulse/default.pa (for Rubix24):

Code: Select all

load-module module-remap-sink sink_name=Roland_Rubix24-channel1 sink_properties="device.description='Roland Rubix24 Stereo Output 1L+2R' device.product.name='Rubix24' alsa.card_name='Rubix24'" master=alsa_output.usb-Roland_Rubix24-00.analog-surround-40 channels=2 master_channel_map=front-left,front-right channel_map=front-left,front-right remix=no
load-module module-remap-sink sink_name=Roland_Rubix24-channel2 sink_properties="device.description='Roland Rubix24 Stereo Output 3L+4R' device.product.name='Rubix24' alsa.card_name='Rubix24'" master=alsa_output.usb-Roland_Rubix24-00.analog-surround-40 channels=2 master_channel_map=rear-left,rear-right channel_map=front-left,front-right remix=no

Post Reply