m-audio Audiophile 2496 PCI - and getting nowhere...

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

Plug&Play
Established Member
Posts: 25
Joined: Sat Jan 14, 2017 2:09 am

m-audio Audiophile 2496 PCI - and getting nowhere...

Postby Plug&Play » Thu Mar 28, 2019 9:04 pm

Red Leader opened a recent and related discussion
Hey all,

First of all, thanks for the support these boards offer.


and here i am with issues getting my "ICE1712 - M Audio Audiophile 24/96", and the same gratitude for whatever help I can get.

I am running Ubuntu Studio 18.04.1 on a Dell workstation, MT7010 , Intel Core i5-3550 CPU @ 3.30GHz and 8GB DDR3

Me - sort of an intermediate guy, familiar with JackQtl, the Linux command line, MIDI routing and debug, and on my third serious attempt to get a music system to work reliably.

I was doing everything with system audio (except the m-audio card is installed for MIDI to my keyboard), but decided to upgrade to an external amplifier, and am trying to get line out routed from the sound card to the amp.

Step one was on another computer, on which my old PreSonus AudioBox USB (red!) works without much coaxing. It seems to work equally well with JACK, or with the system audio, sending YouTube audio from its line out to my amplifier, for example.

Then I attempted to use the M-audio pci card, and have been substantially frustrated.
In the Playback tab of the system "sound setting" display I have two volume control sliders
1) identified by a speaker icon and the words "system audio"
2) identified by a firefox icon and the words "audioIPCserver : audiostream [i]on[i]
and three choices in a box
a) builtin Audio Analog Stereo
b) ICE1712 - M Audio Audiophile 24/96
c) Jack Sink (Pulse Audio JACK Sink)

The only one that seems to pass audio through the JACK connection kit is "Jack Sink" - detected by Meter Bridge, but there is no way to make a connection to the sound card "line out". All I ever get is the sound from the PC headphone plug in the front of the computer.
Except, as I said, if I connect the usb audio, I immediately get audio from it's line out to the amp - JACK not used.
I ran mudita24, really noting going on there.

I apologize that this may not be very coherent, I really have no idea where to look, and have been trying to report what I have tried and observed.

Is there any hope of getting this to work?

Rob

Music Music Music !

glowrak guy
Established Member
Posts: 1302
Joined: Sat Jun 21, 2014 8:37 pm

Re: m-audio Audiophile 2496 PCI - and getting nowhere...

Postby glowrak guy » Fri Mar 29, 2019 3:04 am

Hi, a few things...on Mudita, you have to scroll the window
to the right, to see the analog sliders to raise the volume.
The line-in will in qjackctl,
be labeled 'System'.

If still nothing, as root user or sudo, run command

lsmod

and verify the snd_ice1712 module is included in the list.
If not, run the command

modprobe snd_ice1712 (or use snd-ice1712)

Here is my .jackdrc config textfile, but you'll need to find the name
of your card according to your system, so run commands

arecord -l
aplay -l

The names shown within brackets are to be filled in
after the Chw: and Phw:
as in the following line:

/usr/bin/jackd -alsa -r44100 -n2 -D -Chw:fill-in-name-here -Phw:fill-in-name-here

The line you edit should be saved as .jackdrc in /home/your-name.

Good luck

merlyn
Established Member
Posts: 323
Joined: Thu Oct 11, 2018 4:13 pm

Re: m-audio Audiophile 2496 PCI - and getting nowhere...

Postby merlyn » Fri Mar 29, 2019 1:08 pm

Plug&Play wrote:a) builtin Audio Analog Stereo
b) ICE1712 - M Audio Audiophile 24/96
c) Jack Sink (Pulse Audio JACK Sink)

That means you have the ice 1712 module loaded. So if audio is coming out the headphone jack, that means JACK is using the built-in audio.

You need to go to the setup dialogue of Qjackctl and select the 2496. Then JACK sink will send the output to the 2496. If that doesn't work, check the JACK connections in the appropriate Qjackctl window.

Plug&Play
Established Member
Posts: 25
Joined: Sat Jan 14, 2017 2:09 am

Re: m-audio Audiophile 2496 PCI - and getting nowhere...

Postby Plug&Play » Fri Mar 29, 2019 6:05 pm

glowrak guy -

I see that "card 1" is [M Audio Audiophile 24/96]

Code: Select all

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: M2496 [M Audio Audiophile 24/96], device 0: ICE1712 multi [ICE1712 multi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Studio7010:...~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: M2496 [M Audio Audiophile 24/96], device 0: ICE1712 multi [ICE1712 multi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


so I modified my .jackdrc by adding the a new line:

Code: Select all

$ cat .jackdrc
/usr/bin/jackd -dalsa -dhw:PCH,0 -r44100 -p256 -n2 -Xseq
/usr/bin/jackd -alsa -r44100 -n2 -D -Chw:[M Audio Audiophile 24/96] -Phw:[M Audio Audiophile 24/96]



did you post an attachment of your .jackdrc ? I don't see it.
Without the example, I didn't know if both Chw: and Phw: would be the same, or if the brackets should be included.

Regardless, as merlyn suggested, I experimented with the qjackctl Setup:
jack interfaces2019-03-29_cr1.png

and consistanly get errors when either of the M2494 options are selected in setup.

Code: Select all

11:00:36.331 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started


thank you both for your help with this, I am anxious to hear further suggestions.
You do not have the required permissions to view the files attached to this post.

Rob

Music Music Music !

merlyn
Established Member
Posts: 323
Joined: Thu Oct 11, 2018 4:13 pm

Re: m-audio Audiophile 2496 PCI - and getting nowhere...

Postby merlyn » Fri Mar 29, 2019 6:59 pm

OK well your .jackdrc is now a mess. :) So we'll sort that. Try this: (it's only one line)

Code: Select all

/usr/bin/jackd -dalsa -dhw:M2496 -r44100 -p256 -n2 -Xseq

That's changed the hardware device from PCH,0 to M2496

User avatar
nikgnomicradio
Established Member
Posts: 75
Joined: Wed Feb 07, 2018 9:31 pm
Contact:

Re: m-audio Audiophile 2496 PCI - and getting nowhere...

Postby nikgnomicradio » Sat Mar 30, 2019 2:13 am

In the Playback tab of the system "sound setting" display I have two volume control sliders
1) identified by a speaker icon and the words "system audio"
2) identified by a firefox icon and the words "audioIPCserver : audiostream [i]on[i]
and three choices in a box
a) builtin Audio Analog Stereo
b) ICE1712 - M Audio Audiophile 24/96
c) Jack Sink (Pulse Audio JACK Sink)

That will be settings for Pulseaudio
you want to set playback there to c) Jack Sink. if your M-Audio Card is in use with JACK, selecting b) will not work as Pulseaudio cannot connect to card

That card may not be happy with only 44100Hz. I have a similar card ICE1724 that works much better on 48000Hz

There were some recent updates with QjackCtl and I believe it may not be using .jackdrc configuration
Shouldn't need to edit files or similar with Ubuntu Studio anyway
I usually just select device, adjust the 3 other settings in QjackCtl Parameters (if needed) and JACK server can then be started

Plug&Play
Established Member
Posts: 25
Joined: Sat Jan 14, 2017 2:09 am

Re: m-audio Audiophile 2496 PCI - and getting nowhere...

Postby Plug&Play » Sat Mar 30, 2019 6:09 pm

All -

While reading the advice here, and trying to work through this, I was investigating, attempting to find the manual for jackqtl.
I came upon the this on page
https://www.rncbc.org/drupal/node/1814

from the moment you have jackdbus rigged into the system, it just takes full control and charge of the jack-server auto-starting and what not. also, running jackd on those environments is simply a masochistic and futile experience: you'll get only pain on every other run; mind you, if you want to have control of the jack-server from the command line, then use `jack_control` as your best bet.


I am running jackqtl - is changing .jackd actually doing anything?

Rob

Music Music Music !

Plug&Play
Established Member
Posts: 25
Joined: Sat Jan 14, 2017 2:09 am

Re: m-audio Audiophile 2496 PCI - and getting nowhere...

Postby Plug&Play » Sat Mar 30, 2019 8:07 pm

nikgnomicradio -
Thanks for the useful input. I am trying to migrate
    from: using my system built in audio hardware to send sound to computer speakers
    to: using my m-audio pci card to send line out to an amplifier
I assume I was using pulseaudio - I had to stop Qjackctl to get sound from the browser or parole media player. Once I figured that out it did not seem an inconvenience, when restarting jack I found all the connections to be as they had been before stopping.

nikgnomicradio wrote:
<snip>
There were some recent updates with QjackCtl and I believe it may not be using .jackdrc configuration
Shouldn't need to edit files or similar with Ubuntu Studio anyway
I usually just select device, adjust the 3 other settings in QjackCtl Parameters (if needed) and JACK server can then be started


Just to clarify: I assume that when I click on the speaker icon in the desktop panel I am opening the pulseaudio audio control.
It has 5 tabs, one of which is "Output Devices", in which I can mute "builtin audio analog stereo" and enable the ICE1712 - M Audio Audiophile 24/96
At present, the playback tab only offers "System Sounds", and QjackCtl will not start with hw:M2496" selected in the settings tab.

I am pretty motivated to solve this, thank you for your help, please comment.

Rob

Music Music Music !

merlyn
Established Member
Posts: 323
Joined: Thu Oct 11, 2018 4:13 pm

Re: m-audio Audiophile 2496 PCI - and getting nowhere...

Postby merlyn » Sun Mar 31, 2019 11:56 am

rncbc wrote:running jackd on those environments is simply a masochistic and futile experience:

jackd and jackdbus are two different ways of starting JACK (the JACK server). rncbc is saying choose one or the other. Qjackctl allows the choice between the two. When I have used Qjackctl the default has been jackd.

You can have a look at the JACK logs and see exactly why JACK is not starting. More information is available by ticking the 'verbose' checkbox in Qjackctl.

User avatar
Linuxmusician01
Established Member
Posts: 400
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: m-audio Audiophile 2496 PCI - and getting nowhere...

Postby Linuxmusician01 » Sun Mar 31, 2019 12:36 pm

My apologies on beforehand that I've not read the complete topic but I read that there may be some troubles in determining in what way qjackctl starts Jack. To test things at least I wouldn't use qjackctl. Just start Jack from the command line and see if everything works:

Code: Select all

jackd -d alsa --device hw:1

That is, if you have 2 sound cards and you want to use the second (Alsa starts numbering your audio cards at 0). Determine the number of your preferred audio device with this command:

Code: Select all

cat /proc/asound/cards

After starting Jack this you can still use qjackctl to connect things etc.

glowrak guy
Established Member
Posts: 1302
Joined: Sat Jun 21, 2014 8:37 pm

Re: m-audio Audiophile 2496 PCI - and getting nowhere...

Postby glowrak guy » Sun Mar 31, 2019 1:15 pm

Plug&Play wrote:nikgnomicradio -
Thanks for the useful input. I am trying to migrate
I am pretty motivated to solve this, thank you for your help, please comment.

In qjackctl Advanced panel,
I have

Output Device hw:M2496
Input Device hw:2496

(when you click the selector widget \/ for the above devices,
the soundcards displayed within brackets of the aplay/arecord command output
should appear in the dropdown list of cards that opens. So your motherboard
soundchips will also be listed)

In qjackctl Parameters panel,
Driver: Alsa
MIDI Driver: none

.jackdrc:

/usr/bin/jackd -P80 -dalsa -r44100 -p256 -n2 -D -Chw:M2496 -Phw:M2496

also, the important textfile /etc/security/limits.conf concludes with the lines
below, which if absent in yours, should be appended:

@audio - rtprio 95
@audio - memlock unlimited
#@audio - nice -19

(when appending the lines above, I match the text spacing
of the original limits.conf for luck.)
The @audio implies you need to be part of the audio group,
the command to do that if needed is

adduser yourname audio

The '95' can be anything between about 70, and 98 (choosing 99 could in rare instances
lockup your system during kernel 'housecleaning')

The separate priority setting in qjackctl is meant to be proportionately lower
than the one in limits.conf ...you'll see -P80 in my .jackdrc
indicating I chose a priority of 80 when configuring qjackctl

For Years, I had the two priorities settings at 99 and 89, without
issues, but smarter people than I consider it lucky
to set those a bit lower, on the safe side.
Cheers


Return to “Computer Related Hardware”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests