Anyone using Zoom LiveTrak L-12

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

User avatar
tmray
Posts: 2
Joined: Wed Aug 22, 2018 8:38 pm
Contact:

Anyone using Zoom LiveTrak L-12

Post by tmray »

The band has been talking about getting a Zoom LiveTrak L-12, but before plunking down the money for it I was curious if anyone has tried running it on a Linux OS?

My set up would mainly be using Ardour and I want to get it running for multitrack recordings. So just curious to see how well it works if anyone knows.

I know that all the tracks are also able to record as separate files on an sd card but I'd rather use it directly instead of importing files if I could.
Singer for the open source, creative commons band Lorenzo's Music.
Everything we make is done with open source software and tools including our latest release
Rom-Comm Mixtape - https://open.spotify.com/album/7KnhZZKSNuy5ahbQd6ga8O
uulbri
Established Member
Posts: 10
Joined: Mon Dec 09, 2019 8:05 am

Re: Anyone using Zoom LiveTrak L-12

Post by uulbri »

Hello,
Any chance you got the answer by now ?

I am planning to buy it, and replace my Yamaha MG12XU (which was perfectly compatible but with a pretty standard USB interface 2in/2out).
I would probably use the same setup (Ardour). My only question is the same as yours: Is this beast seen as a 14in/4out USB sound device... ?

Thank you in advance if you got any answer.
uulbri
Established Member
Posts: 10
Joined: Mon Dec 09, 2019 8:05 am

Re: Anyone using Zoom LiveTrak L-12

Post by uulbri »

I couldn't resist and bought one...

First Everything works perfectly with jackd, which is really cool. All 14ins and 4outs are correctly detected, and in Ardour it's a pleasure to record in parallel...

But very surprisingly:
  • I couldn't having it setup correctly with bare ALSA. alsamixer keeps on showing "This sound device does not have any capture controls" for the capture part and "Internal validity" for the playback part... which is non-sense. I cannot even understand how jack can fully work with such a broken setup in ALSA...
  • PulseAudio doesn't see the 4 outs as two separated stereo channels (which actually it is physically...) but as an analog-surround-40, resulting in everything sent to the two stereo channels at once. And for the capture although it detects it is a multichannel-input, it is considered as one input of the 14 channels equally mixed...
Any idea/help appreciated...
--
Uulbri
naught101
Established Member
Posts: 5
Joined: Mon Jan 06, 2014 7:21 am

Re: Anyone using Zoom LiveTrak L-12

Post by naught101 »

uulbri wrote: Mon Dec 23, 2019 6:23 pm First Everything works perfectly with jackd, which is really cool. All 14ins and 4outs are correctly detected, and in Ardour it's a pleasure to record in parallel...
Hey Uulbri,
did you have to do anything special to get the livetrak to be recognised? I have a livetrak8, but have just plugged it in to my laptop for the first time, and am not getting any response - it shows up with lsusb, but it doesn't show up in alsamixer or in cadence as an actual sound card. Wondering if there are some particular packages I need to install or anything?
uulbri
Established Member
Posts: 10
Joined: Mon Dec 09, 2019 8:05 am

Re: Anyone using Zoom LiveTrak L-12

Post by uulbri »

Starts being a while now.

I don't remember having done anything very specific for jackd apart maybe installation related to generic USB devices handling, which actually I have been doing much earlier for other USB hardware, and that I don't remember. One thing, you have to avoid USB 1.1 ports (I don't know what your laptop is providing...)

The status is still the same as in my previous post (Ubuntu 18.04)
  • ALSA: KO (which still makes absolutely no sense to me)
  • Pulsaudio: Almost ok for a desktop usage
  • Jackd: Fully working
The only, but very important thing to do is to switch to "class compliant mode" (in the back-panel of the device)
Image

My sample rate is 48MHz (same as what I did setup in jackd), 41MHz is working as well, I'm not sure I ever tried 96MHz...

Are you sure you did setup correctly jackd. Mine was working before buying this device. So I knew everything was ok beforehand.
alsamixer, as I reported definitely doesn't work. I don't use cadence, are you sure it's actually using jackd as sound backend ? What is your distro ?
--
Uulbri
naught101
Established Member
Posts: 5
Joined: Mon Jan 06, 2014 7:21 am

Re: Anyone using Zoom LiveTrak L-12

Post by naught101 »

uulbri wrote: Mon May 04, 2020 2:27 pm Are you sure you did setup correctly jackd. Mine was working before buying this device. So I knew everything was ok beforehand.
alsamixer, as I reported definitely doesn't work. I don't use cadence, are you sure it's actually using jackd as sound backend ? What is your distro ?
Thanks for the reply. I think I had the wrong version of jackd installed. Works now with jack2. On kubuntu 20.04.

I actually have a Livetrak 8, which doesn't have the external power supply. However, it requires you to unplug the USB in order to switch it to iOS/standards-compliant mode, which powers it down. That means that the only way to run it as an interface is on batteries, and it runs the batteries flat pretty quick. Pretty annoying. I guess I could just record stuff to the SD card, and import it manually, but it'd be nicer to just have things work. Still not sure if I'll keep trying. The livetrak 12 seems a bit big to me, but I also haven't seen many other good alternatives that can act as a mixer, multi-track recorder, AND as a USB interface..
NoMasters
Established Member
Posts: 3
Joined: Sat Nov 29, 2014 11:26 pm

Re: Anyone using Zoom LiveTrak L-12

Post by NoMasters »

So you were able to get Jack to recognize the L-8? I haven't had any such luck. I've done a bunch of searching on this and this seems to be the only thread. I even wrote Zoom and they just plainly said they don't support linux. Personally I wish Jack was more approachable I've been using Linux for years personally and professionally and I still can never seem to get Jack working correctly.
uulbri
Established Member
Posts: 10
Joined: Mon Dec 09, 2019 8:05 am

Re: Anyone using Zoom LiveTrak L-12

Post by uulbri »

As long as you set the device in "compliant mode", which in Zoom language means "Connecting to an iOS device" (it is well known that iOS devices are the embodiment of "compliance" and "standard"...), it should be detected automatically by jack (if you have a reasonably fresh enough and working install of jack).
--
Uulbri
tossin
Established Member
Posts: 4
Joined: Fri Nov 27, 2020 12:06 pm

Re: Anyone using Zoom LiveTrak L-12

Post by tossin »

Hello everyone,
I also use the L-12 and can confirm that it works perfectly with jack if the interface is set to "class compliant mode" and connected to USB 2.0 port as uulbri already said.

Regarding the issue that pulseaudio mixes all 14 inputs to a single input (which means that each physical channel only has a very low volume in this mix), I found a solution by remapping the channels in pulseaudio:

In pulseaudio language the 14 input channels are called [front-left,front-right,rear-left,rear-right,front-center,lfe,side-left,side-right,aux0,aux1,aux2,aux3,aux4,aux5]. One can remap them to create separate inputs in pulseaudio.

The following command creates a new input device which is called "L-12-In-1" and only includes the first channel (with full volume).

Code: Select all

pacmd load-module module-remap-source source_name=L-12-In-1 source_properties=device.description=L-12-In-1 master=alsa_input.usb-ZOOM_Corporation_L-12_7243FFFFFFFFFFFF3F2FFFFFFFFFFFFF-00.multichannel-input master_channel_map=front-left channel_map=mono
All other channels can be added in the same manner by replacing the "master_channel_map=front-left" by the pulseaudio channel names given above (e.g. "aux3" for the 12th channel").

To get these settings on the start up of pulseaudio you can add the command without the leading "pacmd" to your /etc/pulse/default.pa
(To apply the changes whenever the interface is plugged in one needs to define a udev rule. I haven't done that yet.)

Here is the pulseaudio documentation on this remapping
https://www.freedesktop.org/wiki/Softwa ... map-source

I hope that helps.

Cheers,
Tossin
uulbri
Established Member
Posts: 10
Joined: Mon Dec 09, 2019 8:05 am

Re: Anyone using Zoom LiveTrak L-12

Post by uulbri »

Yesss ! super cool tossin,

I was sure there should be a possibility like that. Will try it.
But I think I have some missing pieces of the puzzle especially on how you can get the property values to assign to
* source_name
* source_properties
* master
* master_channel_map
* channel_map

I guess this is somehow using pactl or something like that, but could you specify exactly how to get the right values as the one you provided are specific to your own device ?

Thank you in advance tossin
Last edited by uulbri on Fri Nov 27, 2020 2:16 pm, edited 1 time in total.
--
Uulbri
uulbri
Established Member
Posts: 10
Joined: Mon Dec 09, 2019 8:05 am

Re: Anyone using Zoom LiveTrak L-12

Post by uulbri »

Ok for the master value just do:
pactl list |grep alsa_input |grep ZOOM |grep device.master_device
This is how you get the correct value for your own device (master=).

For source_name and device.description use whatever you want but "L-12-In-xx" as mentioned by tossin for each entry seems a good idea.
For master_channel_map use the name corresponding to to the number of your ZOOM input in the array of values mentioned by tossin ([front-left,front-right,rear-left,rear-right,front-center,lfe,side-left,side-right,aux0,aux1,aux2,aux3,aux4,aux5]). These are default names, I guess it could customized as they make no sense... but it works.

Thanks a lot tossin... That definitely helped.
--
Uulbri
tossin
Established Member
Posts: 4
Joined: Fri Nov 27, 2020 12:06 pm

Re: Anyone using Zoom LiveTrak L-12

Post by tossin »

You are welcome! I actually only got on the right track due to your comment that the standard input is just a mix of all 14 channels.

I use the L-12 usually with my notebook, so I need the remapping when the card is plugged in. So my suggestion of adding the load-module commands to /etc/pulse/default.pa does not work in this case. (and it's anyway not a good solution because this file will probably be overwritten when the pulseaudio package gets an update.)

Here is how I manged to get the correct remapping on startup and every time the L-12 is plugged in. I don't know how clean this solution is. My hacky scripts are certainly not perfect but they work now quite fine.

What we need:
  • a script where the remappings are defined
  • a systemd service which starts the script, this service will be started when the user logs in
  • a udev rule which starts the systemd service whenever the L-12 is plugged in
The script
I call it remap-L12.sh and place it somewhere in my home directory

Code: Select all

#!/bin/bash

##First of all we need to check if pulseaudio is already running with our user id. This is important on startup because the service needs some time until it is ready for use.

pidofpulse=$(pidof pulseaudio)	##get process id of pulseaudio
uidofpulse=$(ps -o uid -p $pidofpulse |grep -o '[0-9]*') ##get user id of the pulseaudio process

##wait until we own the pulseaudio process
while [ $uidofpulse != $UID ]; do
	sleep .1
	
	pidofpulse=$(pidof pulseaudio)
	uidofpulse=$(ps -o uid -p $pidofpulse |grep -o '[0-9]*')
done

PULSE_RUNTIME_PATH="/var/run/user/$UID/pulse" ##runtime path of pulseaudio, might depends on the distro, tested on Manjaro linux
export PULSE_RUNTIME_PATH ##export the path to make it available for the pacmd and pactl command

sleep .1 ##let's wait... somehow necessary to establish the runtime path before we continue
##increase the sleeping time if the following remapping only works occasionally

##Remapping of the channels
##about the values:
#the values of "source_name" and "source_properties=device.description" and can be choosen freely and determine how the channels are called in your system
#"master" is the master input of the zoom. 
masterinput=$(pactl list |grep -m 1 -E -o 'alsa_input.usb-ZOOM\S*') ##get name of master device
#"remix=no" avoids unnecessary remixing by the pulseaudio server
#"master_channel_map" is the pulseaudio name for the channel to be remapped. The 14 physical inputs have the names [front-left,front-right,rear-left,rear-right,front-center,lfe,side-left,side-right,aux0,aux1,aux2,aux3,aux4,aux5]
#"channel_map=mono": the input appears as a single mono channel in the pulseaudio system

       
##I remap the first two channels of the L-12 to make them available as separate inputs.
pacmd load-module module-remap-source source_name=L-12-In-1 source_properties=device.description=L-12-In-1 master=$masterinput remix=no master_channel_map=front-left channel_map=mono 

pacmd load-module module-remap-source source_name=L-12-In-2 source_properties=device.description=L-12-In-2 master=$masterinput remix=no master_channel_map=front-right channel_map=mono

#pacmd load-module module-remap-source source_name=L-12-In-3 source_properties=device.description=L-12-In-3 master=$masterinput remix=no master_channel_map=rear-left channel_map=mono
#pacmd load-module module-remap-source source_name=L-12-In-4 source_properties=device.description=L-12-In-4 master=$masterinput remix=no master_channel_map=rear-right channel_map=mono

##Here is how to make channels 11/12 available as a stereo channel in pulseaudio (not tested)
pacmd load-module module-remap-source source_name=L-12-In-11_12 source_properties=device.description=L-12-In-11/12 master=$masterinput remix=no master_channel_map=aux2,aux3 channel_map=left,right

##Since the remapping works on top of the master inputs we set the latter to 0dB (100% volume). The volume is then controlled by the remapped inputs.
pactl set-source-volume $masterinput 0x10000 


###OUTPUTS
masteroutput=$(pactl list |grep -m 1 -E -o 'alsa_output.usb-ZOOM\S*')  
#Make the USB-Out-1-2, 3-4 available as two separate stereo channels
pacmd load-module module-remap-sink sink_name=L-12-Out-1-2 sink_properties=device.description=L-12-Out-1-2 master=$masteroutput remix=no master_channel_map=front-left,front-right channel_map=left,right

pacmd load-module module-remap-sink sink_name=L-12-Out-3-4 sink_properties=device.description=L-12-Out-3-4 master=$masteroutput remix=no master_channel_map=rear-left,rear-right channel_map=left,right

##Since the remapping works on top of the master outputs we set the latter to 0dB (100% volume). The volume is then controlled by the remapped outputs.
pactl set-sink-volume $masteroutput 0x10000

### Make some devices default
pacmd set-default-sink L-12-Out-1-2
pacmd set-default-source L-12-In-1

exit 0
I only activated the first two channels because I usually use jack if I need more than two inputs. Adding more inputs should be straight forward. I also remapped the 4 outputs to 2 separate stereos. So one can use them independently.

Make the script executable.

The systemd service
We need a file called for example remap-L12.service that we place in ~/.config/systemd/user/
Here is the content. Make sure to change the path to your script.

Code: Select all

[Unit]
Description=Remap inputs of ZOOM L-12 sound card
After=pulseaudio.service
After=pulseaudio.socket

[Service]
Type=oneshot
RemainAfterExit=no
ExecStart=/ABSOLUTE-PATH-TO-YOUR-SCRIPT/remap-L12.sh

[Install]
WantedBy=default.target
Enable the new service

Code: Select all

systemctl --user enable remap-L12.service
The udev rule
As root create a file called 100-zoom-l-12.rules in the directory /lib/udev/rules.d/
Content:

Code: Select all

ATTRS{idVendor}=="1686", ATTRS{idProduct}=="03d5", TAG+="systemd", ACTION=="add", ENV{SYSTEMD_USER_WANTS}+="remap-L12.service"
The idVendor and idProduct should be the same for any L-12. It is certainly different for the L-8! You can find the correct number by running

Code: Select all

lsusb | grep ZOOM
That's it! To check if everything works correctly you should restart the computer.

I tested this on Manjaro linux. On other systems the udev rules might be located somewhere else. The path to the pulse environment could also be a different one (see comment in the script).

Remark on the ZOOM L-8: I think that most of the things should also work for the smaller device. You definitely need to change the product id in the udev rule. Perhaps also the output remapping could cause problems because the device has only 2 and not 4 outputs.

Have a nice weekend!
Tossin
iwanttobefreak
Posts: 1
Joined: Fri Jan 01, 2021 5:54 pm

Re: Anyone using Zoom LiveTrak L-12

Post by iwanttobefreak »

Hello.
Excuse me, I'm noobie with this.
I have a L-12 ti test.
I connect to my computer but can't detect usb device in Alsa. I don't understand the configuration with jack, because I can't select the device, I have in driver Alsa, portaudio, .... but can't detect usb device

lsusb

Code: Select all

Bus 001 Device 027: ID 1686:03b5 ZOOM Corporation L-12
dmesg

Code: Select all

[ 1904.761698] usb 1-3: new high-speed USB device number 27 using xhci_hcd
[ 1904.911848] usb 1-3: New USB device found, idVendor=1686, idProduct=03b5, bcdDevice= 0.17
[ 1904.911855] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1904.911858] usb 1-3: Product: L-12
[ 1904.911861] usb 1-3: Manufacturer: ZOOM Corporation
[ 1904.911864] usb 1-3: SerialNumber: 9513FFFFFFFFFFFF2C3FFFFFFFFFFFFF
I have debian testing
uname -a

Code: Select all

Linux avtp239 5.9.0-5-amd64 #1 SMP Debian 5.9.15-1 (2020-12-17) x86_64 GNU/Linux
I have test with other table, the rodecaster, and detect the usb and all fine.
Could you please give me some documentation how can I configure L-12?

A lot of Thanks.
tossin
Established Member
Posts: 4
Joined: Fri Nov 27, 2020 12:06 pm

Re: Anyone using Zoom LiveTrak L-12

Post by tossin »

Hi iwanttobefreak,

probably your zoom is not running in the correct driver mode. On the back side of the L-12 you find a switch that is labelled "Class Compliant Mode". For Linux this has to be set to "On". (For Windows it must be "Off).

After toggling this switch you have to restart(!) the L-12 (disconnecting and reconnecting the usb cable is NOT sufficient).

After this the output of lsusb should change slightly and now reads "ZOOM Corporation LiveTrak L-12". Can you confirm that?

The L-12 should now appear in the "audio settings" menu of Debian. If this doesn't help you can try to use another usb port of your computer. (For my notebook only 2 of 3 usb ports work with the L-12).

If the problems persist, please post the output of

Code: Select all

pactl list sinks
and

Code: Select all

pactl list sources
Cheers,
tossin
MigrantRecordings
Posts: 1
Joined: Mon Feb 01, 2021 8:06 pm

Re: Anyone using Zoom LiveTrak L-12

Post by MigrantRecordings »

I've got mine running almost perfectly with Ubuntu Studio 20.10 and jack, my only problem so far is that the sound card is not detected when running at 96000 so i can only go 48000 for now...
Did anyone manage to get it working at 96000??
//Samuel @ Migrant Recordings
Post Reply