Page 1 of 1

JACK capturing onboard mic

Posted: Fri Jan 11, 2019 4:39 pm
by donnek
I'm using a new Ubuntu 18.04 install with kxstudio on an Acer Aspire V laptop. Running the quickscan script gives:

Code: Select all

== GUI-enabled checks ==
Checking if you are root... no - good
Checking filesystem 'noatime' parameter... 4.15.0 kernel - good
(relatime is default since 2.6.30)
Checking CPU Governors... CPU 0: 'powersave' CPU 1: 'powersave' CPU 2: 'powersave' CPU 3: 'powersave'  - not good
Set CPU Governors to 'performance' with 'cpupower frequency-set -g performance' or 'cpufreq-set -c <cpunr> -g performance' (Debian/Ubuntu)
See also: http://linuxmusicians.com/viewtopic.php?f=27&t=844
Checking swappiness... 10 - good
Checking for resource-intensive background processes... none found - good
Checking checking sysctl inotify max_user_watches... < 524288 - not good
increase max_user_watches by adding 'fs.inotify.max_user_watches = 524288' to /etc/sysctl.conf and rebooting
For more information, see http://wiki.linuxaudio.org/wiki/system_configuration#sysctlconf
Checking access to the high precision event timer... readable - good
Checking access to the real-time clock... readable - good
Checking whether you're in the 'audio' group... yes - good
Checking for multiple 'audio' groups... no - good
Checking the ability to prioritize processes with chrt... yes - good
Checking kernel support for high resolution timers... found - good
Kernel with Real-Time Preemption... not found - not good
Kernel without real-time capabilities found
For more information, see http://wiki.linuxaudio.org/wiki/system_configuration#installing_a_real-time_kernel
Checking if kernel system timer is high-resolution... found - good
Checking kernel support for tickless timer... found - good
== Other checks ==
Checking filesystem types... ok.
** Set $SOUND_CARD_IRQ to the IRQ of your soundcard to enable more checks.
   Find your sound card's IRQ by looking at '/proc/interrupts' and lspci.


lspci gives (edited):

Code: Select all

00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)


Cadence -> Configure -> Driver -> Input Device is set to "none", and Output Device to "hw:PCH,0 [ALC283 Analog]".

With JACK running (no MIDI or PulseAudio started), I open Catia and Guitarix, and add (for instance) the multiband distortion module to Guitarix. However, once I connect the system capture to gx_head_amp, I get a whining noise,and if I (eg) shout I can hear that on the Guitarix-modulated output!

This suggests that capture is linked to the onboard mic in the laptop, but I can't find any way to turn that off. I've used alsamixer to select the HDA Intel PCH entry and mute Mic Boost and Capture, but it has no effect.

I was originally trying to use a Scarlett 2i2 USB input (selecting it as the Input Device), and trying to trace the godawful whine from that led me to the above minimal configuration. The odd thing is that I tried the 2i2 a couple of days ago, and I can't remember the whine being there then. In the meantime I installed a couple to WINE apps to test them (Guitar Pro and Reaper) - could that have anything to do with it?

Any advice on how I can fix this problem would be gratefully received.

Re: JACK capturing onboard mic

Posted: Fri Jan 11, 2019 6:38 pm
by Musicteacher
Guitarix auto-connects input in default-config.

Have a look at Jack-Ports in guitarix, maybe there is a check at that microphone!

Re: JACK capturing onboard mic

Posted: Fri Jan 11, 2019 10:43 pm
by donnek
No, they're not ticked, but if I do tick them I get the same effect as manually connecting in Catia, namely, input from the onboard mic. I think it must be some setting of the onboard soundcard, but I can't think of how to access that. Thanks anyway.

Re: JACK capturing onboard mic

Posted: Fri Jan 11, 2019 11:04 pm
by tavasti
I suggest that you go thru all audio devices with alsamixer. With F6 you can select device.

What is your audio device you are going to use for capturing your guitar signal?

Re: JACK capturing onboard mic

Posted: Mon Jan 14, 2019 5:03 pm
by donnek
Yes, I've already tried to mute Mic Boost and Capture on the onboard card using alsmixer, but it seems to have no effect once the capture port is connected to (eg) guitarix. The input device is a Scarlett 212 (USB).

Re: JACK capturing onboard mic

Posted: Mon Jan 14, 2019 7:25 pm
by Musicteacher
So you use the scarlett again?

Then you must use that as jack-device, for input and output (you could use both sound card, but this is an advanced topic and won't give optimal results).

Select your Scarlett as Audio hardware in cadence, then you should get things working.

Re: JACK capturing onboard mic

Posted: Mon Jan 14, 2019 9:53 pm
by Pablo
I was originally trying to use a Scarlett 2i2 USB input (selecting it as the Input Device), and trying to trace the godawful whine from that led me to the above minimal configuration. The odd thing is that I tried the 2i2 a couple of days ago, and I can't remember the whine being there then. In the meantime I installed a couple to WINE apps to test them (Guitar Pro and Reaper) - could that have anything to do with it?


I am not sure but I suggest the following.

First, make sure you are muting the mic in the "capture" view of alsamixer (F4), not just in the default "playback" view.

Then, it could be two instances of jackd are running? Maybe jackd and jackdbus at the same time, launched by different programs, with a different input device selection? So, try killing up jackd processes:

killall -9 jackd jackdbus

Issue the above command again, until neither process is found and try again.

Re: JACK capturing onboard mic

Posted: Thu Jan 17, 2019 8:46 am
by donnek
Yes, I muted in both the playback and capture screens.

I ran the killall command, but (response: jackd: no process found) when I start JACK again with Cadence, load Guitarix, and connect capture to gx_head_amp, I still get sound from the flippin' onboard mic!

Re: JACK capturing onboard mic

Posted: Thu Jan 17, 2019 11:57 am
by Musicteacher
I repeat my question: Do you use the scarlett interface again? Did you reconfigure jack to use the scarlett interface?

Re: JACK capturing onboard mic

Posted: Thu Jan 17, 2019 5:50 pm
by tavasti
Run following commands and post output:
cat .jackdrc
arecord -l

Re: JACK capturing onboard mic

Posted: Thu Jan 24, 2019 2:33 pm
by donnek
@ Musicteacher
When I plugged the Scarlett in, there was an almighty racket. So I unplugged it to troubleshoot, and discovered that simply by attaching the onboard capture to Guitarix I get ambient sounds from the room, my typing, etc.

@ tavasti
Here's the info:

Code: Select all

kevin@Aspire-V3-371:~$ cat .jackdrc
/usr/bin/jackd -dalsa -dhw:PCH,0 -r44100 -p1024 -n2 -D -Chw:CODEC
kevin@Aspire-V3-371:~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: Loopback [Loopback], device 0: Loopback PCM [Loopback PCM]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 1: Loopback [Loopback], device 1: Loopback PCM [Loopback PCM]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 2: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0