Ultralite AVB

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: MattKingUSA, khz

frankbuss
Posts: 2
Joined: Sun Aug 25, 2019 2:29 am

Re: Ultralite AVB

Post by frankbuss »

bluebell wrote:As I posted in another thread:

I bought an Ultralite AVB and was disappointed when I had the "traveling channels"-issue.

I tested the latest firmware versions from http://motu.com/techsupport/technotes/f ... changelog/ and found out that 1.3.2+520 is the latest version that provides error-free operation.
I bought it, too, and there was even a firmware later than the latest official version v1.3.5+626 installed. I had the same traveling channels problem: When starting playback, it worked for a few seconds on one stereo pair, then disappeared slowly with lots of noise, and I could see in the web interface that it moved to higher channels. Then after some minutes it was again on the first 2 channels. Installing version 1.3.2+520 fixed this.

But now I have a problem that I can't play with 192 kHz. For example I start Audacity and play a file with 192 kHz (with ALSA), and project rate set as well to 192 kHz. But in the display of the Motu I see only "48k". Changing the samplerate in general works, because I can set it to 44.1 kHz and then the display shows "44k".

Looks like Motus is "famous" for bad USB implementations. For example another device had problems with MIDI, because the Motu USB implementation was not implemented according to the USB specification:

https://lore.kernel.org/lkml/Pine.LNX.4 ... wland.org/

Might work in Windows and Mac by chance, but maybe will stop working with the next OS update, all bets are off if it is not implemented right. Might be very good audio quality, but I'm thinking about returning it if USB doesn't work stable.

If I can't get it to work, does anyone know another audio interface with DC coupled outputs and 192 kHz samplerate which works in Linux?

User avatar
bluebell
Established Member
Posts: 1332
Joined: Sat Sep 15, 2012 11:44 am
Location: Saarland & Frankfurt, Germany

Re: Ultralite AVB

Post by bluebell »

frankbuss wrote: But now I have a problem that I can't play with 192 kHz. For example I start Audacity and play a file with 192 kHz (with ALSA), and project rate set as well to 192 kHz. But in the display of the Motu I see only "48k". Changing the samplerate in general works, because I can set it to 44.1 kHz and then the display shows "44k".
The problem seem to affect only Class Compliant operation. Since I don't need higher sample rates I don't run into this issue.

Did you report this bug to MOTU? When I reported the channel hopping issue they wrote:
Thanks for reaching out. We're aware of this issue and do apologize. As far as we know, it's only specific to non-Mac/Windows class compliant mode. For instance, Linux will show this issue almost immediately.
That being said, I hope to see this fixed soon. I just don't know of an exact time frame. It's in line. That's about all I can say.
So I am looking forward to the next firmware version.
Linux – MOTU UltraLite AVB – Qtractor – https://soundcloud.com/suedwestlicht

frankbuss
Posts: 2
Joined: Sun Aug 25, 2019 2:29 am

Re: Ultralite AVB

Post by frankbuss »

bluebell wrote:
frankbuss wrote: But now I have a problem that I can't play with 192 kHz. For example I start Audacity and play a file with 192 kHz (with ALSA), and project rate set as well to 192 kHz. But in the display of the Motu I see only "48k". Changing the samplerate in general works, because I can set it to 44.1 kHz and then the display shows "44k".
The problem seem to affect only Class Compliant operation. Since I don't need higher sample rates I don't run into this issue.
This article says that even USB Audio Class 1 standard (from 1998) "doesn't impose any limitation on sample rate":

http://thewelltemperedcomputer.com/KB/USB.html

But class 2 (from 2009) explicitly supports sample rates up to 384 kHz. So it is not a problem of the class compliant standard. I'll ask the support.

User avatar
bluebell
Established Member
Posts: 1332
Joined: Sat Sep 15, 2012 11:44 am
Location: Saarland & Frankfurt, Germany

Re: Ultralite AVB

Post by bluebell »

Yes, I think it's a bug in the firmware, not a limitation in the standard.
Linux – MOTU UltraLite AVB – Qtractor – https://soundcloud.com/suedwestlicht

Drumfix
Established Member
Posts: 255
Joined: Mon Jan 26, 2009 5:15 pm

Re: Ultralite AVB

Post by Drumfix »

Connect the Ultralite to Ethernet and set the samplerate in the Web UI.

fsciarra62
Established Member
Posts: 10
Joined: Mon Oct 14, 2019 12:22 am

Re: Ultralite AVB

Post by fsciarra62 »

well...
I’ve just bought yesterday an Ultralite AVB after having read this thread...
So I knew that some troubles were right there to bother... but I wanted to have dc-coupled on linux.
I can confirm that for my unit the only “working” firmware is 1.3.2+520... and I cannot get before 1.2.9 because the firmware uploader complaints that it’s not compatible with my hardware.

I have the error when applying configuration with qjackctl but in generalI just need to clear errors popups and do it again and it works.

I’m currently using 48000hz, 128 bytes buffer, three buffers.
If I try two buffers, after a while (long while) I get some “dirty” in the sound.
I experience some xruns but apparently with no audio dropouts...
I have tried all rates and it works pretty well.
I still have to record.

I will post further experiences next...

Regards,
Fabrizio

ahellquist
Established Member
Posts: 41
Joined: Mon Jul 01, 2013 12:28 am

Re: Ultralite AVB

Post by ahellquist »

I am using 1.3.4+558 which was one of the betas for their Touch Console Mixer and works quite well if you need newer firmware but not the ones that doesn't work.

If you want to test it, let me know.

/anders
fsciarra62 wrote:well...
I’ve just bought yesterday an Ultralite AVB after having read this thread...
So I knew that some troubles were right there to bother... but I wanted to have dc-coupled on linux.
I can confirm that for my unit the only “working” firmware is 1.3.2+520... and I cannot get before 1.2.9 because the firmware uploader complaints that it’s not compatible with my hardware.

I have the error when applying configuration with qjackctl but in generalI just need to clear errors popups and do it again and it works.

I’m currently using 48000hz, 128 bytes buffer, three buffers.
If I try two buffers, after a while (long while) I get some “dirty” in the sound.
I experience some xruns but apparently with no audio dropouts...
I have tried all rates and it works pretty well.
I still have to record.

I will post further experiences next...

Regards,
Fabrizio

redplastic
Established Member
Posts: 7
Joined: Wed Dec 18, 2019 7:26 pm

Re: Ultralite AVB

Post by redplastic »

Hi Guys,
New in the forum (but recording under linux since 2013)!
I can't understand how to open the web control panel of my new 828es...
Can you help me configuring it?
I've plugged cat5e and usb, then I've tried to open the mixer on firefox...nothing!
I think I've to configure something more...
THANKS!!

redplastic
Established Member
Posts: 7
Joined: Wed Dec 18, 2019 7:26 pm

Re: Ultralite AVB

Post by redplastic »

ahellquist wrote:I am using 1.3.4+558 which was one of the betas for their Touch Console Mixer and works quite well if you need newer firmware but not the ones that doesn't work.

If you want to test it, let me know.

/anders
fsciarra62 wrote:well...
I’ve just bought yesterday an Ultralite AVB after having read this thread...
So I knew that some troubles were right there to bother... but I wanted to have dc-coupled on linux.
I can confirm that for my unit the only “working” firmware is 1.3.2+520... and I cannot get before 1.2.9 because the firmware uploader complaints that it’s not compatible with my hardware.

I have the error when applying configuration with qjackctl but in generalI just need to clear errors popups and do it again and it works.

I’m currently using 48000hz, 128 bytes buffer, three buffers.
If I try two buffers, after a while (long while) I get some “dirty” in the sound.
I experience some xruns but apparently with no audio dropouts...
I have tried all rates and it works pretty well.
I still have to record.

I will post further experiences next...

Regards,
Fabrizio
Also with a good latency?

User avatar
bluebell
Established Member
Posts: 1332
Joined: Sat Sep 15, 2012 11:44 am
Location: Saarland & Frankfurt, Germany

Re: Ultralite AVB

Post by bluebell »

redplastic wrote:Hi Guys,
New in the forum (but recording under linux since 2013)!
I can't understand how to open the web control panel of my new 828es...
Can you help me configuring it?
I've plugged cat5e and usb, then I've tried to open the mixer on firefox...nothing!
I think I've to configure something more...
THANKS!!
When using Ethernet then you have to know the ip-Adress of the interface. Your router can tell you the address and most routers allow setting a fixed address when you enter the mac address of the device.

If you simply plug the interface with a cable into your PC then you have tu run a dhcp service on your PC.
Linux – MOTU UltraLite AVB – Qtractor – https://soundcloud.com/suedwestlicht

redplastic
Established Member
Posts: 7
Joined: Wed Dec 18, 2019 7:26 pm

Re: Ultralite AVB

Post by redplastic »

bluebell wrote:
redplastic wrote:Hi Guys,
New in the forum (but recording under linux since 2013)!
I can't understand how to open the web control panel of my new 828es...
Can you help me configuring it?
I've plugged cat5e and usb, then I've tried to open the mixer on firefox...nothing!
I think I've to configure something more...
THANKS!!
When using Ethernet then you have to know the ip-Adress of the interface. Your router can tell you the address and most routers allow setting a fixed address when you enter the mac address of the device.

If you simply plug the interface with a cable into your PC then you have tu run a dhcp service on your PC.
Yeah, thank you!
It works quite well with latency around 3ms and the old driver (2017). Great conversion, very clean mic pres. I'll add an Audient ASP800 as soon as possible, I'll let you know how it works!

User avatar
bluebell
Established Member
Posts: 1332
Joined: Sat Sep 15, 2012 11:44 am
Location: Saarland & Frankfurt, Germany

Re: Ultralite AVB

Post by bluebell »

redplastic wrote:
bluebell wrote:
redplastic wrote:Hi Guys,
New in the forum (but recording under linux since 2013)!
I can't understand how to open the web control panel of my new 828es...
Can you help me configuring it?
I've plugged cat5e and usb, then I've tried to open the mixer on firefox...nothing!
I think I've to configure something more...
THANKS!!
When using Ethernet then you have to know the ip-Adress of the interface. Your router can tell you the address and most routers allow setting a fixed address when you enter the mac address of the device.

If you simply plug the interface with a cable into your PC then you have tu run a dhcp service on your PC.
Yeah, thank you!
It works quite well with latency around 3ms and the old driver (2017). Great conversion, very clean mic pres. I'll add an Audient ASP800 as soon as possible, I'll let you know how it works!
I am running "MOTU AVB 1.3.4+558" for UltraLite AVB and Stage-B16.update" that a nice person gave me, that's a beta version and includes the touch console. It doesn't fix the modulo-8-jumping ofthe input channels when changing jackd's bufsize on the fly but it seems to be as stable as "MOTU AVB 1.3.2+520 for UltraLite AVB and Stage-B16.update".

If you want to try it drop me a note.
Linux – MOTU UltraLite AVB – Qtractor – https://soundcloud.com/suedwestlicht

redplastic
Established Member
Posts: 7
Joined: Wed Dec 18, 2019 7:26 pm

Re: Ultralite AVB

Post by redplastic »

bluebell wrote:
redplastic wrote:
bluebell wrote:
When using Ethernet then you have to know the ip-Adress of the interface. Your router can tell you the address and most routers allow setting a fixed address when you enter the mac address of the device.

If you simply plug the interface with a cable into your PC then you have tu run a dhcp service on your PC.
Yeah, thank you!
It works quite well with latency around 3ms and the old driver (2017). Great conversion, very clean mic pres. I'll add an Audient ASP800 as soon as possible, I'll let you know how it works!
I am running "MOTU AVB 1.3.4+558" for UltraLite AVB and Stage-B16.update" that a nice person gave me, that's a beta version and includes the touch console. It doesn't fix the modulo-8-jumping ofthe input channels when changing jackd's bufsize on the fly but it seems to be as stable as "MOTU AVB 1.3.2+520 for UltraLite AVB and Stage-B16.update".

If you want to try it drop me a note.
Oh yes! Thanks!!

baptiste
Established Member
Posts: 4
Joined: Sat Oct 06, 2018 7:18 am

Re: Ultralite AVB

Post by baptiste »

bluebell wrote: If you want to try it drop me a note.
I'd like to try it, please :)
(sorry, i'm not old enough here to be able to PM you... I just signed in for this topic)

baptiste
Established Member
Posts: 4
Joined: Sat Oct 06, 2018 7:18 am

Re: Ultralite AVB

Post by baptiste »

bluebell wrote: I am running "MOTU AVB 1.3.4+558" for UltraLite AVB and Stage-B16.update" that a nice person gave me, that's a beta version and includes the touch console. It doesn't fix the modulo-8-jumping ofthe input channels when changing jackd's bufsize on the fly but it seems to be as stable as "MOTU AVB 1.3.2+520 for UltraLite AVB and Stage-B16.update".

If you want to try it drop me a note.
Interestingly, my Ultralite AVB runs with this 1.3.4+558 since yesterday and i did not witness any channel hopping nor any progressive decimation. So far so good !

Post Reply