Headset Jack does not record

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

Post Reply
User avatar
flappix
Established Member
Posts: 33
Joined: Thu Jan 19, 2017 10:39 pm
Location: Germany

Headset Jack does not record

Post by flappix »

Hi,
on my laptop I have a combination audio jack with a headset symbol beside. So I guess it should be possible to record via this jack.
Audio output works well, but if I connect a mic or my guitar, I cannot record anything. I tried it with ardour and audacity, in alsa and and in jack mode.
I tried all possible input devices in qjackctl but only the build-in mic works.

Does anyone have a hit for me why it's not working?
The laptop is a Lenovo X1 Carbon 2014 and I'm using Archlinux on it.
Jack Winter
Established Member
Posts: 381
Joined: Sun May 28, 2017 3:52 pm

Re: Headset Jack does not record

Post by Jack Winter »

Does it work in pure ALSA?

It is quite normal to have some problems with onboard HDA soundcards, due to the following.

For Intel's HDA standard the BIOS is supposed to put configuration information in the ACPI tables, this is something that very often doesn't work as it should or at all. Therefor it's very normal on Linux that some things aren't connected properly. To get around this you have so called quirks that informs the driver of what functionality the sound card contains, and what is connected to what. If no quirks have been created for your soundcard, it's possible that some of it works, and other parts not. In this case my guess is that the driver isn't properly configured so JACK doesn't get the audio.

The way to fix this is kind of cumbersome and I am not sure how to help you the best way.

If you can go onto IRC on freenode at the #alsa channel, there is a user called debianuser who can probably help you, he is very good at helping with this specific problem!
Reaper/KDE/Archlinux. i7-2600k/16GB + i7-4700HQ/16GB, RME Multiface/Babyface, Behringer X32, WA273-EQ, 2 x WA-412, ADL-600, Tegeler TRC, etc 8) For REAPER on Linux information: https://wiki.cockos.com/wiki/index.php/REAPER_for_Linux
Post Reply