Page 1 of 1

Focusrite Scarlett 2i2 with jackd: Unknown driver "hw:USB"

Posted: Thu Sep 21, 2017 9:51 pm
by eetfuk1988
Hello everyone,

I was a happy user of the Focusrite Scarlett 2i2 until today. Suddenly jackd fails on startup with: Unknown driver "hw:USB". Any ideas? I tried blacklisting "snd_hda_intel", no effect. Interface works just fine with Win10.

I'm on Ubuntu 17.04. x64.

thanks in advance
alex

Re: Focusrite Scarlett 2i2 with jackd: Unknown driver "hw:USB"

Posted: Sun Sep 24, 2017 8:02 pm
by Baggypants
I've not got one but ir's been discussed here: viewtopic.php?f=18&t=17504&p=85028&hilit=Scarlett+2i2#p85028

Re: Focusrite Scarlett 2i2 with jackd: Unknown driver "hw:USB"

Posted: Thu Sep 28, 2017 10:31 am
by eetfuk1988
As I said, it worked perfectly fine with super low latencies and all of a sudden jackd won't start anymore. So I think it's not a problem with the interface itself but with the OS/jack configuration. An Observation: after I try to use it with Linux and then boot in Windows, Windows is also unable to connect to the device. Only when I unplug and then plug the interface back in it works again.

Re: Focusrite Scarlett 2i2 with jackd: Unknown driver "hw:USB"

Posted: Thu Sep 28, 2017 3:29 pm
by Musicmaker
I have this with the 18i20 Gen 1 sometimes , interface gone in Linux and Windows at boot (no lsusb). Power of, boot the OS, back again. works. \Weird. Sometimes Qjackctrl dus gives DBUS error. Reboot. ok. does not happens so often, once the 18i20 runs, it's solid as a rock.

Re: Focusrite Scarlett 2i2 with jackd: Unknown driver "hw:USB"

Posted: Wed Nov 29, 2017 9:48 pm
by eetfuk1988
Sry to dig out this old thread again, but the problem persists...

I was not able to resolve the problem on Ubuntu so I installed Debian 9 with rt kernel and for some time it work perfectly fine again until it didn't:

Code: Select all

/usr/bin/jackd -R -P80 -dalsa -dhw:USB -r96000 -p64 -n3
jackdmp 1.9.11
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2014 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
no message buffer overruns
JACK server starting in realtime mode with priority 80
self-connect-mode is "Don't restrict self connect requests"
audio_reservation_init
Acquire audio card Audio2
creating alsa driver ... hw:USB|hw:USB|64|3|96000|0|0|nomon|swmeter|-|32bit
configuring for 96000Hz, period = 64 frames (0.7 ms), buffer = 3 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 3 periods for playback
JackPosixProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Driver is not running
Cannot create new client
Unknown request 4294967295
CheckSize error size = 0 Size() = 12
CheckRead error


Again some observations:

- when I get the above output while running jack then no client (DAW) can connect to it. the power LED on the scarlett is on but the metering LED does NOT react to the audio input even though I know that it should at the given level
- if the scarlett is in that undefined behaviour state it won't run on windows either. only when I plug the Scarlett out and back in while Windows is running it starts to work again (metering LED, capture etc.). that works reliably.
- if it recovered from that undefined behaviour state I can often boot back into Linux and it will work for a while again until the circle starts from the beginning

I think a forced reinitialization would help, but how can I order the 2i2 to do so on linux?

Re: Focusrite Scarlett 2i2 with jackd: Unknown driver "hw:USB"

Posted: Sat Dec 02, 2017 1:58 am
by Brynildsen
Have you tried another cable and some og the other usb ports? - since it happens on both win/linux.. are there any usb power saving something enabled anywhere? Could also be a faulty device, try the Scarlett on another pc if you have a friend that has some music software already installed, so you just need to install a driver and plug it in.

Re: Focusrite Scarlett 2i2 with jackd: Unknown driver "hw:USB"

Posted: Thu Dec 07, 2017 11:13 am
by eetfuk1988
I tried different USB ports. I didn't try another cable but it's the one that came with the device. There is an energy save option I tried both on and off and of course it could be a faulty unit. But if I just use it with Windows or macOS it works perfectly fine. Linux somehow temporarily bricks it which can only be recovered if you reattach it while running Windows (didn't try that on macOS yet but I expect the same), so it must be something the class compliant driver or somebody else (pulsaudio maybe) is doing. It must be related to the boot (or shutdown) process, because if it works on Linux and I don't reboot it works forever and if it doesn't work it won't work from the beginning.

Re: Focusrite Scarlett 2i2 with jackd: Unknown driver "hw:USB"

Posted: Sun Dec 10, 2017 11:12 pm
by Brynildsen
Here are some other suggestions..

Can you see the device with lsusb when you have the problem?, if not can you then see it if you unplug the device wait a couple of seconds and plug it back in..? It is a VERY good sign if you/the system is seeing the device.

Do you have alsa-restore.service running and enabled? Check with systemctl --type=service |grep alsa, you might be able to do either a systemctl restart alsa-restore.service, (this depends on which distro you run. I'm on Arch) or by looking through the man page of alsactl. man alsactl look for some of the restore and force settings. You can start/stop/restart/enable/disable services/daemons yourself and it is faster than rebooting. I think there is an init option via alsactl.

Do you have any other devices that can transfer audio and is connected via usb? Some of the new monitors have build in usb hub and build in speakers and jackout for external speakers. Or maybe a keyboard that can pass through audio.. Something that could steal the USB device naming and confuse the system.

I always kill pulseaudio with pulseaudio -k right after I start jack. And then start it again with pulseaudio --start. At the moment my window manager automaticly respawns it because I have a script displaying volume on my statusbar. But it should stay killed until started again by user on normal setups. Browsers and other programs that use pulse sometimes starts it themself also.

I run the jack2-dbus with qjackctl and have very good experience with this one. Have you tried either jack2 or jack2-dbus instead of jack?

Sometimes qjackctl doesn't kill the jack server on exit.. You can do some tricks yourself with jack_control status in terminal. Check jack_control help for commands to start stop it. You could be in a situation where you think you have stopped jack because you have closed the qjackctl windows, but it is actually still running in the background and wont accept that you have unplugged and replugged your card and wont update the list because jack needs to be restarted first.

My card has the input channels in alsamixer muted about 50% of the times I boot, for some weird reason. Write alsamixer in terminal press F6 to see all soundcards, then F5 to see all channels. When the inputchannels are muted the card works fine but I have no input, and no working clipping LEDs on the input channels.

Hope some of this helps.

Re: Focusrite Scarlett 2i2 with jackd: Unknown driver "hw:USB"

Posted: Mon Dec 11, 2017 8:04 pm
by Brynildsen
I just bought one of these also today (needed and extra card for my laptop also), and it looks like there is no control options in alsamixer for this card. It is not a big deal since the alsamixer channels for setting the level are kind of messy anyway. On my other Presonus 22VSL I have a few controls in alsamixer, which I always just max out anyway and use a combo of the physical knobs on the card and level settings in my DAW instead.

I bought the Scarlett 2i2 2.generation it worked out of the box without reboot.

Out of curiosity I'd like to know if anyone else have any channels visible in alsamixer for the Scarlett 2i2 ..? It might be just on my system, dunno.