Boss Micro BR-80

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

singforme
Established Member
Posts: 127
Joined: Sat Dec 31, 2016 1:58 pm
Contact:

Re: Boss Micro BR-80

Post by singforme »

Thank you Drumfix!

neilnardlenoo
Established Member
Posts: 20
Joined: Mon Jul 10, 2017 7:31 pm

Re: Boss Micro BR-80

Post by neilnardlenoo »

Singforme.

For what it's worth I've started having a go at tweaking the kernel. I have the sources and have altered and applied drumfix's patch. Just got to try the compilation next.
From what I saw there are still quite a few Roland quirks so I guess some have been re-added/left in as not working with the generic one.
I'd agree the alsa devs are the way to go - get it done properly so we don't have to keep recompiling for every new kernel - but I'd like to know it works for next time someone decides to remove it!

Thanks again drumfix.

User avatar
Linuxmusician01
Established Member
Posts: 705
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Boss Micro BR-80

Post by Linuxmusician01 »

Wouldn't it be possible to only compile a (separate) kernel module?

singforme
Established Member
Posts: 127
Joined: Sat Dec 31, 2016 1:58 pm
Contact:

Re: Boss Micro BR-80

Post by singforme »

Thank you all!

Drumfix
Established Member
Posts: 258
Joined: Mon Jan 26, 2009 5:15 pm

Re: Boss Micro BR-80

Post by Drumfix »

The kernel module usually must match the version of the installed kernel.

There is one more thing. My JD-Xi is stalled, when it is connected by USB to the computer but no application is reading from its first USB Midi In port.
So if your device provides a USB midi in, make sure something is reading from it. E.g. this can be done using aseqdump or by using jack with the midi driver set to "seq".

singforme
Established Member
Posts: 127
Joined: Sat Dec 31, 2016 1:58 pm
Contact:

Re: Boss Micro BR-80

Post by singforme »

Hi, I tried to follow this guide,

http://org0ne.livejournal.com/29979.html

when I get to the following point I get an error:

Code: Select all

root@microlab:/home/benjamin# make O=../build oldconfig
make: *** Keine Regel, um „oldconfig“ zu erstellen.  Schluss.
"No Rule to create "oldconfig". End."

Does anyone know what to do here?

Drumfix
Established Member
Posts: 258
Joined: Mon Jan 26, 2009 5:15 pm

Re: Boss Micro BR-80

Post by Drumfix »

You are in your home directory. You must execute the make command in the directory of the kernel sources you want to compile.

neilnardlenoo
Established Member
Posts: 20
Joined: Mon Jul 10, 2017 7:31 pm

Re: Boss Micro BR-80

Post by neilnardlenoo »

singforme,

those "livejournal" instructions, I believe, create a new snd-usb-audio driver (actually quite a few other audio drivers too). I've had a go at that, too as it's quicker than compiling the whole kernel, but so far I've not managed to get the resulting driver to load - perhaps something I'm doing wrong with the kernel version I'm running vs. the source code I'm using as drumfix mentioned earlier.

Unfortunately, I've also had no luck with compiling a new kernel - or rather, the compiled kernels are fine, but none of the quirk changes I have tried so far have made any difference (or they've made things worse, with the BOSS no longer being recognised at all).

Also, for what it's worth, I booted back to my fedora 17 (kernel 3.9.10, I think (not sat at it now)) install and that still works straight away with aplay etc. and all the aplay -l, lsusb, cat /proc/asound/cards type commands show just the same details on either kernel. The only difference in the logs that I see when switching the thing on is the newer kernel produces
"kernel: usb 1-1.4: Unable to change format on ep #8e: already in use"
a lot after the main device registration etc., as I mentioned previously. This seems to be the 'key' to me.

Given that the BOSS looks to be fully recognised and the kernel is able to tell when it's busy (I tried aplay whilst it was still switching on and got a 'busy' message) and when you try to send the incorrect sample rate to it with aplay, etc. I'm inclined to try drumfix's other suggestion, next....
There is one more thing. My JD-Xi is stalled, when it is connected by USB to the computer but no application is reading from its first USB Midi In port. So if your device provides a USB midi in, make sure something is reading from it. E.g. this can be done using aseqdump or by using jack with the midi driver set to "seq".
Not sure how "stalled" manifests on the JD-Xi, but it seems feasible to think this might actually be what we're seeing.

singforme
Established Member
Posts: 127
Joined: Sat Dec 31, 2016 1:58 pm
Contact:

Re: Boss Micro BR-80

Post by singforme »

neilnardlenoo

that sounds interesting! Unfortunately it's not possible to have an ancient Kernel like 3.9 on a recent installation as a boot option. Maybe it's really the midi. I'm not sure how to make use of BR-80s MIDI though... Let me know when you've had success with this!

singforme
Established Member
Posts: 127
Joined: Sat Dec 31, 2016 1:58 pm
Contact:

Re: Boss Micro BR-80

Post by singforme »

Thank you Drumfix, that was helpful! *wink*

I'm stuck again though a bit further down the line:

Code: Select all

root@microlab:/home/benjamin/linux-4.11.6# make O=../build modules SUBDIRS=soundmake[1]: Verzeichnis „/home/benjamin/build“ wird betreten
arch/x86/Makefile:136: CONFIG_X86_X32 enabled but no binutils support
  CC [M]  sound/sound_core.o
/home/benjamin/linux-4.11.6/sound/sound_core.c:1:0: error: code model kernel does not support PIC mode
 /*
 
/home/benjamin/linux-4.11.6/scripts/Makefile.build:299: die Regel für Ziel „sound/sound_core.o“ scheiterte
make[2]: *** [sound/sound_core.o] Fehler 1
/home/benjamin/linux-4.11.6/Makefile:1509: die Regel für Ziel „_module_sound“ scheiterte
make[1]: *** [_module_sound] Fehler 2
make[1]: Verzeichnis „/home/benjamin/build“ wird verlassen
Makefile:152: die Regel für Ziel „sub-make“ scheiterte
make: *** [sub-make] Fehler 2
root@microlab:/home/benjamin/linux-4.11.6#
Any idea on this?
Drumfix wrote:You are in your home directory. You must execute the make command in the directory of the kernel sources you want to compile.

User avatar
Linuxmusician01
Established Member
Posts: 705
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Boss Micro BR-80

Post by Linuxmusician01 »

singforme wrote:Thank you Drumfix, that was helpful! *wink*

I'm stuck again though a bit further down the line:

Code: Select all

root@microlab:/home/benjamin/linux-4.11.6# make O=../build modules SUBDIRS=soundmake[1]: Verzeichnis „/home/benjamin/build“ wird betreten
arch/x86/Makefile:136: CONFIG_X86_X32 enabled but no binutils support
  CC [M]  sound/sound_core.o
/home/benjamin/linux-4.11.6/sound/sound_core.c:1:0: error: code model kernel does not support PIC mode
 /*
 
/home/benjamin/linux-4.11.6/scripts/Makefile.build:299: die Regel für Ziel „sound/sound_core.o“ scheiterte
make[2]: *** [sound/sound_core.o] Fehler 1
/home/benjamin/linux-4.11.6/Makefile:1509: die Regel für Ziel „_module_sound“ scheiterte
make[1]: *** [_module_sound] Fehler 2
make[1]: Verzeichnis „/home/benjamin/build“ wird verlassen
Makefile:152: die Regel für Ziel „sub-make“ scheiterte
make: *** [sub-make] Fehler 2
root@microlab:/home/benjamin/linux-4.11.6#
Any idea on this?
Drumfix wrote:You are in your home directory. You must execute the make command in the directory of the kernel sources you want to compile.
The error "code model kernel does not support PIC mode" appears to be a bug of gcc6+. See: https://askubuntu.com/questions/851433/ ... -compiling

Compiling stuff from source code is not for the faint of heart. It requires a lot of experience and patience. Another fact that doesn't help is that your error messages are in German instead of English, I'm sorry...

singforme
Established Member
Posts: 127
Joined: Sat Dec 31, 2016 1:58 pm
Contact:

Re: Boss Micro BR-80

Post by singforme »

Linuxmusician01 wrote:
Compiling stuff from source code is not for the faint of heart. It requires a lot of experience and patience. Another fact that doesn't help is that your error messages are in German instead of English, I'm sorry...
Thank you Linuxmusician01!

I just went on according to the description ignoring the errors and afterwards I was able to run jack with that device. Pretty exciting, no sound though. After a reboot everything was back to where I started, no way to get the thing going;)

neilnardlenoo
Established Member
Posts: 20
Joined: Mon Jul 10, 2017 7:31 pm

Re: Boss Micro BR-80

Post by neilnardlenoo »

singforme,

Interesting that jack ran - it hasn't for me. The lack of sound could be one of the jack settings? Or have to do with your jack routing to whatever application you're using to play the sound?

I never got those livejournal instructions to work for me but that quirks file, used in a full kernel compilation didn't make a difference (though, to be fair I haven't tried jack much - I've been using aplay as a test)

Just tried jack with midi=seq and no joy. Also now tried aseqdump (though I don't know if it was the right way to use it):

# aseqdump -l
Port Client name Port name
24:0 BR-80(AUDIO) BR-80(AUDIO) MIDI 1

# aseqdump --port=24:0
Waiting for data. Press Ctrl+C to end.
Source Event Ch Data

with no luck either - the aseqdump sits there waiting, so I assume that is working, but an aplay from a second terminal still fails.

User avatar
Linuxmusician01
Established Member
Posts: 705
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Boss Micro BR-80

Post by Linuxmusician01 »

singforme wrote:
Linuxmusician01 wrote: Compiling stuff from source code is not for the faint of heart. It requires a lot of experience and patience. Another fact that doesn't help is that your error messages are in German instead of English, I'm sorry...
Thank you Linuxmusician01!

I just went on according to the description ignoring the errors and afterwards I was able to run jack with that device. Pretty exciting, no sound though. After a reboot everything was back to where I started, no way to get the thing going;)
That it didn't work after a reboot is "not a bug but a feature". What you made is a kernel module (read: driver). You most probably need to insert said module in the kernel manually (after each reboot). One removes the "old" kernel module inserts an other one like so:

Code: Select all

sudo rmmod old_module
sudo insmod new_module
List modules in use:

Code: Select all

lsmod
I see that you used this How To to make and insert your kernel module. Then the kernel module you baked is probably located at: [subdir unknown to me!!]/linux-3.0.0/build/sound/usb/snd-usb-audio.ko.

Try to resolve the issue w/ the help from Neilnardlenoo above. You might need to fiddle w/ Jackaudio, on the other hand the module might load but not work at all.

Good luck!

neilnardlenoo
Established Member
Posts: 20
Joined: Mon Jul 10, 2017 7:31 pm

Re: Boss Micro BR-80

Post by neilnardlenoo »

The jack setup I always used to run was:

/usr/bin/jackd -dalsa -dhw:BR80AUDIO -r44100 -p1024 -n3 -D -Phw:2

which came from a combination of qjackctl fiddling and the man page and in the end was clearly quite basic - and probably had some mistakes and redundant options (and a probably needless mix of device name and device number) .... but as soon as it worked with my old kernel I stopped messing with it.

For reference, I've attached an lsusb -v, as well as the quirk-table I had a stab at creating by using that lsusb output and also the quirk-table from the source for the kernel I have that works and which is somewhat spectacularly generic looking!
You do not have the required permissions to view the files attached to this post.

Post Reply