Linux support Behringer UMC404HD?

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

Jack Winter
Established Member
Posts: 376
Joined: Sun May 28, 2017 3:52 pm

Re: Linux support Behringer UMC404HD?

Postby Jack Winter » Mon May 28, 2018 8:12 am

Note that all of this isn't terribly important for recording, it mostly becomes increasingly important as you lower buffers/periods, especially if you want to monitor tracks through your DAW. The lowlatency kernel gives the kernel the capability to preempt running threads to run your high priority audio threads. The realtime kernel takes that a step further and makes the kernel itself preemptable. YMMW depending on your usage, hardware, software installed, etc. Some of it is most likely not important at all (just legacy information), for instance it's highly unlikely that your system uses the RTC at all.
Reaper/KDE/Archlinux. i7-2600k/16GB + i7-4700HQ/16GB, RME Multiface/Babyface, Behringer X32, WA273-EQ, 2 x WA-412, ADL-600, Tegeler TRC, etc 8) For REAPER on Linux information: https://wiki.cockos.com/wiki/index.php/REAPER_for_Linux

basstrombone
Established Member
Posts: 31
Joined: Sun Mar 18, 2018 11:39 pm
Location: Paraíba, PB Brasil
Contact:

Re: Linux support Behringer UMC404HD?

Postby basstrombone » Thu May 31, 2018 7:50 pm

Jack Winter wrote:Note that all of this isn't terribly important for recording, it mostly becomes increasingly important as you lower buffers/periods, especially if you want to monitor tracks through your DAW. The lowlatency kernel gives the kernel the capability to preempt running threads to run your high priority audio threads. The realtime kernel takes that a step further and makes the kernel itself preemptable. YMMW depending on your usage, hardware, software installed, etc. Some of it is most likely not important at all (just legacy information), for instance it's highly unlikely that your system uses the RTC at all.



After making all adjustments suggested by quickscan, both systems (a very old mini pc and a 2011 Gateway NV75S) are running quite smoothly. Related to latency and buffer size, I understand that the limitations are tottally related to the both age and machine limitations. But to record live concerts both machines reacted great. Last week I've done live recordings using my UMC 404 @ 24 Bits and 96K, worked just fine.
Very happy. I'll study more tweaks to see if I can improve latency by buffer sizes to see if I can improve monitoring through both Ardour and MixBus

Thanks!

LinuxStudioAmateur
Posts: 1
Joined: Sun Feb 17, 2019 7:56 pm

Re: Linux support Behringer UMC404HD?

Postby LinuxStudioAmateur » Sun Feb 17, 2019 9:01 pm

Hi All. Been using Ubuntu for a couple years, but far from any kind of power user. I'm trying to set up a home studio to try my hand at voice acting. I picked up a UMC404HD to interface with my Lenovo ThinkCentre. Mainly as an audio interface, but also as a MIDI interface for my kids to screw around with my old Roland PC-200 keyboard and software synths/samplers. I'm having a pretty frustrating issue.

When plugging the UMC into the PC with the supplied USB cable, the audio in/out and MIDI-in works (can assign to instruments in LMMS). However, the PC is not receiving the maximum audio levels. The signal is being clipped at the interface or in the connection. For the below image, I've got the audio signal cranked way up to constant clipping indicators on the UMC, just to illustrate what the PC is receiving:
Image
That reading on the "input level" bar is as high as it will go. You can see on Audacity that the max signal is being clipped before it reaches the PC/Audacity.

When using the same connection, on the audio output panel, the interface shows up just as "Analog Output - UMC404HD 192k," with four channels of output, which seems fine, but this will come to relevance later:
Image

So in an attempt to get the full audio signal, I tried switching to an active USB cable. Using the active cable, the full audio signal is passed through. However, strangely enough, the UMC404HD now shows up as two separate input options: "Digital Input (S/PDIF) - UMC404HD 192k" and "Microphone - UMC404HD 192k." When using the active cable, the full audio signal makes it through to the PC/Audacity (levels from source are the same as the images above). Switching between these two input sources makes no difference in the input level reading or what is being picked up by Audacity:
Image

Image

Also, when viewing the audio output panel, the UMC now shows up as two separate options: "Digital Output (S/PDIF) - UMC404HD 192k" and "Analog Output - UMC404HD 192k," both of which are two-channel stereo only (note: no other options are available when selecting the "Profile" dropdown). Selecting either of these options passes the audio out to the monitors at the same levels, which are connected only to the first two playback outputs (I'm currently only using 2-channel stereo in and out on the UMC).
Image

Image

The UMC shows up the same in a lsusb scan whether it's through the active cable or not (the Amtel Corp line appears to be the active cable, showing as a 4-port hub even though it's just a single cable):
Image

Now, while I'm not happy about losing the 4-channel out while using the active cable, I could deal with it as I'm only using 2-channel stereo at the moment. However, the other issue with using the active cable is that when trying to link LMMS instruments to the MIDI, the setting won't "stick." The option to associate the instrument with the UMC MIDI channel shows up in LMMS, but if I select it, the UMC connection cycles off and on (it disappears and reappears in the input list of the audio settings panel), and the checkmark won't stick next to the UMC on the instrument in LMMS.

(just FYI, the PCM2902 that shows on the audio panel is an old UCA202 USB card that I used previously, and that behaves properly for input/output, but is lower bitrate and a bit noisy, which is why I upgraded)

Maybe this could be rectified by using JACK, but my cursory experience with JACK hasn't been successful, and it seems more complicated and requires more tweaking than needed for my basic needs; the default audio settings panel seems to suffice, but if I need to dig more into JACK to get it all to work, I guess I can try that. I'm also not sure how using JACK would change the signal level that's reaching the PC through the USB or the MIDI connection dropping.

Any help appreciated. Thought I'd post this first in this thread,and if there's not much response I'll try it as its own topic to maybe get more eyes on it.

User avatar
Linuxmusician01
Established Member
Posts: 594
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Linux support Behringer UMC404HD?

Postby Linuxmusician01 » Mon Feb 18, 2019 1:57 pm

@LinuxStudioAmateur: welcome to the forum! :)

What is an "active" USB cable? Can you post a photo, or an internet link where I can see it?

P.S. You can try to start Jack the easy way:

Code: Select all

jackd -d alsa --device hw:1

Determine if the Behringer 404HD is hw:0, hw:1 or hw:2 etc.:

Code: Select all

cat /proc/asound/cards


P.S.2 Some people say that you'd better not use a USB hub w/ the 404. Connect the 404 directly.

Hedon
Established Member
Posts: 13
Joined: Tue Nov 27, 2018 7:09 pm

Re: Linux support Behringer UMC404HD?

Postby Hedon » Thu Mar 21, 2019 1:42 pm

My computer is running Lubuntu 16.04 with KXStudio repos. I was using a Behringer UMC202HD to record in Ardour and was fantastically pleased with the device, its clarity, and latency. But I also thought it'd be nice to record 4 tracks simultaneously, rather than be limited to 2. I saw the "big brother" UMC404HD, realized it sounded like exactly what I'm looking for, and did a quick search to verify it was Linux friendly. Saw the reports on here "works out of the box" and pulled the trigger.

Swapped out the UMC202HD with the UMC404HD and tried 4-tracking, but experiencing issues. While I can "hear" all 4 inputs to the front panel of the 404HD, and Ardour "input selector" seems to recognize there are 4 channels of input, selecting inputs 3 or 4 does not provide a signal in the selected channel. Selecting inputs 1 or 2 works exactly as expected. It seems like the computer recognizes 4 inputs, but will only work with 2. Is it possible the 404HD has "tricked" my computer into thinking it's the 202HD? The device name is the same in Cadence for both cards, and the 404HD shows up in ALSA as device hw:3, same as the 202HD used to occupy.

I have disconnected and re-connected the 404HD. I have shut down the computer and re-booted. I have attempted to 'sudo apt upgrade', but no upgrades are available. Ardour simply doesn't provide an input/capture signal for inputs 3 or 4.

My cadence settings are nearly identical to the 202HD, but with 4 input/output, rather than 2:
https://imgur.com/C1xvDHv

Alsamixer capture settings look like this:
https://imgur.com/NWHJmJe

And reading from several other threads in other forums, the command "amixer" was suggested for configuration information. I dont understand that discussion, but the CLI output did reveal something interesting, IMO: (see below)
jim@Asus-TT:~$ amixer -c3 controls
numid=7,iface=MIXER,name='Mic Capture Switch'
numid=8,iface=MIXER,name='Mic Capture Switch',index=1
numid=9,iface=MIXER,name='Mic Capture Volume'
numid=10,iface=MIXER,name='Mic Capture Volume',index=1
numid=3,iface=MIXER,name='UMC404HD 192k Output Playback Switch'
numid=4,iface=MIXER,name='UMC404HD 192k Output Playback Switch',index=1
numid=5,iface=MIXER,name='UMC404HD 192k Output Playback Volume'
numid=6,iface=MIXER,name='UMC404HD 192k Output Playback Volume',index=1
numid=2,iface=PCM,name='Capture Channel Map'
numid=1,iface=PCM,name='Playback Channel Map'
jim@Asus-TT:~$ amixer -c3 contents
numid=7,iface=MIXER,name='Mic Capture Switch'
; type=BOOLEAN,access=rw------,values=4
: values=on,on,off,off
numid=8,iface=MIXER,name='Mic Capture Switch',index=1
; type=BOOLEAN,access=rw------,values=1
: values=on
numid=9,iface=MIXER,name='Mic Capture Volume'
; type=INTEGER,access=rw---R--,values=4,min=0,max=127,step=0
: values=127,127,127,127
| dBminmax-min=-127.00dB,max=0.00dB
numid=10,iface=MIXER,name='Mic Capture Volume',index=1
; type=INTEGER,access=rw---R--,values=1,min=0,max=127,step=0
: values=127
| dBminmax-min=-127.00dB,max=0.00dB
numid=3,iface=MIXER,name='UMC404HD 192k Output Playback Switch'
; type=BOOLEAN,access=rw------,values=4
: values=on,on,on,on
numid=4,iface=MIXER,name='UMC404HD 192k Output Playback Switch',index=1
; type=BOOLEAN,access=rw------,values=1
: values=on
numid=5,iface=MIXER,name='UMC404HD 192k Output Playback Volume'
; type=INTEGER,access=rw---R--,values=4,min=0,max=127,step=0
: values=127,127,127,127
| dBminmax-min=-127.00dB,max=0.00dB
numid=6,iface=MIXER,name='UMC404HD 192k Output Playback Volume',index=1
; type=INTEGER,access=rw---R--,values=1,min=0,max=127,step=0
: values=127
| dBminmax-min=-127.00dB,max=0.00dB
numid=2,iface=PCM,name='Capture Channel Map'
; type=INTEGER,access=r----R--,values=4,min=0,max=36,step=0
: values=3,4,7,8
| container
| chmap-fixed=FL,FR,FC,LFE

numid=1,iface=PCM,name='Playback Channel Map'
; type=INTEGER,access=r----R--,values=4,min=0,max=36,step=0
: values=3,4,7,8
| container
| chmap-fixed=FL,FR,FC,LFE



What caught my eye was the output of amixer -c3 contents, which showed:
numid=7,iface=MIXER,name='Mic Capture Switch'
; type=BOOLEAN,access=rw------,values=4
: values=on,on,off,off


This would appear that the 404HD only has 2 of the input channels switched on, correct, even though all 4 output channels are working properly. Is this diagnosis correct? And if so, how do I turn them "on"?

Considering all the folks who state their 404HD worked "out of the box", just plug'n'play, do I have a faulty unit needing to be returned and exchanged? Or is this likely some kind of residual effect from my previously working 202HD; and since they seem to have the same deviceID and hw:3 location, something is now corrupted and confusing ALSA?

Is anyone able to help me resolve this issue? I've effectively replicated the functionality of my 202HD, but at 2x the price! Please advise, and thank you in advance for any assistance provided!

User avatar
Linuxmusician01
Established Member
Posts: 594
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Linux support Behringer UMC404HD?

Postby Linuxmusician01 » Thu Mar 21, 2019 7:41 pm

@Hedon: I think that you're not using Jack as a layer on ALSA. On my Linux PC the 404 doesn't work w/ only Alsa either... (only just found out). The 4 in/4 out only works w/ Jack. You can start Jack w/ the following command (if the 404 is audio device number 3, like in your post above):

Code: Select all

jackd -d alsa --device hw:3

Then configure your DAW of choice to use Jack (which sounds easier than it is).

Good luck. :)

Hedon
Established Member
Posts: 13
Joined: Tue Nov 27, 2018 7:09 pm

Re: Linux support Behringer UMC404HD?

Postby Hedon » Thu Mar 21, 2019 11:09 pm

Linuxmusician01 wrote:@Hedon: I think that you're not using Jack as a layer on ALSA. On my Linux PC the 404 doesn't work w/ only Alsa either... (only just found out). The 4 in/4 out only works w/ Jack. You can start Jack w/ the following command (if the 404 is audio device number 3, like in your post above):

Code: Select all

jackd -d alsa --device hw:3

Then configure your DAW of choice to use Jack (which sounds easier than it is).

Good luck. :)


Linuxmusician01,

Thanks for responding so quickly! I believe jack is started with Cadence, when I switch from my onboard soundcard to the USB Behringer 404HD. Typeing the suggested command in terminal yielded this:

jim@Asus-TT:~$ jackd -d alsa --device hw:3
jackdmp 1.9.12
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2018 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
no message buffer overruns
`default' server already active
Failed to open server
jim@Asus-TT:~$


It seems to me that Jack IS running, but for some reason 2 input channels are "off". I believe this is a hardware issue, or a hardware configuration issue. But this stuff is slightly above my head, so I'll defer to whomever can decipher this mess. Thanks!

User avatar
Linuxmusician01
Established Member
Posts: 594
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Linux support Behringer UMC404HD?

Postby Linuxmusician01 » Fri Mar 22, 2019 10:56 am

Hedon wrote:Linuxmusician01,

Thanks for responding so quickly! I believe jack is started with Cadence, when I switch from my onboard soundcard to the USB Behringer 404HD. Typeing the suggested command in terminal yielded this:

jim@Asus-TT:~$ jackd -d alsa --device hw:3
jackdmp 1.9.12
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2018 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
no message buffer overruns
`default' server already active
Failed to open server
jim@Asus-TT:~$

It seems to me that Jack IS running, but for some reason 2 input channels are "off". I believe this is a hardware issue, or a hardware configuration issue. But this stuff is slightly above my head, so I'll defer to whomever can decipher this mess. Thanks!

Indeed, Jack is running. When I start QJackctl then I can see 4 input and 4 output ports (see picture below). How is that on your side?

Image

P.S. It could also be that Jack is started for the wrong audio device (i.e. the default 0 instead of 3). To test this kill Jack first and then start it manually like so:

Code: Select all

pkill -9 jackdbus
killall jackd
jackd -d alsa --device hw:3

Hedon
Established Member
Posts: 13
Joined: Tue Nov 27, 2018 7:09 pm

Re: Linux support Behringer UMC404HD?

Postby Hedon » Fri Mar 22, 2019 11:49 am

Not sure how to embed screenshot like you did, so here's link to screenshot. Qjackctl looks like this:

https://imgur.com/ttnzIu4

Image

I'm seeing the four (4) inputs AND outputs. I strongly suspect there's a config file somewhere that Jack is using from my previous UMC-202HD device. They have the same identifier in Cadence (U192k) and occupy the same hardware slot (device #3). Of course I could be wrong, but that's my suspicion. See previous post regarding amixer command, showing 2 inputs working and 2 inputs "off".

User avatar
Linuxmusician01
Established Member
Posts: 594
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Linux support Behringer UMC404HD?

Postby Linuxmusician01 » Fri Mar 22, 2019 12:13 pm

Hedon wrote:Not sure how to embed screenshot like you did, so here's link to screenshot. Qjackctl looks like this:

https://imgur.com/ttnzIu4

Image

I'm seeing the four (4) inputs AND outputs. I strongly suspect there's a config file somewhere that Jack is using from my previous UMC-202HD device. They have the same identifier in Cadence (U192k) and occupy the same hardware slot (device #3). Of course I could be wrong, but that's my suspicion. See previous post regarding amixer command, showing 2 inputs working and 2 inputs "off".

I agree on the config. That's why I never use qjackctl or other software to start Jack. Because that's like a box of chocolates: you never know what you're gonna get. However, I disagree on alsamixer: on my system alsamixer also shows only two channels (maybe 2 stereo chanels; stereo is 2 channels adding up to 4?).

Good luck w/ Jack and the 404. :)

Hedon
Established Member
Posts: 13
Joined: Tue Nov 27, 2018 7:09 pm

Re: Linux support Behringer UMC404HD?

Postby Hedon » Fri Mar 22, 2019 2:34 pm

For instance, my 404HD device is #3 in Alsa settings. amixer -c3 indicates 4 input channels are available (as expected), but 2 (identified as rear left and rear right, respectively) are turned "off".

Code: Select all

jim@Asus-TT:~$ amixer -c3
Simple mixer control 'Mic',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right - Rear Left - Rear Right
  Limits: Capture 0 - 127
  Front Left: Capture 127 [100%] [0.00dB] [on]
  Front Right: Capture 127 [100%] [0.00dB] [on]
  Rear Left: Capture 127 [100%] [0.00dB] [off]
  Rear Right: Capture 127 [100%] [0.00dB] [off]
Simple mixer control 'Mic',1
  Capabilities: cvolume cvolume-joined cswitch cswitch-joined
  Capture channels: Mono
  Limits: Capture 0 - 127
  Mono: Capture 127 [100%] [0.00dB] [on]
Simple mixer control 'UMC404HD 192k Output',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right - Rear Left - Rear Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 127 [100%] [0.00dB] [on]
  Front Right: Playback 127 [100%] [0.00dB] [on]
  Rear Left: Playback 127 [100%] [0.00dB] [on]
  Rear Right: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'UMC404HD 192k Output',1
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 127
  Mono: Playback 127 [100%] [0.00dB] [on]
jim@Asus-TT:~$


how do I turn those channels "on" in a permanent fashion for the 404HD device?

Hedon
Established Member
Posts: 13
Joined: Tue Nov 27, 2018 7:09 pm

Re: Linux support Behringer UMC404HD?

Postby Hedon » Fri Mar 22, 2019 3:18 pm

GOT IT!

Stumbled onto this article:
https://www.maketecheasier.com/alsa-utilities-manage-linux-audio-command-line/

Screenshot of alsamixer "help" shows that spacebar will "toggle capture". Sure enough, looking at the capture channels of my card indicated a middle channel (labeled "mic rear") was NOT captured. hit the space bar and...BOOM...channel was enabled.

restarted Jack for good measure, opened Ardour, connected to input channels 3 and 4, and there's my input signal! I'm no engineer, so maybe I'm wrong, but I'm convinced this issue was the result of upgrading from the UMC202HD to the UMC404HD. When I attached the 404HD, the card has the same identifier name in Cadence (jack frontend), referred to as "U192k", and occupied the same hardware slot H:3 as the 202HD. While the additional captures were being recognized, they weren't "activated" for some reason. Someone smarter than me will have to explain how, but that's my theory. If I had hooked up the 40HD first, I'm sure all would have went fine. If I had then "downgraded" to the 202HD, I'll bet the same thing would've happened in reverse, behind the scenes, but went undetected because the 2 input channels of the 202HD would've never interfered with the 2 "unused" capture settings remaining from the 404HD configuration. Also not sure if this is a Behringer issue, or an Alsa issue, or something else, but it's fixed easily enough, now that the troubleshooting is done.

Maybe I'm just the 1st guy on the planet to upgrade a UMC202HD to a UMC404HD on a linux system, using jack/also and Ardour. But the trail has been blazed for the 2nd guy, if there is one! Enjoy!

P.S. To those who are looking for soundcard recommendations for use in audio recording on linux systems, I highly recommend both the Behringer cards UMC202HD (2 input/2 output) and the UMC404HD (4 input/4 output). Don't let my unique situation fool you. Both cards worked fantastically with no configuration by me (just plug'n'play), other than my unique situation, which is now solved for the next guy, if there ever is one. I'm no audio expert, just a music lover with limited computer skills who wants to "get up and running" with minimal setup and maintenance. I have used Lexicon Omega and Focusrite Scarlett 6i6, as well as Behringer UMC202HD and UMC404HD. The Focusrite and Behringer have better sound quality (presumably due to Midas preamps), although in fairness to Lexicon are also much newer tech. the Focusrite is obviously a higher quality build, but a much higher price tag, for no discernible difference in sound quality. However, the Behringers were the easiest setups I've ever done...literally just plugged them in, waited for system to recognize and configure, fired up Cadence, switched to USB card, fired up Ardour, selected track inputs (channel 1,2,3 or 4), armed track, and started recording. Very simple and sound great.

User avatar
Linuxmusician01
Established Member
Posts: 594
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Linux support Behringer UMC404HD?

Postby Linuxmusician01 » Fri Mar 22, 2019 4:08 pm

@Hedon: thanks for the tip on activating everything in alsamixer for capturing! Glad you've got it working.

P.S. Doesn't the 404 hiss/make noise? When I use it as an analogue mixer I cant' seem to get the volume of my synth high enough to get over the noise without overdriving/clipping the 404.

Hedon
Established Member
Posts: 13
Joined: Tue Nov 27, 2018 7:09 pm

Re: Linux support Behringer UMC404HD?

Postby Hedon » Fri Mar 22, 2019 4:43 pm

Linuxmusician01 wrote:@Hedon: thanks for the tip on activating everything in alsamixer for capturing! Glad you've got it working.

P.S. Doesn't the 404 hiss/make noise? When I use it as an analogue mixer I cant' seem to get the volume of my synth high enough to get over the noise without overdriving/clipping the 404.


I do not have those issues @LM. Have you tinkered with the Line/Instrument and/or Pad buttons? Varying between line/instrument really has an effect on my input signals, effectively boosting "trim" like on older manual/analog mixers. And "pad" seems to provide a "minimum signal level". Personally, I prefer to send the hottest signal possible, and pull down the sliders to an acceptable level to prevent clipping.

Not sure it applies in the digital world, but old habits die hard and I was always told "it's better to attenuate a hot signal than it is to boost a weak one". I would start by making sure Alsa input/capture channels are maxxed. Then, if you haven't already, try switching those 404HD line/instr and pad buttons on/off to find a level that works for you.

User avatar
Linuxmusician01
Established Member
Posts: 594
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Linux support Behringer UMC404HD?

Postby Linuxmusician01 » Fri Mar 22, 2019 4:49 pm

Hedon wrote:
Linuxmusician01 wrote:@Hedon: thanks for the tip on activating everything in alsamixer for capturing! Glad you've got it working.

P.S. Doesn't the 404 hiss/make noise? When I use it as an analogue mixer I cant' seem to get the volume of my synth high enough to get over the noise without overdriving/clipping the 404.


I do not have those issues @LM. Have you tinkered with the Line/Instrument and/or Pad buttons? Varying between line/instrument really has an effect on my input signals, effectively boosting "trim" like on older manual/analog mixers. And "pad" seems to provide a "minimum signal level". Personally, I prefer to send the hottest signal possible, and pull down the sliders to an acceptable level to prevent clipping.

Not sure it applies in the digital world, but old habits die hard and I was always told "it's better to attenuate a hot signal than it is to boost a weak one". I would start by making sure Alsa input/capture channels are maxxed. Then, if you haven't already, try switching those 404HD line/instr and pad buttons on/off to find a level that works for you.

Thank you for the tip "it's better to attenuate a hot signal than it is to boost a weak one". Sounds very sensible. :)


Return to “Computer Related Hardware”

Who is online

Users browsing this forum: No registered users and 1 guest