Problem with my Fast Track Ultra USB card

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

Post Reply
mfares07
Posts: 2
Joined: Sun Feb 26, 2017 11:03 pm

Problem with my Fast Track Ultra USB card

Post by mfares07 »

Hi everybody, i has taken few weeks trying solve this problem with my card sound. It is a Fast Track Ultra. The sound is not as when i used Windows but i want use Linux! I can only select 7.1 profiles from my sound panel (icon on right below) The stereo profile does not appear and the card sound shows itself as: "M-Audio RunTime DFU". So i think, my sound card is not working 100% or isn't recoznized fully.

I read many forums about this problem but i can't figure out yet. I saw about a patch for 2 files: usbaudio.c and usbquirks.h (both i have them in: /usr/src/Alsa Drivers/alsa-driver-1.0.9/sound/usb) . This is the patch:

Code: Select all

The MIDI interface is class compliant, and this is what's shown by Jack.
The audio interfaces are marked as vendor specific, so the driver needs
to be changed to support them.

Please try recompiling your kernel with the patch below.

Some M-Audio devices use big-endian samples, so beware of speaker-
killing noise.

It's possible that playback synchronization doesn't work completely.

Please check what happens when you try to play and record with different
sample rates.


HTH
Clemens

--- linux/sound/usb/usbaudio.c
+++ linux/sound/usb/usbaudio.c
@@ -2235,6 +2235,10 @@ static void init_substream(struct snd_us
                case USB_ID(0x041e, 0x3f0a): /* E-Mu Tracker Pre */
                        subs->ops.retire_sync = retire_playback_sync_urb_hs_emu;
                        break;
+               case USB_ID(0x0763, 0x2080): /* M-Audio Fast Track Ultra */
+                       subs->ops.prepare_sync = prepare_playback_sync_urb;
+                       subs->ops.retire_sync = retire_playback_sync_urb;
+                       break;
                }
        }
        snd_pcm_set_ops(as->pcm, stream,
@@ -2786,6 +2790,7 @@ static int parse_audio_endpoints(struct 
                        break;
                case USB_ID(0x041e, 0x3020): /* Creative SB Audigy 2 NX */
                case USB_ID(0x0763, 0x2003): /* M-Audio Audiophile USB */
+               case USB_ID(0x0763, 0x2080): /* M-Audio Fast Track Ultra */
                        /* doesn't set the sample rate attribute, but supports it */
                        fp->attributes |= EP_CS_ATTR_SAMPLE_RATE;
                        break;
--- linux/sound/usb/usbquirks.h
+++ linux/sound/usb/usbquirks.h
@@ -1864,6 +1864,33 @@
                }
        }
 },
+{
+       USB_DEVICE_VENDOR_SPEC(0x0763, 0x2080),
+       .driver_info = (unsigned long) & (const struct snd_usb_audio_quirk) {
+               /* .vendor_name = "M-Audio", */
+               /* .product_name = "Fast Track Ultra", */
+               .ifnum = QUIRK_ANY_INTERFACE,
+               .type = QUIRK_COMPOSITE,
+               .data = & (const struct snd_usb_audio_quirk[]) {
+                       {
+                               .ifnum = 0,
+                               .type = QUIRK_IGNORE_INTERFACE
+                       },
+                       {
+                               .ifnum = 1,
+                               .type = QUIRK_AUDIO_STANDARD_INTERFACE
+                       },
+                       {
+                               .ifnum = 2,
+                               .type = QUIRK_AUDIO_STANDARD_INTERFACE
+                       },
+                       /* interface 3 (MIDI) is standard compliant */
+                       {
+                               .ifnum = -1
+                       }
+               }
+       }
+},
 
 /* Casio devices */
 {
 
i run that patch (creating a file fastrack.patch and type in the terminal: patch < fastrack.patch ) but i got this errors:

Code: Select all

patching file usbaudio.c
Hunk #1 FAILED at 2235.
Hunk #2 FAILED at 2786.
2 out of 2 hunks FAILED -- saving rejects to file usbaudio.c.rej
patching file usbquirks.h
Hunk #1 succeeded at 1899 with fuzz 2 (offset 35 lines).
I don't know what should i so, i saw a few people has downloaded kernel and compile it, but doesn't explain step to step. So i don't know how to do it.
For example i tried this : viewtopic.php?f=6&t=1581&start=15#p9895 but i got errors too about kernel headers (that i think)

If anyone might help me would be great, i would like to see my Fast Track Ultra working in my Linux Mint.
Thank you so much !
AyeLinux
Established Member
Posts: 13
Joined: Fri Jul 31, 2015 8:27 pm
Location: California, US

Re: Problem with my Fast Track Ultra USB card

Post by AyeLinux »

It sounds like your FTU is working fine, but PulseAudio is making the assumption that 8 channels must be a 7.1 surround system. I haven't had to deal with this myself, because I don't use multichannel interfaces with Pulse (just JACK).

I remember a discussion about this somewhere, but I have no idea if it was this site, or another.
All in favor of Linux, say 'aye.'
mclstr
Established Member
Posts: 48
Joined: Sat Jul 23, 2016 4:10 pm
Contact:

Re: Problem with my Fast Track Ultra USB card

Post by mclstr »

Sorry I missed this post.

I overcame almost all of my my audio problems by configuring my audio to only use Jack. I leave Jack running all the time.
That way I don't have to keep changing my sound configuration and lets face it Jack is superior to the others.

There are many ways of dealing with audio under Linux and my method is just one.

I really don't remember all the details, I just did a pretty thorough google search and ignored most articles unless they were relatively current. Lots of changes have been made to how most distributions and kernels deal with audio. Older methods may not work.

I just wish I documented the process:-(

I have the FastTrack Ultra 8r and can easily patch it in Bitwig, Qtractor, Renoise, Ardour, ...

I have been very happy with it so far.
Post Reply