Page 1 of 1

Audio playback speed is wrong

Posted: Fri May 23, 2014 11:26 am
by steevc
Hi, I've not been visiting here lately due to being busy, but I've just built a new PC and have a strange problem.

I went for an AMD A8 6500 CPU on a Gigabyte GA-F2A88X-D3H motherboard with 8GB RAM. I transferred my old M-Audio Delta 66 from the old PC. I'm using the on-board graphics as I don't need anything fancy. I don't generally play games. I installed Kubuntu 14.04 and added the Kxstudio repos.

I think it was mostly okay to start with, but one day I noticed that the sound in a Youtube video was out of tune with my guitar, i.e. playing too slow. This seemed to affect both Flash and html5 in Firefox and Chrome. I think it is also affecting purely audio playback in other apps.

I wonder if this could be 44100/48000 sample rate issue. I have the audio card master clock set to 44100 in Envy24. Where else should I be looking?

I did a quick bit of recording recently in Ardour and it was okay then, but I was having an issue with the recorded sound being distorted. Levels looked okay. I had all this working on the old PC, but I've probably forgotten to set something up.

Cheers

Re: Audio playback speed is wrong

Posted: Fri May 23, 2014 11:39 am
by lazyklimm
do you use jackd?

Re: Audio playback speed is wrong

Posted: Fri May 23, 2014 11:44 am
by steevc
lazyklimm wrote:do you use jackd?


Not running Jack for general audio. I only start it when I need it.

I think this proves the Delta is running at 48000, but I think I need it at 44100

Code: Select all

steve@slarti:~$ cat /proc/asound/card2/pcm0p/sub0/hw_params
access: MMAP_INTERLEAVED
format: S32_LE
subformat: STD
channels: 10
rate: 48000 (48000/1)
period_size: 441
buffer_size: 3528


Shouldn't the default be 44100? How should I set it?

Re: Audio playback speed is wrong

Posted: Fri May 23, 2014 7:11 pm
by lazyklimm
never tried 44.1, but 48/96khz works well for me (I use 1010LT)

Re: Audio playback speed is wrong

Posted: Fri May 23, 2014 8:24 pm
by steevc
This is weird. I just changed the sample rate in Envy24 to 48000 and back to 44100 and it seems to have sorted itself out, for now at least. I thought I tried that yesterday.

Ah well, I've learnt a bit about this stuff whilst investigating.

I tend to used 44.1 as most audio media is in that rate and it avoids extra processing. When recording I'm not sure I'd gain much from higher rates for what I do.

I'll see if it's still okay next time I start the PC.

Re: Audio playback speed is wrong

Posted: Sun May 25, 2014 3:51 pm
by steevc
The problem was still there the next day and I've not managed to change it as I did yesterday.

Re: Audio playback speed is wrong

Posted: Wed Jun 04, 2014 3:23 pm
by steevc
I've found I can generally get the hardware sample rate to change is I disable/enable the Delta in Envy24. I assume this resets something. Even with this the sound is still distorted as if something is over-driven. I'll double check the levels, but it looked okay.

Somewhere in this process I lost the setting for the master volume control that let me control it via the speaker app or the buttons on my keyboard.

Is it just that something changed recently in the M-Audio drivers and has messed me up? I would have expected this to be pretty stable by now as it's old hardware.

Just thinking I could try with a live boot to see how it sounds then. Will try that later.

Update: I see there is on-going work on the driver. Maybe I should report a bug. I'm never sure where to report it if I don't know the cause

https://git.kernel.org/cgit/linux/kerne ... ci/ice1712

Re: Audio playback speed is wrong

Posted: Thu Jun 05, 2014 9:39 am
by steevc
Booted up the PC with a Mint USB drive. That defaulted to 44100 and sounded fine. Cool that they have things like Pulseaudio volume there by default. Makes life simple.

If I wanted to report this as a bug, where should I do it? I don't know what 'level' of the system could be at fault.