M-Audio Fast Track Pro

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: MattKingUSA, khz

Established Member
Posts: 29
Joined: Fri Dec 13, 2013 12:17 am

Re: M-Audio Fast Track Pro

Post by chalee »

Fuck Hell! so now is working!??? I just had choosen in Cadence/Jack the #1-Input to capture (which is normally the digital input/output)
and now its working in Ardour!!! Of course the Output#1-one is Output 3+4!

So i tried one whole night with the wrong input?!??? :P
sometimes its so heavy easy! And crazy! 8)

But maybe this mistake helps somebody reading this with the same Problem!

Actual this works!!!:
M-Audio Fast Track Pro

The M-Audio Fast Track Pro is an USB 4x4 audio interface, working at 24bit/96kHz. Due to limitation of USB 1, this device requires additional setup to get access to all its features. Device works in one of two configuration:
Configuration 1, or "Class compliant mode" - with reduced functionality, only 16bit, 48kHz, analogue input (2 channels) and digital/analogue output (4 channels).
Configuration 2 - with access to all features of interface.
Currently with stock kernel it runs in configuration 2, but if you want to make sure in what mode you are, you can check kernel log for entries:
usb-audio: Fast Track Pro switching to config #2
usb-audio: Fast Track Pro config OK

here is the solution to get it fully working (tested under Linux Mint 13 with Mate and KXStudio):


Code: Select all

arecord -l && aplay -l
in Terminal and you see the priority of all soundcards and their I/Os


Code: Select all


Code: Select all

cat /proc/asound/modules

Code: Select all

cat /proc/asound/cards
if you want to know more about your soundconfiguration!

since Kernel 3.x No patch of Kernel needed (tested with LowLatency Kernel of KXStudio)- the Kernel has the patch inside and is switching automatical to config2 (you can check in the kernel-log) which makes the 24bit/48hz-Resolution and many others options of the M-Audio Fast Track Pro possible.

You have to make a „fast-track-pro.conf“-file with just one entry in /etc/modprobe.d/fast-track-pro.conf :

Code: Select all

options snd-usb-audio vid=0x763 pid=0x2012 device_setup=0x9 index=0 enable=1

The index=x-option sets the priority of different soundcards you use.

→ For example: i choose „0“ if i want the FTP as the default sounddevice in Linux and „1“ to use it behind the onboard sound!

The enable=x-option activates this configuration (0=off)

in /etc/modprobe.d/alsa-base.conf:
it should show a bunch of lines with index values for snd-usb-audio that we have to deactivate with commenting. There’s one (for e.g.) we have to look for:

options snd-usb-audio index=-2

change it (comment it out) as:

#options snd-usb-audio index=-2

Save it, and close it

Now reboot……

This settings from above will put the FastTrack Pro at device number 0 with 24bit mode, max. 48kHz sampling mode, 2 inputs and 4 outputs. According to the patch, the possible values for the device_setup parameter are the sum of the following numbers:

0x01 : use the device_setup parameter, always needed
0x02 : enable digital output (channels 3,4)
0x04 : use 48kHz-96kHz sampling rate, 8-48 kHz if not used
0x08 : 24bit sampling rate
0x10 : enable digital input (channels 3,4)

where vid and pid are vendor and product id for M-Audio Fast Track Pro, index is desired device number and device_setup is desired device setup. Possible values for device_setup are:
The 24 bit/96kHz mode is special: it provides all input/output, but you can open only one of 4 interfaces at a time. If you for example open output interface and then try to open second output or input interface, you will see error in kernel log:
cannot submit datapipe for urb 0, error -28: not enough bandwidth
which is perfectly normal, because this is USB 1 device and cannot provide enough bandwidth to support more than single (2 channel) destination/source of that quality at a time.

You can modify the I/O-Configuration of your FTP with the following lines in fast-track-pro.conf:

#24bit/48hz Analog I/O, Digital Out:
options snd-usb-audio vid=0x763 pid=0x2012 device_setup=0x9 index=5 enable=1

#24bit/96hz All In OR Out:
options snd-usb-audio vid=0x763 pid=0x2012 device_setup=0x5 index=5 enable=1

#24bit/48hz Analog Out, Digital I/O
options snd_usb-audio vid=0x763 pid=0x2012 device_setup=0x13 index=5 enable=1

#(experimental, not recommend!!) merge 2 Interfaces into one!
options snd-usb-audio index=2,3 vid=0x46d,0x763 pid=0x81d,0x2012 device_setup=0x00,0x9 enable=1,1

At last
you have to switch the usb-sound permantly to the default card (0)


sudo bash
echo options snd_usb_audio index=0 >> /etc/modprobe.d/sound-cards-order
echo options snd_hda_intel index=1 >> /etc/modprobe.d/sound-cards-order
sudo reboot

→ use the name of your recognized cards above!

Now your M-Audio Fast Track Pro should work fine with 24bit, Jack, Ardour and others. :D

[Edit:] At this time the 24bit-Modus with the Fast Track Pro is just possible with Jack in MIXXX 1.11! For using Monitor-Outputs (3+4) of the FTP you have to use ALSA-drivers in 16bit-Modus:
>>>>>>>>>>>>>>To use the 16bit-class-compilant-modus, deactivate the fast-track-pro.conf with # before the lines or delete it ! ------------------------------------------------------------------------------------------------------------------------------------------------------------------

Everything a little tricky- but if you know what to do the Fast Track pro is a really good soundinterface with less latency and good sound! ;)

And don't forget: to choose the ANALOG-INPUTS take

Code: Select all

hw:Pro,1 [USB Audio]
and not the (digital)

Code: Select all

 hw:Pro,0 [USB Audio]
8) :wink: :mrgreen: :) :o :D
Established Member
Posts: 6
Joined: Tue Feb 23, 2016 5:04 am

Re: M-Audio Fast Track Pro

Post by maxime.levesque »

There seems to be an error in this line :

Code: Select all

options snd-usb-audio vid=0x763 pid=0x2012 device_setup=0x9 index=0 enable=1

I could not get the FTP working with these settings, I then changed it to :

Code: Select all

options snd-usb-audio vid=0x763 pid=0x2012 device_setup=0x09 index=0 enable=1
and it started to work, notice the device_setup code : 0x9, vs 0x09 ... !!!
User avatar
Established Member
Posts: 11
Joined: Sat Jul 25, 2015 12:26 pm

Re: M-Audio Fast Track Pro

Post by CeeJayTheFirst »

Not really contributing to the thread but has anyone tried reamping with this device?
If not I'll just leave this subtle request since I don't own one (there is a possibility to get this one new on a local store, for a decent price)
glowrak guy
Established Member
Posts: 1989
Joined: Sat Jun 21, 2014 8:37 pm
Been thanked: 136 times

Re: M-Audio Fast Track Pro

Post by glowrak guy »

reamping has a lot of misconceptions about it's definitions and uses.
What is the exact use you have in mind?
User avatar
Established Member
Posts: 11
Joined: Sat Jul 25, 2015 12:26 pm

Re: M-Audio Fast Track Pro

Post by CeeJayTheFirst »

1: record a dry track.
2: send it through one of the balanced outs through the (guitar) preamp and recording the "coloured" track.
2.5: at the same time sending the track that's being recorded to the monitors.
A reamping box would be employed of course.

My question was only if the fast track could cope with this.
Established Member
Posts: 42
Joined: Fri Nov 04, 2016 10:18 pm

Re: M-Audio Fast Track Pro

Post by Telover »

Hi all. I'm new to home recording (on computer) and not too expert on Linux, so a half disaster.
I'm writing because I have a problem connecting the Fast Track Pro to Ardour. In other words, I cannot get any sound out of it.
I have a drum track in Ardour I've imported from H2 and that's ok, it works.
I've made an audio track to record the bass but even though I've tried all possible setups, I cannot get a single sound coming from the Fast Track.
I've also posted in Ardour site, but since it seems there are other people here using my setup or almost, maybe somebody faced the same issue and solved it. Or anyways can help me solve it.
I'm on Linux 12.04 and Ardour 5.1.0.
Here are some printscreens I took of the set up in QJackCtl and Ardour:

As you can see, the Fast Track only appears in the ALSA window so I have no chance to connect it to any track in Ardour (the bass track I've created it's the first on top in the Audio window), while Ardour appears both in Audio and MIDI windows.
With this configuration I can hear the drum track I've imported in Ardour through the headphones connected on the Fast Track.
I've tried to change config in Ardour and I've chosen JACK Audio System, ALSA Driver and Fast Track Device, in this way I had all those option in MIDI System, while in the earlier Ardour setup (ALSA Audio System in the image above), I only had ALSA raw devices and ALSA sequencer.
Here's the printscreen:

Before to do all this, I've changed the audio setup on my computer, chosing Fast Track as OUT and IN instead the speakers and internal audio.

As I wrote, I have no clue what might be the problem. So any hints would be more than highly appreciated.
Post Reply