USB 3 problems - Linux Mint....

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

Post Reply
User avatar
Chipfryer
Established Member
Posts: 362
Joined: Tue Nov 24, 2009 12:43 pm

USB 3 problems - Linux Mint....

Post by Chipfryer »

Also posted about this on their site. I have an ASUS x54C, and I'm having nothing but connection problems via USB to a Fast Track External Sound card.
Sometimes it's there, sometimes it isn't, sometimes it just decides not to be there when recording, after a loud pop sound.
I have an Omega 4 point powered usb Hub.
Mouse problems, stalling, freezing and so on. This happened more recently, but the symptom does not appear on the Windows partition sadly. I might have thought Bios had a part to play had this been the case.

Has anyone come across such issues before, and how did you solve them please?
Thank you.
Chippy

Pablo
Established Member
Posts: 1271
Joined: Thu Apr 17, 2008 9:57 pm

Re: USB 3 problems - Linux Mint....

Post by Pablo »

What linux mint version and what kernel does it use?

You can learn it via these commands:

cat /etc/lsb-release
uname -a

User avatar
Chipfryer
Established Member
Posts: 362
Joined: Tue Nov 24, 2009 12:43 pm

Re: USB 3 problems - Linux Mint....

Post by Chipfryer »

Hi Pablo, thank you very much.

DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=12
DISTRIB_CODENAME=lisa
DISTRIB_DESCRIPTION="Linux Mint 12 Lisa"

Kernal is:
3.2.0-23-realtime

on an Asus x54C with USB 3.0 ports.
Omega powered USB hub 4 prong (No serial number).

Odd thing has started happening. Mouse freezes, M-Audio sound card drops out and vanishes even at the slightest touch on the USB port.

***** This morning I found Pulse Audio was installed. I removed that and things are slightly better, although the mouse still hangs from time to time.
I have so many ideas now, this is a killer, and I want Linux to be part of it.
Thanks again Pablo,

Chippy

Pablo wrote:What linux mint version and what kernel does it use?

You can learn it via these commands:

cat /etc/lsb-release
uname -a

Pablo
Established Member
Posts: 1271
Joined: Thu Apr 17, 2008 9:57 pm

Re: USB 3 problems - Linux Mint....

Post by Pablo »

Hi Chippy!
Odd thing has started happening. Mouse freezes, M-Audio sound card drops out and vanishes even at the slightest touch on the USB port
Could it be a loose connection somewhere in the USB hub? Have you tried connecting the m-audio directly to the computer? Or another external hub?

If the problem is in the software side, I can't help much but upgrading the kernel might help. For this, upgrading the whole distro via system update manager would be the easiest, I think.

User avatar
Chipfryer
Established Member
Posts: 362
Joined: Tue Nov 24, 2009 12:43 pm

Re: USB 3 problems - Linux Mint....

Post by Chipfryer »

Hi Pablo!
Thank you, yes. I think you are right about this. A very bad USB setup on this Laptop. Breath on it, and the card dies. :roll:
I do have better news this morning however. I recorded my very first Linux guide vocal this morning. Needless to say, I am extatic about it too.
A few pops and crinkles in the fabric, and getting to know the plugins will take some time yet. However I'm pretty pleased :D
I posted about such on Linux Mint Forums without reply, I know. Everyone is busy
So thank you very much for taking the time.
Cheers to you, have a great weekend.
Chippy

===

Pablo wrote: Could it be a loose connection somewhere in the USB hub? Have you tried connecting the m-audio directly to the computer? Or another external hub?

If the problem is in the software side, I can't help much but upgrading the kernel might help. For this, upgrading the whole distro via system update manager would be the easiest, I think.

Pablo
Established Member
Posts: 1271
Joined: Thu Apr 17, 2008 9:57 pm

Re: USB 3 problems - Linux Mint....

Post by Pablo »

You're welcome!

Post Reply