Tascam US-122L and Ubuntu

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

Post Reply
studio32
Established Member
Posts: 2415
Joined: Mon Apr 07, 2008 5:09 pm

Tascam US-122L and Ubuntu

Post by studio32 »

Anyone who succeeded using US-122L on Ubuntu?

User avatar
simta
Established Member
Posts: 81
Joined: Mon Jan 12, 2009 3:35 am
Contact:

Re: Tascam US-122L and Ubuntu

Post by simta »

i've got my us-428 working, but quite restricted only 1/2 channels working and lose all the other functionality the desk offers.

i used a combination of advice from different places. i think i just googled the model with linux/ubuntu and went through them all. i'm sorry i can't give you the exact way i did it as my machine is down at the moment so can't really get stuff from there.
HP laptop 1.6GHz dual core 2gig ram
Ubuntu 8.10 + Fedora 10
Tascam US-428

turion
Posts: 1
Joined: Fri Feb 18, 2011 5:36 pm

Re: Tascam US-122L and Ubuntu

Post by turion »

After installation of the US122L you might want to try:

aplay -MDusb_stream:1 -fS24_3LE -r44100 -c2 -twav --period-size=640 ~/test.wav

and

jackd -RP50 -dalsa -dusb_stream:1 -r44100 -p64 -n2
(now try to playback from some JACK-aware software)

Those two worked for me even though aplay -l does not list my US122L.

User avatar
eikakot
Established Member
Posts: 93
Joined: Fri Jan 29, 2010 2:24 pm
Location: Vilnius, Lithuania
Contact:

Re: Tascam US-122L and Ubuntu

Post by eikakot »

I'm using us-122l and it works great! Make sure you have .asoundrc file modified like this:
# The usb_stream plugin configuration

pcm.!usb_stream {
@args [ CARD ]
@args.CARD {
type string
default "1"
}

type usb_stream

card $CARD
}

ctl.!usb_stream {
@args [ CARD ]
@args.CARD {
type string
default "1"
}

type hw

card $CARD
}

So now interface is usb_stream:1
You can start jack from terminal like this jackd -dalsa -dusb_stream:1 -r44100 -p128 -n2
Or if you are using Qjackctl, just write the name of the interface manualy, because it is not listed automatically:
You do not have the required permissions to view the files attached to this post.

mikeh789
Established Member
Posts: 5
Joined: Sun Jul 19, 2009 3:22 pm

Re: Tascam US-122L and Ubuntu

Post by mikeh789 »

what kernel are you running? im in lucid and maverick with various -generic -lowlatency and -realtime kernels getting errors...

User avatar
eikakot
Established Member
Posts: 93
Joined: Fri Jan 29, 2010 2:24 pm
Location: Vilnius, Lithuania
Contact:

Re: Tascam US-122L and Ubuntu

Post by eikakot »

I'm using 2.6.37.3 kernel from archlinux, but I've been using tascam us-122l for a long time now with different kernels and distros. lucid worked for me too if I remember it right

tokenringman42
Posts: 1
Joined: Wed Mar 23, 2011 4:22 pm

Re: Tascam US-122L and Ubuntu

Post by tokenringman42 »

Been at getting this thing to load since the device was new and am frustrated. I now realize that the US-122 and US-122L are two totally different devices entirely (contrary to several forums elsewhere, not to mention the idiot salesperson who sold the thing to me).

I finally found this forum and this one here http://wiki.briata.org/doku.php who suggests to do this:
STEP 3 - Set ALSA

Plug in the US-122L.

My onboard sound card is recognized as 1st card (card-0), so the US-122L will be the 2nd (card-1).
If you reboot with the card plugged in it can happen that the US-122L will recognized as card-0 (now this should be fixed,is it not?) To force the order try by doing:

sudo rmmod snd_usb_us122
sudo modprobe snd_usb_us122l enable=1 index=1 id=1

To see your order do:

$ cat /proc/asound/modules
0 snd_hda_intel ## my real card is
1 snd_usb_us122l

PCM access needs an ~/.asoundrc in your home directory

$ wget -c http://pub.briata.org/us-122l/.asoundrc ~/.asoundrc

Code: Select all

cat /proc/asound/cards 
0 [Live ]: EMU10K1 - SB Live! Value [CT4780]
SB Live! Value [CT4780] (rev.10, serial:0x80221102) at 0xdf80, irq 17
1 [US122L ]: USB US-122L - TASCAM US-122L
TASCAM US-122L (644:800e if 0 at 006/007)

Code: Select all

paul@cool-studio $ aplay -MDusb_stream:1 -fS24_3LE -r44100 -c2 -twav --period-size=640 ~/test.wav
ALSA lib pcm.c:2208:(snd_pcm_open_noupdate) Unknown PCM usb_stream:1
aplay: main:654: audio open error: No such file or directory

What am I missing or what else is needed from me to help you to help me?

Thanks in advance

Paul

==== edit ====

Code: Select all

$ aplay -l && lsusb
**** List of PLAYBACK Hardware Devices ****
card 0: Live [SB Live! Value [CT4780]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
Subdevices: 30/32
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
Subdevice #8: subdevice #8
Subdevice #9: subdevice #9
Subdevice #10: subdevice #10
Subdevice #11: subdevice #11
Subdevice #12: subdevice #12
Subdevice #13: subdevice #13
Subdevice #14: subdevice #14
Subdevice #15: subdevice #15
Subdevice #16: subdevice #16
Subdevice #17: subdevice #17
Subdevice #18: subdevice #18
Subdevice #19: subdevice #19
Subdevice #20: subdevice #20
Subdevice #21: subdevice #21
Subdevice #22: subdevice #22
Subdevice #23: subdevice #23
Subdevice #24: subdevice #24
Subdevice #25: subdevice #25
Subdevice #26: subdevice #26
Subdevice #27: subdevice #27
Subdevice #28: subdevice #28
Subdevice #29: subdevice #29
Subdevice #30: subdevice #30
Subdevice #31: subdevice #31
card 0: Live [SB Live! Value [CT4780]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: Live [SB Live! Value [CT4780]], device 3: emu10k1 [Multichannel Playback]
Subdevices: 1/1
Subdevice #0: subdevice #0
Bus 006 Device 007: ID 0644:800e TEAC Corp. TASCAM US-122L
Bus 006 Device 002: ID 8086:1120 Intel Corp.
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 03f0:1d04 Hewlett-Packard
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Astur
Posts: 2
Joined: Thu Aug 18, 2011 8:05 pm

Re: Tascam US-122L and Ubuntu

Post by Astur »

Hi!

This is the way I make it work in AV Linux 5.0:

1.- Put the asoundrc file in your home directory from Briata's page:

$ wget -c http://pub.briata.org/us-122l/.asoundrc ~/.asoundrc

2.- Install alsa-tools, alsa-firmware-loaders and libasound2-plugins from Sypnaptic Package Manager

3.- Plug in US122L and check if it has been detected

$ cat /proc/asound/modules

0 snd_hda_intel
1 snd_hda_intel
2 snd_usb_us122l

Sometimes it is necessary to plug in several times the US122L in order to get it detected by the system. I don't know the reason.


4.- Open QjackCtl. Configure setup like this:

Real Time: Checked
Frecuency: 48000Hz
Interface: usb_stream:2 -Write this manually because it is not listed-

If in your system the snd_usb_us122l has another number just replace the '2' with it.

5.- Start JACK

6.- Start ARDOUR, arm an audio track and just record!


Note:

I have tested this in Ubuntu 11.04 and it also works but you have to disable the Real Time in the setup of QjackCtl.

millerthegorilla
Established Member
Posts: 72
Joined: Wed Oct 26, 2011 11:22 am

Re: Tascam US-122L and Ubuntu

Post by millerthegorilla »

Re: Tascam US-122L and Ubuntu

Post by Astur on Thu Aug 18, 2011 8:11 pm
Hi!

This is the way I make it work in AV Linux 5.0:

1.- Put the asoundrc file in your home directory from Briata's page:

$ wget -c http://pub.briata.org/us-122l/.asoundrc ~/.asoundrc

2.- Install alsa-tools, alsa-firmware-loaders and libasound2-plugins from Sypnaptic Package Manager

3.- Plug in US122L and check if it has been detected

$ cat /proc/asound/modules

0 snd_hda_intel
1 snd_hda_intel
2 snd_usb_us122l

Sometimes it is necessary to plug in several times the US122L in order to get it detected by the system. I don't know the reason.


4.- Open QjackCtl. Configure setup like this:

Real Time: Checked
Frecuency: 48000Hz
Interface: usb_stream:2 -Write this manually because it is not listed-

If in your system the snd_usb_us122l has another number just replace the '2' with it.

5.- Start JACK

6.- Start ARDOUR, arm an audio track and just record!


Note:

I have tested this in Ubuntu 11.04 and it also works but you have to disable the Real Time in the setup of QjackCtl.
I just got the us122l working on ubuntu studio 11.04 following the above advice, although I had to remember in qJackCtl to set the input and output sources before it would work.

Cheers

Pablo
Established Member
Posts: 1270
Joined: Thu Apr 17, 2008 9:57 pm

Re: Tascam US-122L and Ubuntu

Post by Pablo »

I have tested this in Ubuntu 11.04 and it also works but you have to disable the Real Time in the setup of QjackCtl.
Really? Afaik, realtime mode is kind of a must for a usable jackd. The problem might have to do with your user not having rtprio (and memlock) privileges. Not with the card itself.

So, check in a terminal with:

ulimit -r -l

rtprio should be ninety-something and memlock unlimited (or a fair amount of memory, in kB).

If not so, add your user to the audio group (in a terminal "sudo adduser your_username audio", or, via menu in System->"users and groups"), reboot the computer, check again and try jack again in realtime mode.


Cheers! Pablo

Astur
Posts: 2
Joined: Thu Aug 18, 2011 8:05 pm

Re: Tascam US-122L and Ubuntu

Post by Astur »

Hi!

You are right!

I added my user to the audio group and modified the limits.conf file in etc/security/ adding this lines:

@audio - rtprio 99
@audio - memlock unlimited
@audio - nice -10

Now, I can check the Real Time box and there is no warning from Ardour about the menlock. Thanks!

I also updated the US122L firmware to version 1.12 from http://tascam.com/product/us-122l/downloads/ and now the us122l is recognized at first try.

benjod
Posts: 1
Joined: Wed Mar 21, 2012 7:31 am

Re: Tascam US-122L and Ubuntu

Post by benjod »

Hi Guys and Gals,

I'm sorry if I'm posting this on the wrong thread, but I've scoured the net and I can't seem to find a solution to my noob problem :? : How do I configure my sound settings that the audio output is to the USB device and not the onboard soundcard? I think it must be something simple that I don't know about.

I'm using Xubuntu 11.10 64bit, and I'm trying to configure the audio output to my external USB sound card (Tascam US-122L). I think I've managed to install the firmware so that Xubuntu recognises the device. I followed the steps listed above with some success, but now I'm stuck.

I'm getting:

cat /proc/asound/cards
0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfe024000 irq 22
1 [US122L ]: USB US-122L - TASCAM US-122L
TASCAM US-122L (644:800e if 0 at 001/003)

cat /proc/asound/modules ~/.asoundrc
0 snd_hda_intel
1 snd_usb_us122l
# got from http://www.nabble.com/tascam-us122l-...d24036395.html
# thanks to Karsten

# The usb_stream plugin configuration

pcm.!usb_stream {
@args [ CARD ]
@args.CARD {
type string
default "1"
}

type usb_stream

card $CARD
}

ctl.!usb_stream {
@args [ CARD ]
@args.CARD {
type string
default "1"
}

type hw

card $CARD
}


So, should be working right? Just need to somehow select to use it?

Many thanks,

Ben

slowpick
Established Member
Posts: 457
Joined: Mon Apr 25, 2011 10:09 am

Re: Tascam US-122L and Ubuntu

Post by slowpick »

look in qjackctl setup page, on the right side
Input Device >
Output Device >

click the >
to open a dropdown menu, the tascam should be there when recognized.
Use a Periods/Buffer setting of 3.

Plug it in after power on, look at output from

lsusb
cat /proc/asound/cards
aplay -l
arecord -l
aconnect -i
aconnect -o
a tascam name in found in brackets, can be used in the qjackctl dropdown.

That Tascam device also can fry, when changing phantom power,
or inserting mics, when the power is on, so be careful.

urlwolf
Established Member
Posts: 37
Joined: Wed Mar 06, 2013 11:57 pm

Re: Tascam US-122L and Ubuntu

Post by urlwolf »

Following the instructions, this is what I get when starting jack:

Code: Select all

Sat Mar 16 15:51:25 2013: Starting jack server...
Sat Mar 16 15:51:25 2013: JACK server starting in realtime mode with priority 10
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
(qjackctl.real:25048): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion `GTK_IS_WIDGET (widget)' failed
(qjackctl.real:25048): Gtk-CRITICAL **: IA__gtk_widget_get_direction: assertion `GTK_IS_WIDGET (widget)' failed
Sat Mar 16 15:51:25 2013: [1m[31mERROR: cannot register object path "/org/freedesktop/ReserveDevice1/Audio3": A handler is already registered for /org/freedesktop/ReserveDevice1/Audio3[0m
Sat Mar 16 15:51:25 2013: [1m[31mERROR: Failed to acquire device name : Audio3 error : A handler is already registered for /org/freedesktop/ReserveDevice1/Audio3[0m
Sat Mar 16 15:51:25 2013: [1m[31mERROR: Audio device hw:3 cannot be acquired...[0m
Sat Mar 16 15:51:25 2013: [1m[31mERROR: Cannot initialize driver[0m
Sat Mar 16 15:51:25 2013: [1m[31mERROR: JackServer::Open failed with -1[0m
Sat Mar 16 15:51:25 2013: [1m[31mERROR: Failed to open server[0m
Sat Mar 16 15:51:26 2013: Saving settings to "/home/jack/.config/jack/conf.xml" ...
15:51:27.728 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
X Error: XI_BadClass (invalid Class parameter) 133
  Extension:    131 (XInputExtension)
  Minor opcode: 6 (X_SelectExtensionEvent)
  Resource id:  0x46000f9
X Error: XI_BadClass (invalid Class parameter) 133
  Extension:    131 (XInputExtension)
  Minor opcode: 6 (X_SelectExtensionEvent)
  Resource id:  0x46000f9
X Error: XI_BadClass (invalid Class parameter) 133
  Extension:    131 (XInputExtension)
  Minor opcode: 6 (X_SelectExtensionEvent)
  Resource id:  0x4600104
X Error: XI_BadClass (invalid Class parameter) 133
  Extension:    131 (XInputExtension)
  Minor opcode: 6 (X_SelectExtensionEvent)
  Resource id:  0x4600104

jamsterthecool
Established Member
Posts: 24
Joined: Sun Mar 17, 2013 11:34 am

Re: Tascam US-122L and Ubuntu

Post by jamsterthecool »

Hi all ,

EDIT: This issues has also been reported here https://bugs.archlinux.org/task/33499

I recently installed linux mint . If I can just get my US-122L card working then I'll have a fully functional system :D .

I've made sure that my system is setup as the advice on this thread . In Qjackctl in/output device I selected the pre-listed hw:1 TASCAM us-122l .

But when I try to start Jack I get ;

Code: Select all

Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
12:11:41.707 ALSA connection graph change.
Sun Mar 17 12:11:41 2013: Starting jack server...
Sun Mar 17 12:11:41 2013: JACK server starting in non-realtime mode
Sun Mar 17 12:11:41 2013: [1m[31mERROR: Failed to acquire device name : Audio1 error : Cannot allocate memory[0m
Sun Mar 17 12:11:41 2013: [1m[31mERROR: Audio device usb_stream:1 cannot be acquired...[0m
Sun Mar 17 12:11:41 2013: [1m[31mERROR: Cannot initialize driver[0m
Sun Mar 17 12:11:41 2013: [1m[31mERROR: JackServer::Open failed with -1[0m
Sun Mar 17 12:11:41 2013: [1m[31mERROR: Failed to open server[0m
Sun Mar 17 12:11:43 2013: Saving settings to "/home/gary/.config/jack/conf.xml" ...
12:11:43.913 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
I get the below message from system log when I plug in the Tascam USB .

Code: Select all

sb 2-2: new high-speed USB device number 5 using ehci_hcd
Musb 2-2: config 1 interface 1 altsetting 1 bulk endpoint 0x83 has invalid maxpacket 9
 usb 2-2: New USB device found, idVendor=0644, idProduct=800e
 [ 1180.341391] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-2: Product: US-122L
usb 2-2: Manufacturer: TASCAM
 usb 2-2: SerialNumber: no serial number
 mtp-probe: checking bus 2, device 5: "/sys/devices/pci0000:00/0000:00:04.0/0000:01:0a.2/usb2/2-2"
mtp-probe: bus: 2, device: 5 was not an MTP device
pulseaudio[2101]: [pulseaudio] module-alsa-card.c: Failed to find a working profile.
pulseaudio[2101]: [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="1" name="usb-TASCAM_US-122L_no_serial_number-01-US122L" card_name="alsa_card.usb-TASCAM_US-122L_no_serial_number-01-US122L" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes card_properties="module-udev-detect.discovered=1""): initialization failed.
[UFW BLOCK] IN=eth0 OUT= MAC=01:00:5e:00:00:01:58:98:35:06:c2:db:08:00 SRC=192.168.1.254 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=60089 DF PROTO=2 
Help appreciated !

linux mint cinnamon 64bit
JACK Audio Connection Kit - Qt GUI Interface

Post Reply