Presonus Studio1810c no sound

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: khz, MattKingUSA

User avatar
Linuxmusician01
Established Member
Posts: 705
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Presonus Studio1810c no sound

Post by Linuxmusician01 »

vladanl wrote:
Linuxmusician01 wrote:Another tip. My 4 IN and 4 OUT usb audio device (Behringer 404HD) won't work properly in Alsa/PulseAudio. Will only work good w/ Jack.
Just to repeat, that means a device can work properly in Jack even if it doesn't in Alsa / PulseAudio. This is an important info for me, thanks.

Also, thanks for another info, if I don't manage to solve this problem, Behringer 404HD might be a good alternative.
Linuxmusician01 wrote: So you might have luck w/ Jack. Start Jack for audio device number 2 like so:

Code: Select all

jackd -d alsa --device hw:2
Then start QJackctl and look for IN and OUT-puts of your card.
I tried the command you specified and variations: 2,0, S1810c, S1810c,0, -P instead of --device, specified the number of out channels with -o, in all these cases jack fails. For example:

Code: Select all

jackd -d alsa --device hw:2 
jackdmp 1.9.12
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2017 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
no message buffer overruns
JACK server starting in realtime mode with priority 10
self-connect-mode is "Don't restrict self connect requests"
audio_reservation_init
Acquire audio card Audio2
creating alsa driver ... hw:2|hw:2|1024|2|48000|0|0|nomon|swmeter|-|32bit
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
ALSA: cannot set hardware parameters for playback
ALSA: cannot configure playback channel
Released audio card Audio2
audio_reservation_finish
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server
Increasing verbocity didn't provide more info, ALSA lines were the same.
That Jack does not want to start w/ this device is worrisome. :?:

From some other command line output that you posted it seemed to me that the (standard?) USB audio device driver from Alsa was loaded. It almost looks like the Presonos Studio 1810 is not supported by this driver. Almost every cheap USB sound "stick" up to my Behringer 404HD works with the driver called snd_usb_audio.

Check if the kernel module (read: driver) named snd_usb_audio is loaded:

Code: Select all

$ lsmod | grep usb

snd_usb_audio         155107  0 
snd_usbmidi_lib        29282  1 snd_usb_audio
usb_storage            62209  0 
usblp                  22891  0 
snd_hwdep              13602  3 snd_usb_audio,snd_hda_codec,snd_opl3_lib
snd_pcm               102099  7 snd_usb_audio,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_cmipci
snd_rawmidi            30731  3 snd_usbmidi_lib,snd_mpu401_uart,snd_seq_midi
snd                    69416  32 snd_hda_codec_realtek,snd_hrtimer,snd_usb_audio,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_mpu401_uart,snd_seq_device,snd_seq_dummy,snd_cmipci,snd_seq_midi_emul,snd_opl3_lib,snd_seq_midi
usbhid                 52659  0 
hid                   106148  2 hid_generic,usbhid

Wat seems very strange to me is that they say that the device works in MacOS because it's class compliant. The Presonus Studio1810c looks like a very nice audio card to me. Pity that it doesn't seem to work in Linux. I couldn't find anything on the internet about this device and Linux, other than that Linuxers ask for a port to Linux of Presonos' software. Is it a very new device?

If it is really class compliant then the developers at Alsa might pick up on it and find a way to support it. The tip you got from somebody to contact ALsa might be your best option at the moment...

vladanl
Established Member
Posts: 12
Joined: Mon Jun 10, 2019 8:13 pm

Re: Presonus Studio1810c no sound

Post by vladanl »

Linuxmusician01 wrote: Check if the kernel module (read: driver) named snd_usb_audio is loaded:
Both snd_usb_audio and snd_usbmidi_lib modules are loaded upon connecting S1810c. I can check module parameters in /sys/module/ ..., I also changed index parameter by editing /etc/modprobe.d/alsa-base.conf and it worked as expected.
Linuxmusician01 wrote: Wat seems very strange to me is that they say that the device works in MacOS because it's class compliant.
I just checked it on a Mac. Disconnected network to make sure nothing is downloaded and connected the device, for the first time on this computer. The device showed up in System preferences but I couldn't use it from there because it said "The selected device has no input / output controls", probably to be expected. Opened (pre-installed) Audacity, both play and record worked immediately. That's even without the software that Presonus recommends (was not installed). So it looks like it is class compliant.
Linuxmusician01 wrote: If it is really class compliant then the developers at Alsa might pick up on it and find a way to support it. The tip you got from somebody to contact ALsa might be your best option at the moment...
Thanks for the tip, I agree, hopefully I have enough info by now to convince ALSA devs to look at this

vladanl
Established Member
Posts: 12
Joined: Mon Jun 10, 2019 8:13 pm

Re: Presonus Studio1810c no sound

Post by vladanl »

For people who might be interested in Presonus 1810c, there is a patch now, thanks to Nick Kossifidis and Takashi Iwai (alsa-devs). It's disappointing that Presonus people didn't supply the info needed to develop the patch, it seems it would've been very easy for them.

I used the patch to recompile usb_snd_audio for kernel 5.3.0. The only thing I had to do in addition to the standard procedure for building a kernel module was to merge few lines that were added to mixer.h after 5.3.0. I didn't check midi, otherwise works perfectly.

atsintli
Posts: 1
Joined: Wed Oct 07, 2020 6:58 pm

Re: Presonus Studio1810c no sound

Post by atsintli »

Hi vladanl. I have the same problem, just bought this Presonus card but can't make it works. I've tried to compile and install different kernerls all the past week and today installed the 5.8.14, but neither JACK or ALSA can properly enable the interface. I also tried on Ubuntu Studio but it didn't work for me either. I wonder if you can share with us what exactly did you do to make it work. I'm running Linux Mint 19.3 with Kernel 5.8.14.

Jack return this message when i attempt to start the card:

Code: Select all

14:17:23.979 D-BUS: JACK server could not be started. Sorry
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Wed Oct  7 14:17:23 2020: Starting jack server...
Wed Oct  7 14:17:23 2020: JACK server starting in realtime mode with priority 10
Wed Oct  7 14:17:23 2020: self-connect-mode is "Don't restrict self connect requests"
Wed Oct  7 14:17:23 2020: ERROR: Cannot lock down 82280346 byte memory area (Cannot allocate memory)
Wed Oct  7 14:17:23 2020: Acquired audio card Audio1
Wed Oct  7 14:17:23 2020: creating alsa driver ... hw:S1810|hw:S1810|512|2|48000|0|0|nomon|swmeter|-|32bit
Wed Oct  7 14:17:23 2020: configuring for 48000Hz, period = 512 frames (10.7 ms), buffer = 2 periods
Wed Oct  7 14:17:23 2020: ALSA: final selected sample format for capture: 32bit integer little-endian
Wed Oct  7 14:17:23 2020: ALSA: use 2 periods for capture
Wed Oct  7 14:17:23 2020: ALSA: final selected sample format for playback: 32bit integer little-endian
Wed Oct  7 14:17:23 2020: ALSA: use 2 periods for playback
Wed Oct  7 14:17:23 2020: ERROR: ALSA: cannot set hardware parameters for playback
Wed Oct  7 14:17:23 2020: ERROR: ALSA: cannot configure playback channel
Wed Oct  7 14:17:23 2020: Released audio card Audio1
Wed Oct  7 14:17:23 2020: ERROR: Cannot initialize driver
Wed Oct  7 14:17:23 2020: ERROR: JackServer::Open failed with -1
Wed Oct  7 14:17:23 2020: ERROR: Failed to open server
Wed Oct  7 14:17:24 2020: Saving settings to "/home/atsintli/.config/jack/conf.xml" ...
14:17:28.698 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Cheers

uns4ph3
Established Member
Posts: 41
Joined: Mon Apr 27, 2020 12:53 am

Re: Presonus Studio1810c no sound

Post by uns4ph3 »

There are drivers for this class in devices in the 5.7 kernel

vladanl
Established Member
Posts: 12
Joined: Mon Jun 10, 2019 8:13 pm

Re: Presonus Studio1810c no sound

Post by vladanl »

atsintli wrote:
Wed Oct 07, 2020 7:30 pm
Hi vladanl. I have the same problem, just bought this Presonus card but can't make it works. I've tried to compile and install different kernerls all the past week and today installed the 5.8.14, but neither JACK or ALSA can properly enable the interface. I also tried on Ubuntu Studio but it didn't work for me either. I wonder if you can share with us what exactly did you do to make it work. I'm running Linux Mint 19.3 with Kernel 5.8.14.
In short, I added the new code relevant for 1810c and recompiled the kernel. But, as uns4ph3 said, your kernel should already contain these changes. Before I send you detailed instructions, could you check first whether your kernel source contains sound/usb/mixer_s1810c.* files please. If it does, that would mean that you have everything already.

All 1810c changes are listed at
https://git.kernel.org/pub/scm/linux/ke ... 9c83317f54

vladanl
Established Member
Posts: 12
Joined: Mon Jun 10, 2019 8:13 pm

Re: Presonus Studio1810c no sound

Post by vladanl »

Just as an info for people that might be interested.

I upgraded to Ubuntu Studio 2020.10 and the device was not recognized by Jack anymore. This was surprising because 2020.10 comes with kernel 5.8. As mentioned before, the new drivers for this device were added in kernel 5.7 and I had them working fine by patching 5.3.

About a week ago an Ubuntu Studio 2020.10 update came and now the device works again. This upgrade contains Ubuntu 5.8.0-28-lowlatency kernel, but I'm not sure what exactly was the problem.

Post Reply