No MIDI_IN for Linux from ROLAND FANTOM X - Help!

Talk about your MIDI interfaces, microphones, keyboards...

Moderators: MattKingUSA, khz

Post Reply
Stamper
Established Member
Posts: 5
Joined: Mon Jun 29, 2020 10:57 am

No MIDI_IN for Linux from ROLAND FANTOM X - Help!

Post by Stamper »

I am trying to make the switch from Windows to Linux Mint 20. But I cannot get MIDI_IN to work for my Roland FANTOM X8.

My PC is currently dual boot between Win10 and Linux Mint 20, and everything works fine on Win10, but on Linux Mint 20, whilst USB Storage works fine and the FANTOM can receive MIDI, I cannot send MIDI from the FANTOM to the PC.

Not sure if this is a USB v1.10 issue (it should work), or something else, but if anyone has a working FANTOM X on Linux, please reach out.

Thanks

Stamper
Established Member
Posts: 5
Joined: Mon Jun 29, 2020 10:57 am

Re: No MIDI_IN for Linux from ROLAND FANTOM X - Help!

Post by Stamper »

Some extra info:

I also have a Roland GAIA SH-01 which works fine. I tried cross connecting the MIDI ins and outs between the SH-01 and the FANTOM X8 in 'qjackctl' connections, and the connection from the FANTOM shows 'red'.

Image

So, ALSA knows something is wrong with the FANTOM. Is there a log file, or config file I can check??

j_e_f_f_g
Established Member
Posts: 1063
Joined: Fri Aug 10, 2012 10:48 pm

Re: No MIDI_IN for Linux from ROLAND FANTOM X - Help!

Post by j_e_f_f_g »

Roland devices often have two USB modes. One is the USBMIDI standard. The other mode is a proprietary "enhanced" mode that supports extra features (ie more than 16 MIDI channels). There is a "USB mode" setting you can change (usually in the "System" menu). The proprietary roland driver for Windows supports Enhanced MIDI. The linux usbmidi driver does not. Therefore, for linux, you must turn off Enhanced MIDI mode on your Fantom.

Also, for devices that can be loaded with waveforms (like the X), there are two modes. One is the USBMIDI standard. The other mode is USB Storage mode. The latter means your computer sees your X like a usb hard drive. Do you see a drive icon on your desktop labeled something like "ROLAND"? That drive icon should appear and disappear when you connect/disconnect the X, just like it's a usb drive. You can open that ROLAND drive icon, "drag" WAV (or AIFF, but not mp3, flac, or ogg) files from your computer drive, and "drop" them into that ROLAND folder. Your computer will transfer those files to the X (so the X can play them). It's just like working with a usb thumb drive. So that's how you move waves to and from your X.

But when you want to use the X for MIDI, you have to disconnect it, and switch it to "MIDI USB mode" (not Storage mode). Now when you reconnect the X, linux will no longer see it as a usb drive. (ie No drive icon appears on your desktop). Instead, linux/alsa will see it as a MIDi device.

Your manual tells how to enable/disable storage and enhanced modes. After changing a mode, you do need to then disconnect/reconnect the X from your computer's usb. Maybe even turn the X on/off.

If you see a roland icon appear on your desktop, you're in the wrong mode.

Stamper
Established Member
Posts: 5
Joined: Mon Jun 29, 2020 10:57 am

Re: No MIDI_IN for Linux from ROLAND FANTOM X - Help!

Post by Stamper »

thanks for the reply.

The storage mode works fine. Switching between storage and midi is fully understood, I have been using the FANTOM X8 on windows for many years.

As you can see from the screen shot, the FANTOM receives midi, but sending is set to red, and no messages are received.

If the FANTOM X8 has a midi enhanced mode, I know not of it, nor how to turn if off and on. (Other than the USB storage mode, that is understood). Can you please elaborate?

j_e_f_f_g
Established Member
Posts: 1063
Joined: Fri Aug 10, 2012 10:48 pm

Re: No MIDI_IN for Linux from ROLAND FANTOM X - Help!

Post by j_e_f_f_g »

Consult page 218 of your manual "Selecting MIDI Mode". Try saving the setting so the X8 powers up in this mode (instead of storage mode). Also, try changing the "MIDI Thru" setting. Perhaps it is on, and therefore alsa is detecting a potential "MIDI feedback loop", and thus compensating by disabling input.

Stamper
Established Member
Posts: 5
Joined: Mon Jun 29, 2020 10:57 am

Re: No MIDI_IN for Linux from ROLAND FANTOM X - Help!

Post by Stamper »

thanks for the suggestion, but the Fantom is already configured as you suggested anyway. USB mode is system write MIDI and MIDI Thru is OFF.

The fact that ALSA is reporting that MIDI in is not available (the red connection line in the screen shot) would mean that there is a config issue, or should be a log somewhere with an error reported (or that is what I hope). I just don't know where to look.

merlyn
Established Member
Posts: 640
Joined: Thu Oct 11, 2018 4:13 pm

Re: No MIDI_IN for Linux from ROLAND FANTOM X - Help!

Post by merlyn »

The tab you're looking at called 'ALSA' is ALSA MIDI. There's also JACK MIDI under the tab called 'MIDI'. To debug this I would first check if MIDI from the Fantom is getting into the computer using jack_midi_dump. Type

Code: Select all

$ jack_midi_dump
into a terminal and you'll see a JACK client called 'midi-monitor' in the MIDI tab. Try connecting the Fantom to that, and you'll see if MIDI is being received in the terminal window where you ran jack_midi_dump.

Stamper
Established Member
Posts: 5
Joined: Mon Jun 29, 2020 10:57 am

Re: No MIDI_IN for Linux from ROLAND FANTOM X - Help!

Post by Stamper »

thanks for the suggestion @merlyn

The jack_midi_dump does show in the JACK MIDI, but connecting the 2 midi-captures both connect red, and there is nothing to show in the terminal window when playing the FANTOM's keyboard. :(

Image

merlyn
Established Member
Posts: 640
Joined: Thu Oct 11, 2018 4:13 pm

Re: No MIDI_IN for Linux from ROLAND FANTOM X - Help!

Post by merlyn »

There's a setting on the Fantom 'soft through'. Try turning that off.

Until you figure out what's wrong a workaround would be to use a 5 pin DIN MIDI cable. You could go out of the Fantom into your other keyboard, and connect your other keyboard via USB.

Something you could try is making a bootable USB of AV Linux and seeing if it works there.

http://www.bandshed.net/avlinux/

j_e_f_f_g
Established Member
Posts: 1063
Joined: Fri Aug 10, 2012 10:48 pm

Re: No MIDI_IN for Linux from ROLAND FANTOM X - Help!

Post by j_e_f_f_g »

You don't have some "MIDI bridge software" installed, such as a2jmid, right? Because that will grab your midi ports away from ALSA.

Post Reply