Guitarix on a Raspberry Pi 2

Discussion of all things Raspberry Pi / Raspberry Pi 2 related

Moderators: khz, MattKingUSA

BruceR
Establlshed Member
Posts: 5
Joined: Sat Mar 04, 2017 8:45 pm

Re: Guitarix on a Raspberry Pi 2

Postby BruceR » Sun Mar 05, 2017 7:33 pm

Thanks, I'll convert that into a command line jack command and give it a go.
I'm just starting from scratch (again) trying DietPi.

User avatar
tramp
Establlshed Member
Posts: 803
Joined: Mon Jul 01, 2013 8:13 am

Re: Guitarix on a Raspberry Pi 2

Postby tramp » Mon Mar 06, 2017 7:50 am

Frank Carvalho wrote:I can share the setting I use, and they work. But as I use the dbus version of jack it might not be applicable in your situation.
Notice that, contrary to what I said above, it does start with realtime enabled. But I also have to start Jack externally before I start Guitarix, because it does not work when Guitarix starts jack. Two more things. I use 44.1kHz. 48kHz does not work for Guitarix, and I do not believe that it is just the fact that it processes 9% more instructions per time unit. The CPU is only moderately active. Even doubling the buffer size and latency etc, it still goes into some nasty digital distortion at 48kHz, even with no plugins activated. So for the time being I stick with 44.1kHz. Also, try "soft mode".

Jackd settings from ~/.config/jack/config.xml (which is used by jackdbus). My sound card is an M-Audio Quattro:

Code: Select all

<?xml version="1.0"?>
<!--
JACK settings, as persisted by D-Bus object.
You probably don't want to edit this because
it will be overwritten next time jackdbus saves.
-->
<!-- Thu Dec 15 23:13:07 2016 -->
<jack>
 <engine>
  <option name="driver">alsa</option>
  <option name="realtime">true</option>
  <option name="verbose">false</option>
  <option name="client-timeout">2000</option>
 </engine>
 <drivers>
  <driver name="loopback">
  </driver>
  <driver name="net">
  </driver>
  <driver name="dummy">
  </driver>
  <driver name="netone">
  </driver>
  <driver name="alsa">
   <option name="capture">hw:Quattro,0</option>
   <option name="playback">hw:Quattro,0</option>
   <option name="rate">44100</option>
   <option name="period">64</option>
   <option name="nperiods">3</option>
   <option name="hwmon">false</option>
   <option name="hwmeter">false</option>
   <option name="duplex">true</option>
   <option name="softmode">true</option>
   <option name="monitor">false</option>
   <option name="dither">n</option>
   <option name="inchannels">2</option>
   <option name="outchannels">2</option>
   <option name="shorts">false</option>
  </driver>
  <driver name="alsarawmidi">
  </driver>
 </drivers>
 <internals>
  <internal name="netmanager">
  </internal>
  <internal name="audioadapter">
  </internal>
  <internal name="profiler">
  </internal>
  <internal name="netadapter">
  </internal>
 </internals>
</jack>


/Frank


If you would start jack-dbus, you need to select "other" in the Jack Startup Control widget from guitarix, and enter the compand-line you use to start jack-dbus. Otherwise, guitarix always tries to use jackd without dbus.

The issue at 48Khz must be related to the hardware in use, as guitarix usually runs fine at 48Khz, in fact, it is developed on a machine running at 48Khz.

regards
hermann

Frank Carvalho
Establlshed Member
Posts: 290
Joined: Sat Nov 17, 2012 3:36 pm

Re: Guitarix on a Raspberry Pi 2

Postby Frank Carvalho » Mon Mar 06, 2017 9:59 am

It's possible. I always run 48kHz on my main machine, and never had any problems with Guitarix or any other sound software. I also run the sound card at 48kHz on a laptop I have, so the sound card should be allright too. So the issues must arise from the RPi itself and the software running on it, though I can not get any closer.

/Frank
Vox, Selmer, Yamaha and Leslie amplifiers. Rickenbacker, Epiphone, Ibanez, Washburn, Segovia, Yamaha and Fender guitars. Hammond, Moog, Roland, Korg, Yamaha, Crumar, Ensoniq and Mellotron keyboards. Xubuntu+KXStudio recording setup.

BruceR
Establlshed Member
Posts: 5
Joined: Sat Mar 04, 2017 8:45 pm

Re: Guitarix on a Raspberry Pi 2

Postby BruceR » Tue Mar 07, 2017 9:25 pm

Thanks for the help but annoyingly I'm still getting the same jackd error after a few minutes of playing.

Code: Select all

JACK server starting in realtime mode with priority 90
self-connect-mode is "Don't restrict self connect requests"
creating alsa driver ... hw:1,0|hw:0,0|512|3|44100|0|0|nomon|swmeter|-|32bit
configuring for 44100Hz, period = 512 frames (11.6 ms), buffer = 3 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 3 periods for capture
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 3 periods for playback
JackPosixProcessSync::LockedTimedWait error usec = 232180 err = Connection timed out
JackEngine::ClientDeactivate wait error ref = 2 name = gx_head_amp
JackPosixProcessSync::LockedTimedWait error usec = 232180 err = Connection timed out
JackEngine::ClientDeactivate wait error ref = 3 name = gx_head_fx
JackPosixProcessSync::LockedTimedWait error usec = 46436 err = Connection timed out
JackEngine::ClientCloseAux wait error ref = 2
JackPosixProcessSync::LockedTimedWait error usec = 46436 err = Connection timed out
JackEngine::ClientCloseAux wait error ref = 3


This has happened with my compiled version of jackd2 and the Raspbian apt version in exactly the same manner. It does not seem to matter what jack settings I use or if I use it in the GUI or not. The only bit that stays the same is alsa and the driver for the (cheap) C-Media USB guitar adaptor. Maybe I should go and buy a Behringer ucg102 or something else.

BruceR
Establlshed Member
Posts: 5
Joined: Sat Mar 04, 2017 8:45 pm

Re: Guitarix on a Raspberry Pi 2

Postby BruceR » Wed Mar 08, 2017 6:48 am

Scratch that, I've got it working. .. :D

In case anyone stumbles on this thread my current working jackd command line is

Code: Select all

/usr/local/bin/jackd -R -P 90 -d alsa -P hw:1,0 -C hw:0,0 -r 44100 -p 128 -n 3 -s


many thanks again for this thread and the individual help

Bruce

beacolyte
Posts: 1
Joined: Thu Mar 16, 2017 4:34 pm

Re: Guitarix on a Raspberry Pi 2

Postby beacolyte » Thu Mar 16, 2017 4:36 pm

are you still working on this Bruce? Are there any clips of these projects anywhere?

It seems like this is a fairly common project. I am looking for a budget Torpedo C.A.B. type box. Possible?

glowrak guy
Establlshed Member
Posts: 861
Joined: Sat Jun 21, 2014 8:37 pm

Re: Guitarix on a Raspberry Pi 2

Postby glowrak guy » Thu Mar 16, 2017 11:29 pm

BruceR wrote:Scratch that, I've got it working. .. :D

In case anyone stumbles on this thread my current working jackd command line is

Code: Select all

/usr/local/bin/jackd -R -P 90 -d alsa -P hw:1,0 -C hw:0,0 -r 44100 -p 128 -n 3 -s


many thanks again for this thread and the individual help

Bruce

I've always read that -P90 in .jackdrc or qjacktl gui is above the maximim allowed of 89,
and that 89 is only available when etc/security/limits.conf has it's own maximum priority setting of 99.

I mention this in case jackd sees P90 as out of range, and quietly
uses some lower default. Probably one of the devs can clarify this.
Cheers


Return to “Raspberry Pi”

Who is online

Users browsing this forum: RockHopper and 1 guest