gigedit 1.1.0 does not compile

Link to good samples/soundfonts at http://wiki.linuxaudio.org/wiki/free_audio_data

Moderators: khz, MattKingUSA

CG3D
Posts: 3
Joined: Sun Nov 05, 2017 9:36 am

gigedit 1.1.0 does not compile

Postby CG3D » Wed Dec 06, 2017 11:28 am

Hi,

I tried to compile gigedit 1.1.0 with GTK2 and GTK3 in Linux Mint XFCE 18.2. Both versions error out:

If I install libgtkmm-3.0-dev, libgtk-3-dev and libgtkmm-3.0-1v5, this error prevents me from compiling:

Code: Select all

regionchooser.cpp:30:25: fatal error: gdkmm/seat.h: No such file or directory


If I however install libgtkmm-2.4-dev, libgtk2.0-dev and libgtkmm-2.4-1v5, this error prevents me from compiling:

Code: Select all

wrapLabel.cc:69:27: error: ‘WORD_CHAR’ is not a member of ‘Pango::WrapMode’


Any help to get gigedit 1.1.0 to compile would be highly appreciated...?

p.s. I tried to search the forum for 'compile gegedit' to see if anyone had already mentioned this issue but it returned an error saying:

The following words in your search query were ignored because they are too common words: compile gigedit.
You must specify at least one word to search for. Each word must consist of at least 3 characters and must not contain more than 14 characters excluding wildcards.


So, sorry if this question has been asked before. :)

Thanx in advance and greetings,

CG3D

User avatar
davephillips
Establlshed Member
Posts: 391
Joined: Sat Aug 15, 2015 1:05 pm

Re: gigedit 1.1.0 does not compile

Postby davephillips » Wed Dec 06, 2017 12:22 pm

Greetings,

I hit the same problem. I think you'll need to update your distro. In my case I definitely have to update, Fedora 23 does not support the required version of gdkmm.

Best,

dp

CG3D
Posts: 3
Joined: Sun Nov 05, 2017 9:36 am

Re: gigedit 1.1.0 does not compile

Postby CG3D » Wed Dec 06, 2017 1:32 pm

Hi Dave,

Thanx for your reply :).

Linux Mint XFCE 18.2 is the latest stable release, so I cannot upgrade until 18.3 is released. It is however based on Ubuntu 16.04 so maybe is has a somewhat older version of gdkmm in the repository...?

I will try to compile in LM XFCE 18.3 beta (or Ubuntu 17.10 if needed). I'll let you know if that works!

Thanx again and greetings,

CG3D


Return to “Samplers & samples”

Who is online

Users browsing this forum: No registered users and 5 guests