Problem while mixing using LSP Sampler Mono

Link to good samples/soundfonts at http://wiki.linuxaudio.org/wiki/free_audio_data

Moderators: khz, MattKingUSA

Post Reply
User avatar
Fatima
Established Member
Posts: 44
Joined: Sat Aug 13, 2016 11:45 pm
Location: Montevideo, Uruguay
Has thanked: 1 time
Contact:

Problem while mixing using LSP Sampler Mono

Post by Fatima »

Hi people,
I am creating a song where I am using:
+ some tracks with the Yoshimi plug-in
+ some tracks with LSP Sampler Mono

Mostly everything runs fine, but I cannot seem to control the volume for LSP Sampler Mono.
Neither with the Mixer screen nor the fade out in a short MIDI clip that I use at the beginning.

Any hints will be highly appreciated.
All the best,
Fatima
porzione
Established Member
Posts: 18
Joined: Sat Dec 12, 2020 7:46 am
Location: Cyprus
Has thanked: 1 time
Been thanked: 3 times

Re: Problem while mixing using LSP Sampler Mono

Post by porzione »

Hi
I'm using LSP sampler (mostly multichannel direct out) in Reaper and the only way to disable volume control in master is to route LSP track outputs to another track and disable "master send", but it depends on your DAW. Anyway you should check properties of track with sampler.
What do you see on master level meters on LSP track during the play?
User avatar
Fatima
Established Member
Posts: 44
Joined: Sat Aug 13, 2016 11:45 pm
Location: Montevideo, Uruguay
Has thanked: 1 time
Contact:

Re: Problem while mixing using LSP Sampler Mono

Post by Fatima »

Hi @porzione ,
thank you for your kind answer.
I am using Qtractor, sorry, I forgot to mention, my bad.

I got 4 tracks running Yoshimi, on those I can control the mixing with no trouble.

I got other 3 tracks running LSP Sampler Mono, on those I cannot seem to control the mixing.
If I open the Qtractor Mixer and I play with the volume sliders on the LSP Sampler Mono tracks, the level meters behave as if I was controlling the mixing (i.e., if I go down completely they get smaller until the yellow dancing bar disappears). But the volume does not got up or down with the slider.
In one of the LSP Sampler Mono tracks, I programmed a fade-out for a sound clip using the graphic tool, and it does not work either.

In every case, the master volume slider works perfectly, and it controls the volume for all channels.

Any hint will be greatly appreciated.
All the best,
Fatima
porzione
Established Member
Posts: 18
Joined: Sat Dec 12, 2020 7:46 am
Location: Cyprus
Has thanked: 1 time
Been thanked: 3 times

Re: Problem while mixing using LSP Sampler Mono

Post by porzione »

I tried LSP and other plugins but seems it is impossible, if I understand correctly there is no simple way to achieve this without additional plugins and wiring viewtopic.php?t=13379
Qtractor just can't mix and pan MIDI tracks outs in master mixer. If it was me then I would rather deal with Ardour ;)
User avatar
Fatima
Established Member
Posts: 44
Joined: Sat Aug 13, 2016 11:45 pm
Location: Montevideo, Uruguay
Has thanked: 1 time
Contact:

Re: Problem while mixing using LSP Sampler Mono

Post by Fatima »

Hey @porzione thank you very much.
Now I understand the issue, will try to configure a solution using LADSPA
User avatar
sadko4u
Established Member
Posts: 866
Joined: Mon Sep 28, 2015 9:03 pm
Been thanked: 39 times

Re: Problem while mixing using LSP Sampler Mono

Post by sadko4u »

Could you please describe your workflow?
Looks like a new feature for LSP sampler that should be implemented.
The ideal case would be if you describe it as a separate ticket on GitHub: https://github.com/sadko4u/lsp-plugins/issues
If you describe your workflow and actual and desired results, it is possible to add such feature to LSP Sampler after releasing 1.2.0.
LSP (Linux Studio Plugins) Developer and Maintainer.
Post Reply