Can't execute fluidsynth with a soundfont from a script

All your LV2 and LADSPA goodness and more.

Moderators: khz, MattKingUSA

Post Reply
yama
Established Member
Posts: 32
Joined: Tue Dec 27, 2016 10:00 pm

Can't execute fluidsynth with a soundfont from a script

Post by yama »

Doing

Code: Select all

fluidsynth -a jack -j ~/soundfonts/KawaiUprightPiano-20180102.sf2
directly from terminal works as intended, however, putting the exact same line within a bash script results in:
Parameter '~/soundfonts/KawaiUprightPiano-20180102.sf2' not a SoundFont or MIDI file or error occurred identifying it.
Which is evidently wrong since I can load that file directly with terminal.

EDIT: Doing some testing, this works with `xterm`. It does not work with termite, st, or urxvt.

yama
Established Member
Posts: 32
Joined: Tue Dec 27, 2016 10:00 pm

Re: Can't execute fluidsynth with a soundfont from a script

Post by yama »

Well I feel dumb now, solution was to use $HOME instead of ~

User avatar
milo
Established Member
Posts: 745
Joined: Wed Sep 06, 2017 2:55 am
Location: Southern Utah, USA
Contact:

Re: Can't execute fluidsynth with a soundfont from a script

Post by milo »

Don't worry, mate. We all do stupid things in shell scripts from time to time. Just be glad you didn't erase all the files in your home directory. You're always ahead of the game on days when you avoid that error! :)

User avatar
Linuxmusician01
Established Member
Posts: 705
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Can't execute fluidsynth with a soundfont from a script

Post by Linuxmusician01 »

yama wrote:Well I feel dumb now, solution was to use $HOME instead of ~
Thanks for the post. This would be a mistake that I could have made after writing simple shell scripts for myself for almost 15 years. :mrgreen:

yama
Established Member
Posts: 32
Joined: Tue Dec 27, 2016 10:00 pm

Re: Can't execute fluidsynth with a soundfont from a script

Post by yama »

ty for making me feel less dumb about it :)

Post Reply