Problem when I load plugins NadIr and Emissary with linvst

All your LV2 and LADSPA goodness and more.

Moderators: khz, MattKingUSA

pedrobotero
Established Member
Posts: 19
Joined: Thu Oct 18, 2018 10:08 pm

Problem when I load plugins NadIr and Emissary with linvst

Postby pedrobotero » Mon Jun 17, 2019 9:42 am

Hi everyone,

When I load the windows plugins NAdIR and Emissary on Reaper linux version (too Carla) they load with black background and they don't load with their graphic interface.

I used LinVst-2.5 to convert this plugins.

With lepoul plugins this doesn't happen and they load correctly.

Can anybody help me?

thanks so much and sorry for my english :-D

Regards
Last edited by pedrobotero on Mon Jun 17, 2019 7:25 pm, edited 1 time in total.

User avatar
Linuxmusician01
Established Member
Posts: 648
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Problem when I load plugins NadIr and Emissary

Postby Linuxmusician01 » Mon Jun 17, 2019 10:40 am

If you use Carla then you do not need to "convert" (i.e. bridge) the plugins w/ LinVST. One uses one or the other. Maybe the plugins from the Emissary company do not work in Linux. Try to load them in Carla without Reaper and see what happens. Tip: a screenshot may come in handy. :wink:

pedrobotero
Established Member
Posts: 19
Joined: Thu Oct 18, 2018 10:08 pm

Re: Problem when I load plugins NadIr and Emissary

Postby pedrobotero » Mon Jun 17, 2019 10:56 am

Linuxmusician01 wrote:If you use Carla then you do not need to "convert" (i.e. bridge) the plugins w/ LinVST. One uses one or the other. Maybe the plugins from the Emissary company do not work in Linux. Try to load them in Carla without Reaper and see what happens. Tip: a screenshot may come in handy. :wink:


I tested them in my previous installation (ubuntustudio 19.04) y they loaded correctly but now in ubuntu 19.04 they don't load well.

I can't attach a screenshot right now :-(

Regards

User avatar
Linuxmusician01
Established Member
Posts: 648
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Problem when I load plugins NadIr and Emissary

Postby Linuxmusician01 » Mon Jun 17, 2019 11:50 am

pedrobotero wrote:
Linuxmusician01 wrote:If you use Carla then you do not need to "convert" (i.e. bridge) the plugins w/ LinVST. One uses one or the other. Maybe the plugins from the Emissary company do not work in Linux. Try to load them in Carla without Reaper and see what happens. Tip: a screenshot may come in handy. :wink:


I tested them in my previous installation (ubuntustudio 19.04) y they loaded correctly but now in ubuntu 19.04 they don't load well.

I can't attach a screenshot right now :-(

Regards

Are you using the KXStudio repository to install Carla from? See https://kx.studio/Repositories

pedrobotero
Established Member
Posts: 19
Joined: Thu Oct 18, 2018 10:08 pm

Re: Problem when I load plugins NadIr and Emissary

Postby pedrobotero » Mon Jun 17, 2019 11:56 am

Linuxmusician01 wrote:
pedrobotero wrote:
Linuxmusician01 wrote:If you use Carla then you do not need to "convert" (i.e. bridge) the plugins w/ LinVST. One uses one or the other. Maybe the plugins from the Emissary company do not work in Linux. Try to load them in Carla without Reaper and see what happens. Tip: a screenshot may come in handy. :wink:


I tested them in my previous installation (ubuntustudio 19.04) y they loaded correctly but now in ubuntu 19.04 they don't load well.

I can't attach a screenshot right now :-(

Regards

Are you using the KXStudio repository to install Carla from? See https://kx.studio/Repositories


I have installed the kxstudio repositories, I think that I have install carla of these repositories but now I can't look it

User avatar
lilith
Established Member
Posts: 1033
Joined: Fri May 27, 2016 11:41 pm
Location: bLACK fOREST
Contact:

Re: Problem when I load plugins NadIr and Emissary

Postby lilith » Mon Jun 17, 2019 12:40 pm

Is kxstudio working with Ubuntu 19??
https://soundcloud.com/lilith_93
latest: https://soundcloud.com/lilith_93/days-of-terror
_____________________________
Debian 9 (XFCE) & KXStudio repos

pedrobotero
Established Member
Posts: 19
Joined: Thu Oct 18, 2018 10:08 pm

Re: Problem when I load plugins NadIr and Emissary

Postby pedrobotero » Mon Jun 17, 2019 12:46 pm

lilith wrote:Is kxstudio working with Ubuntu 19??


Yes, I installed kxstudio repos
You do not have the required permissions to view the files attached to this post.

User avatar
Linuxmusician01
Established Member
Posts: 648
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Problem when I load plugins NadIr and Emissary

Postby Linuxmusician01 » Mon Jun 17, 2019 6:58 pm

Can you determine the Carla version that you installed/use? I can choose between 2 versions (both from KXStudio): Carla (ver. 2:2.0.0+git) or Carla-git (ver. 2:2.1~alpha). The one I've got installed is the Alpha.

User avatar
sysrqer
Established Member
Posts: 1823
Joined: Thu Nov 14, 2013 11:47 pm
Contact:

Re: Problem when I load plugins NadIr and Emissary

Postby sysrqer » Mon Jun 17, 2019 7:07 pm

There might be a fix for the black screen, I've had that with the odd plugin too but I have seen people suggest dll overrides and stuff on here to make some plugins work. The author of linvst posts here so they might be best to get an answer from. Maybe rename this thread and include linvst in the title. I don't remember the username, it's something like ubuntuser.

You can use wine-staging directly from a ppa from wine to make sure you have the newest version - at least I think you can with mint?

User avatar
Linuxmusician01
Established Member
Posts: 648
Joined: Mon Feb 23, 2015 2:38 pm
Location: Holland

Re: Problem when I load plugins NadIr and Emissary

Postby Linuxmusician01 » Mon Jun 17, 2019 7:39 pm

sysrqer wrote:[...] You can use wine-staging directly from a ppa from wine to make sure you have the newest version - at least I think you can with mint?

There's no Wine staging in Ubuntu/Mint.

tavasti
Established Member
Posts: 832
Joined: Tue Feb 16, 2016 6:56 am
Location: Kangasala, Finland
Contact:

Re: Problem when I load plugins NadIr and Emissary

Postby tavasti » Mon Jun 17, 2019 8:12 pm

Linuxmusician01 wrote:
sysrqer wrote:[...] You can use wine-staging directly from a ppa from wine to make sure you have the newest version - at least I think you can with mint?

There's no Wine staging in Ubuntu/Mint.

Wine staging is from winehq for all distros.
Linux veteran & Novice musician

Hear my music at https://audiu.net/users/tawaste

jonetsu
Established Member
Posts: 1439
Joined: Sat Jun 11, 2016 12:05 am

Re: Problem when I load plugins NadIr and Emissary with linvst

Postby jonetsu » Mon Jun 17, 2019 8:30 pm

I'd give Emissary a try (never heard of those plugins before) but they don't seem to have any demo.

By the way, there's a section of Linux Musicians dedicated to running non-linux software.

pedrobotero
Established Member
Posts: 19
Joined: Thu Oct 18, 2018 10:08 pm

Re: Problem when I load plugins NadIr and Emissary with linvst

Postby pedrobotero » Mon Jun 17, 2019 8:58 pm

jonetsu wrote:I'd give Emissary a try (never heard of those plugins before) but they don't seem to have any demo.

By the way, there's a section of Linux Musicians dedicated to running non-linux software.


link to download Emissary, NadIR and Lepoul plugins

[link removed by moderator] - are you sure you are allowed to redistribute those?
[link removed by moderator again] - please don't share copyrighted material via this forum without the appropriate license.

jonetsu
Established Member
Posts: 1439
Joined: Sat Jun 11, 2016 12:05 am

Re: Problem when I load plugins NadIr and Emissary with linvst

Postby jonetsu » Mon Jun 17, 2019 11:05 pm

pedrobotero wrote: link to download Emissary, NadIR and Lepoul plugins


I gave Emissary a quick try, on a Spectral synth track in Bitwig:


test.jpg



What I did:

1) Copy Emissary.dll to the plugins test folder
2) Copy the linvst.so adapter there renamed as Emissary.so
3) Start Bitwig, load synth track, add Emissary

Looks like it's working fine. I use wine-4.5 (Staging) and linvst from git (January 2019) on Xubuntu 18.04 with Bitwig 2.4.3.

I'm not impressed by this plugin though. Turning many knobs produces not much variations at all, and the quality of distortion is very low. This is a plugin I certainly will not use.

But it works.
You do not have the required permissions to view the files attached to this post.

glowrak guy
Established Member
Posts: 1352
Joined: Sat Jun 21, 2014 8:37 pm

Re: Problem when I load plugins NadIr and Emissary with linvst

Postby glowrak guy » Tue Jun 18, 2019 3:26 am

Emissary is split, having Clean and Lead channels, turn all knobs,
and the Channel switch, to the left.
Bring the Clean Master knob up to 75%
then, in this order, bring up the gain,
mids, treble, and bass to 60%, and adjust to taste

Now turn all those knobs down, flip the Channel switch
to Lead, bring up the lead master to 50%
and the others to 40%, and adjust to taste.

I use it in linux Reaper via linvst 2.5 with nvidia 9400 GT pcie card,
and Nouveau video driver.
Cheers


Return to “Plugins, Effects and Instruments”

Who is online

Users browsing this forum: No registered users and 1 guest